summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--x11-misc/root-portal/ChangeLog6
-rw-r--r--x11-misc/root-portal/files/digest-root-portal-0.5.22
-rw-r--r--x11-misc/root-portal/files/root-portal-0.5.2-gcc4.patch11
-rw-r--r--x11-misc/root-portal/root-portal-0.5.2.ebuild12
4 files changed, 29 insertions, 2 deletions
diff --git a/x11-misc/root-portal/ChangeLog b/x11-misc/root-portal/ChangeLog
index 0088f00db99a..5ba5c114870f 100644
--- a/x11-misc/root-portal/ChangeLog
+++ b/x11-misc/root-portal/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for x11-misc/root-portal
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/root-portal/ChangeLog,v 1.21 2006/01/21 12:15:43 nelchael Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/root-portal/ChangeLog,v 1.22 2006/09/21 11:57:58 nelchael Exp $
+
+ 21 Sep 2006; Krzysiek Pawlik <nelchael@gentoo.org>
+ +files/root-portal-0.5.2-gcc4.patch, root-portal-0.5.2.ebuild:
+ Add patch to fix compilation with GCC 4. See bug #146185.
21 Jan 2006; Krzysiek Pawlik <nelchael@gentoo.org>
-files/0.4.11-gcc3.patch, -root-portal-0.5.0.ebuild,
diff --git a/x11-misc/root-portal/files/digest-root-portal-0.5.2 b/x11-misc/root-portal/files/digest-root-portal-0.5.2
index 616001da80a8..8c82ad0afbad 100644
--- a/x11-misc/root-portal/files/digest-root-portal-0.5.2
+++ b/x11-misc/root-portal/files/digest-root-portal-0.5.2
@@ -1 +1,3 @@
MD5 dd169a5e2149c1c87f764c93851cdf0c root-portal-0.5.2.tar.gz 429754
+RMD160 005a296a71fa5efd4949fde2e4ab6179e80beab5 root-portal-0.5.2.tar.gz 429754
+SHA256 1460f8c474ecb11d6564009f3ab6fb5d9b8aa5cfbbedba3bac79946208e8119a root-portal-0.5.2.tar.gz 429754
diff --git a/x11-misc/root-portal/files/root-portal-0.5.2-gcc4.patch b/x11-misc/root-portal/files/root-portal-0.5.2-gcc4.patch
new file mode 100644
index 000000000000..e423c745f4bb
--- /dev/null
+++ b/x11-misc/root-portal/files/root-portal-0.5.2-gcc4.patch
@@ -0,0 +1,11 @@
+--- ./src/modules/process/process.h~ 2006-03-22 01:55:50.000000000 +0000
++++ ./src/modules/process/process.h 2006-03-22 01:55:55.000000000 +0000
+@@ -56,7 +56,7 @@
+ virtual void close(const string& timestamp, int pid, const string& processName) {};
+
+ protected:
+- void Procchange::updated(const string& keyName, const DataSet& data);
++ void updated(const string& keyName, const DataSet& data);
+ DataSet format;
+ };
+
diff --git a/x11-misc/root-portal/root-portal-0.5.2.ebuild b/x11-misc/root-portal/root-portal-0.5.2.ebuild
index f6650c707986..8dc13658e82f 100644
--- a/x11-misc/root-portal/root-portal-0.5.2.ebuild
+++ b/x11-misc/root-portal/root-portal-0.5.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/root-portal/root-portal-0.5.2.ebuild,v 1.5 2006/01/21 12:15:43 nelchael Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/root-portal/root-portal-0.5.2.ebuild,v 1.6 2006/09/21 11:57:58 nelchael Exp $
inherit gnome2 debug
@@ -24,7 +24,17 @@ DEPEND="${RDEPEND}
app-text/scrollkeeper
dev-util/pkgconfig"
+src_unpack() {
+
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/${P}-gcc4.patch"
+
+}
+
src_install() {
+
# stupid sandboxing
einstall || die "einstall failed"
+
}