summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--mail-mta/opensmtpd/ChangeLog9
-rw-r--r--mail-mta/opensmtpd/files/smtpd.initd6
-rw-r--r--mail-mta/opensmtpd/opensmtpd-5.7.1_p1-r1.ebuild93
3 files changed, 104 insertions, 4 deletions
diff --git a/mail-mta/opensmtpd/ChangeLog b/mail-mta/opensmtpd/ChangeLog
index 0ecec897052b..b110dbb03cbc 100644
--- a/mail-mta/opensmtpd/ChangeLog
+++ b/mail-mta/opensmtpd/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for mail-mta/opensmtpd
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/mail-mta/opensmtpd/ChangeLog,v 1.76 2015/07/02 12:19:41 zx2c4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-mta/opensmtpd/ChangeLog,v 1.77 2015/07/18 11:33:58 pinkbyte Exp $
+
+*opensmtpd-5.7.1_p1-r1 (18 Jul 2015)
+
+ 18 Jul 2015; Sergey Popov <pinkbyte@gentoo.org>
+ +opensmtpd-5.7.1_p1-r1.ebuild, files/smtpd.initd:
+ Revision bump: add missing configure option for building with BerkDB support,
+ bug #554654. Put socket and PID files into /run, instead of /var/run
02 Jul 2015; Jason A. Donenfeld <zx2c4@gentoo.org>
-files/opensmtpd-5.4.5_p2-libevent-version-macro.patch,
diff --git a/mail-mta/opensmtpd/files/smtpd.initd b/mail-mta/opensmtpd/files/smtpd.initd
index 50a200d9c7f4..b4daf6a3c35c 100644
--- a/mail-mta/opensmtpd/files/smtpd.initd
+++ b/mail-mta/opensmtpd/files/smtpd.initd
@@ -1,10 +1,10 @@
#!/sbin/runscript
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/mail-mta/opensmtpd/files/smtpd.initd,v 1.3 2013/11/20 05:16:56 zx2c4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-mta/opensmtpd/files/smtpd.initd,v 1.4 2015/07/18 11:33:58 pinkbyte Exp $
command="smtpd"
-start_stop_daemon_args="--pidfile=/var/run/smtpd.pid"
+start_stop_daemon_args="--pidfile=/run/smtpd.pid"
description="SMTP daemon from OpenBSD"
depend() {
diff --git a/mail-mta/opensmtpd/opensmtpd-5.7.1_p1-r1.ebuild b/mail-mta/opensmtpd/opensmtpd-5.7.1_p1-r1.ebuild
new file mode 100644
index 000000000000..a6a4e6dcdc48
--- /dev/null
+++ b/mail-mta/opensmtpd/opensmtpd-5.7.1_p1-r1.ebuild
@@ -0,0 +1,93 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/mail-mta/opensmtpd/opensmtpd-5.7.1_p1-r1.ebuild,v 1.1 2015/07/18 11:33:58 pinkbyte Exp $
+
+EAPI=5
+
+inherit multilib user flag-o-matic eutils pam toolchain-funcs autotools systemd versionator
+
+DESCRIPTION="Lightweight but featured SMTP daemon from OpenBSD"
+HOMEPAGE="http://www.opensmtpd.org/"
+MY_P="${P}"
+if [ $(get_last_version_component_index) -eq 4 ]; then
+ MY_P="${PN}-$(get_version_component_range 4-)"
+fi
+SRC_URI="https://www.opensmtpd.org/archives/${MY_P/_}.tar.gz"
+
+LICENSE="ISC BSD BSD-1 BSD-2 BSD-4"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="pam +mta"
+
+DEPEND="dev-libs/openssl:0
+ sys-libs/zlib
+ pam? ( virtual/pam )
+ sys-libs/db:=
+ dev-libs/libevent
+ app-misc/ca-certificates
+ net-mail/mailbase
+ net-libs/libasr
+ !mail-mta/courier
+ !mail-mta/esmtp
+ !mail-mta/exim
+ !mail-mta/mini-qmail
+ !mail-mta/msmtp[mta]
+ !mail-mta/netqmail
+ !mail-mta/nullmailer
+ !mail-mta/postfix
+ !mail-mta/qmail-ldap
+ !mail-mta/sendmail
+ !mail-mta/ssmtp[mta]
+"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/${MY_P/_}
+
+src_prepare() {
+ # Use /run instead of /var/run
+ sed -i -e '/pidfile_path/s:_PATH_VARRUN:"/run/":' openbsd-compat/pidfile.c || die
+
+ epatch_user
+ eautoreconf
+}
+
+src_configure() {
+ tc-export AR
+ AR="$(which "$AR")" econf \
+ --enable-table-db \
+ --with-privsep-user=smtpd \
+ --with-queue-user=smtpq \
+ --with-privsep-path=/var/empty \
+ --with-sock-dir=/run \
+ --sysconfdir=/etc/opensmtpd \
+ --with-ca-file=/etc/ssl/certs/ca-certificates.crt \
+ $(use_with pam)
+}
+
+src_install() {
+ default
+ newinitd "${FILESDIR}"/smtpd.initd smtpd
+ systemd_dounit "${FILESDIR}"/smtpd.{service,socket}
+ use pam && newpamd "${FILESDIR}"/smtpd.pam smtpd
+ if use mta ; then
+ dodir /usr/sbin
+ dosym /usr/sbin/smtpctl /usr/sbin/sendmail
+ dosym /usr/sbin/smtpctl /usr/bin/sendmail
+ dosym /usr/sbin/smtpctl /usr/$(get_libdir)/sendmail
+ fi
+}
+
+pkg_preinst() {
+ enewgroup smtpd 25
+ enewuser smtpd 25 -1 /var/empty smtpd
+ enewgroup smtpq 252
+ enewuser smtpq 252 -1 /var/empty smtpq
+}
+
+pkg_postinst() {
+ einfo
+ einfo "Plugins for SQLite, MySQL, PostgreSQL, LDAP, socketmaps,"
+ einfo "Redis, and many other useful addons and filters are"
+ einfo "available in the mail-filter/opensmtpd-extras package."
+ einfo
+}