summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sci-electronics/vbs/ChangeLog7
-rw-r--r--sci-electronics/vbs/files/vbs-1.4.0-gcc-4.1.patch111
-rw-r--r--sci-electronics/vbs/files/vbs-gcc-3.4.patch44
-rw-r--r--sci-electronics/vbs/vbs-1.4.0.ebuild26
4 files changed, 129 insertions, 59 deletions
diff --git a/sci-electronics/vbs/ChangeLog b/sci-electronics/vbs/ChangeLog
index bcac819275fd..4c34adc77f4d 100644
--- a/sci-electronics/vbs/ChangeLog
+++ b/sci-electronics/vbs/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-electronics/vbs
# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-electronics/vbs/ChangeLog,v 1.5 2007/02/21 18:57:34 calchan Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-electronics/vbs/ChangeLog,v 1.6 2007/03/09 22:34:48 calchan Exp $
+
+ 09 Mar 2007; Denis Dupeyron <calchan@gentoo.org>
+ +files/vbs-1.4.0-gcc-4.1.patch, -files/vbs-gcc-3.4.patch,
+ vbs-1.4.0.ebuild:
+ Cleanups and gcc 4.1 compatibility fixes.
21 Feb 2007; Denis Dupeyron <calchan@gentoo.org> files/digest-vbs-1.4.0,
Manifest:
diff --git a/sci-electronics/vbs/files/vbs-1.4.0-gcc-4.1.patch b/sci-electronics/vbs/files/vbs-1.4.0-gcc-4.1.patch
new file mode 100644
index 000000000000..20f2aadb7e6e
--- /dev/null
+++ b/sci-electronics/vbs/files/vbs-1.4.0-gcc-4.1.patch
@@ -0,0 +1,111 @@
+diff -ur vbs-1.4.0.orig/src/common/bvector.h vbs-1.4.0/src/common/bvector.h
+--- vbs-1.4.0.orig/src/common/bvector.h 2003-01-12 05:40:59.000000000 +0100
++++ vbs-1.4.0/src/common/bvector.h 2007-03-09 22:40:02.000000000 +0100
+@@ -90,9 +90,9 @@
+ size_type _size; // Size of this sub-bit vector.
+
+ // Only bit_vector can create a sub_bit_vector object.
++ public:
+ sub_bit_vector(bit_vector &, const position_type, const position_type);
+ sub_bit_vector(const sub_bit_vector &);
+- public:
+ sub_bit_vector &operator=(const sub_bit_vector &);
+ sub_bit_vector &operator=(const const_sub_bit_vector &);
+ sub_bit_vector &operator=(const bit_vector &);
+@@ -116,8 +116,8 @@
+
+ // Only bit_vector can create a sub_bit_vector object.
+ const_sub_bit_vector(const bit_vector &, const position_type, const position_type);
+- const_sub_bit_vector(const const_sub_bit_vector &);
+ public:
++ const_sub_bit_vector(const const_sub_bit_vector &);
+ size_type size() const
+ { return _size; }
+ ostream_type &info(ostream_type &) const;
+diff -ur vbs-1.4.0.orig/src/common/logic.h vbs-1.4.0/src/common/logic.h
+--- vbs-1.4.0.orig/src/common/logic.h 2002-10-21 11:01:02.000000000 +0200
++++ vbs-1.4.0/src/common/logic.h 2007-03-09 22:40:02.000000000 +0100
+@@ -44,6 +44,10 @@
+ { return (_state == HI) ? true : false; }
+ operator int() const
+ { return _state; }
++
++ operator long int() const
++ { return _state; }
++
+ operator char() const
+ {
+ switch (_state)
+diff -ur vbs-1.4.0.orig/src/common/st_net.h vbs-1.4.0/src/common/st_net.h
+--- vbs-1.4.0.orig/src/common/st_net.h 2002-11-24 03:07:00.000000000 +0100
++++ vbs-1.4.0/src/common/st_net.h 2007-03-09 22:40:02.000000000 +0100
+@@ -133,4 +133,7 @@
+ const st_net &_net;
+ };
+
++void entry_iovars(st_net::io_list &, st_net::arg_list &);
++void exit_iovars(st_net::io_list &, st_net::arg_list &);
++
+ #endif // _ST_NET_H
+diff -ur vbs-1.4.0.orig/src/expr/erdwr.cc vbs-1.4.0/src/expr/erdwr.cc
+--- vbs-1.4.0.orig/src/expr/erdwr.cc 2002-05-28 08:22:46.000000000 +0200
++++ vbs-1.4.0/src/expr/erdwr.cc 2007-03-09 22:40:02.000000000 +0100
+@@ -25,8 +25,9 @@
+ expr_base *
+ read_expr::operator()() const
+ {
+- VBSOBJ_EXPR_TYPE type;
+- _in >> (int &) type;
++ int type_num = 0;
++ _in >> type_num;
++ VBSOBJ_EXPR_TYPE type = VBSOBJ_EXPR_TYPE(type_num);
+ long ln;
+ _in >> ln;
+ expr_base *expr = 0;
+diff -ur vbs-1.4.0.orig/src/Makefile.in vbs-1.4.0/src/Makefile.in
+--- vbs-1.4.0.orig/src/Makefile.in 2003-06-08 00:38:24.000000000 +0200
++++ vbs-1.4.0/src/Makefile.in 2007-03-09 22:40:02.000000000 +0100
+@@ -329,13 +329,15 @@
+ rm -f *.o
+ rm -f *.a
+ rm -f *.so
++ rm -f vbs
+
+ clean-repo:
+ if test -d ptrepository; then rm -rf ptrepository; fi
+ rm -f *.rpo
+
+ install:
+- $(INSTALL) vbs $(bindir)
++ $(INSTALL) -d $(DESTDIR)$(bindir)
++ $(INSTALL) vbs $(DESTDIR)$(bindir)
+
+ tarball:
+ @echo "===== Tar ball ======"
+diff -ur vbs-1.4.0.orig/src/misc/mrdwr.cc vbs-1.4.0/src/misc/mrdwr.cc
+--- vbs-1.4.0.orig/src/misc/mrdwr.cc 2002-05-28 11:42:00.000000000 +0200
++++ vbs-1.4.0/src/misc/mrdwr.cc 2007-03-09 22:40:02.000000000 +0100
+@@ -21,8 +21,9 @@
+ module *
+ read_module::operator()() const
+ {
+- VBSOBJ_MISC_TYPE type;
+- _in >> (int &) type;
++ int type_num = 0;
++ _in >> type_num;
++ VBSOBJ_MISC_TYPE type = VBSOBJ_MISC_TYPE(type_num);
+ if (type != VBSOBJ_MISC_MODULE)
+ {
+ vbs_err.set_data(vbs_error::SE_VBSOBJ, -1);
+@@ -129,8 +130,9 @@
+ port *
+ read_port::operator()() const
+ {
+- VBSOBJ_MISC_TYPE type;
+- _in >> (int &) type;
++ int type_num = 0;
++ _in >> type_num;
++ VBSOBJ_MISC_TYPE type = VBSOBJ_MISC_TYPE(type_num);
+ if (type != VBSOBJ_MISC_PORT)
+ {
+ vbs_err.set_data(vbs_error::SE_VBSOBJ, -1);
diff --git a/sci-electronics/vbs/files/vbs-gcc-3.4.patch b/sci-electronics/vbs/files/vbs-gcc-3.4.patch
deleted file mode 100644
index 9ee5b1af06fd..000000000000
--- a/sci-electronics/vbs/files/vbs-gcc-3.4.patch
+++ /dev/null
@@ -1,44 +0,0 @@
---- src/common/bvector.h 2003-01-12 04:40:59.000000000 +0000
-+++ src/common/bvector.h 2004-10-03 18:19:38.364060736 +0100
-@@ -88,10 +88,6 @@
- position_type _begin; // Starting position.
- position_type _end; // Stopping position.
- size_type _size; // Size of this sub-bit vector.
--
-- // Only bit_vector can create a sub_bit_vector object.
-- sub_bit_vector(bit_vector &, const position_type, const position_type);
-- sub_bit_vector(const sub_bit_vector &);
- public:
- sub_bit_vector &operator=(const sub_bit_vector &);
- sub_bit_vector &operator=(const const_sub_bit_vector &);
-@@ -100,6 +96,10 @@
- { return _size; }
- ostream_type &info(ostream_type &) const;
-
-+ // Only bit_vector can create a sub_bit_vector object.
-+ sub_bit_vector(bit_vector &, const position_type, const position_type);
-+ sub_bit_vector(const sub_bit_vector &);
-+
- // We don't need any other method, yet!
- };
- class const_sub_bit_vector
-@@ -113,15 +113,15 @@
- position_type _begin; // Starting position.
- position_type _end; // Stopping position.
- size_type _size; // Size of this sub-bit vector.
--
-- // Only bit_vector can create a sub_bit_vector object.
-- const_sub_bit_vector(const bit_vector &, const position_type, const position_type);
-- const_sub_bit_vector(const const_sub_bit_vector &);
- public:
- size_type size() const
- { return _size; }
- ostream_type &info(ostream_type &) const;
-
-+ // Only bit_vector can create a sub_bit_vector object.
-+ const_sub_bit_vector(const bit_vector &, const position_type, const position_type);
-+ const_sub_bit_vector(const const_sub_bit_vector &);
-+
- // We don't need any other method, yet!
- };
-
diff --git a/sci-electronics/vbs/vbs-1.4.0.ebuild b/sci-electronics/vbs/vbs-1.4.0.ebuild
index f51635073266..d7cf0e3a5a9a 100644
--- a/sci-electronics/vbs/vbs-1.4.0.ebuild
+++ b/sci-electronics/vbs/vbs-1.4.0.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2005 Gentoo Foundation and Tim Yamin <plasmaroo@gentoo.org> <plasmaroo@squirrelsoft.org.uk>
+# Copyright 1999-2007 Gentoo Foundation and Tim Yamin <plasmaroo@gentoo.org> <plasmaroo@squirrelsoft.org.uk>
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-electronics/vbs/vbs-1.4.0.ebuild,v 1.2 2005/05/17 18:18:50 hansmi Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-electronics/vbs/vbs-1.4.0.ebuild,v 1.3 2007/03/09 22:34:48 calchan Exp $
inherit eutils
@@ -10,7 +10,7 @@ SRC_URI="http://www.geda.seul.org/dist/${P}.tar.gz"
SLOT="0"
LICENSE="GPL-2"
-IUSE=""
+IUSE="examples"
KEYWORDS="ppc ~x86"
DEPEND=">=sys-devel/flex-2.3
@@ -18,23 +18,21 @@ DEPEND=">=sys-devel/flex-2.3
src_unpack () {
unpack ${A}
-
cd ${S}
- epatch ${FILESDIR}/${PN}-gcc-3.4.patch
+ epatch ${FILESDIR}/${P}-gcc-4.1.patch
}
src_compile () {
cd src
- econf || die
- emake vbs || die
+ econf || die "Configuration failed"
+ emake -j1 vbs || die "Compilation failed"
}
src_install () {
- dodoc BUGS CONTRIBUTORS COPYRIGHT FAQ README vbs.txt
-
- docinto examples
- dodoc EXAMPLES/*
-
- exeinto /usr/bin
- doexe src/vbs
+ dodoc BUGS CHANGELOG* CONTRIBUTORS COPYRIGHT FAQ README vbs.txt
+ dobin src/vbs
+ if use examples ; then
+ insinto /usr/share/${PF}/examples
+ doins EXAMPLES/*
+ fi
}