summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sci-libs/geos/ChangeLog6
-rw-r--r--sci-libs/geos/files/geos-2.1.1-multilib.patch24
-rw-r--r--sci-libs/geos/geos-2.1.1.ebuild31
3 files changed, 47 insertions, 14 deletions
diff --git a/sci-libs/geos/ChangeLog b/sci-libs/geos/ChangeLog
index e9a613966a64..de9376fd1361 100644
--- a/sci-libs/geos/ChangeLog
+++ b/sci-libs/geos/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-libs/geos
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/geos/ChangeLog,v 1.2 2005/05/14 04:19:22 matsuu Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/geos/ChangeLog,v 1.3 2005/05/14 13:02:32 matsuu Exp $
+
+ 14 May 2005; MATSUU Takuto <matsuu@gentoo.org>
+ +files/geos-2.1.1-multilib.patch, geos-2.1.1.ebuild:
+ clean up ebuild. Fixed multilib problem.
14 May 2005; MATSUU Takuto <matsuu@gentoo.org> geos-2.1.1.ebuild:
mark ~amd64
diff --git a/sci-libs/geos/files/geos-2.1.1-multilib.patch b/sci-libs/geos/files/geos-2.1.1-multilib.patch
new file mode 100644
index 000000000000..374ab0db1e4b
--- /dev/null
+++ b/sci-libs/geos/files/geos-2.1.1-multilib.patch
@@ -0,0 +1,24 @@
+diff -Naur geos-2.1.1.orig/source/geom/Makefile.am geos-2.1.1/source/geom/Makefile.am
+--- geos-2.1.1.orig/source/geom/Makefile.am 2004-11-24 01:22:49.000000000 +0900
++++ geos-2.1.1/source/geom/Makefile.am 2005-05-14 21:52:02.000000000 +0900
+@@ -2,7 +2,7 @@
+ top_srcdir=@top_srcdir@
+ GEOS_VERSION=@VERSION@
+
+-pkglibdir=$(prefix)/lib
++pkglibdir=$(libdir)
+ pkglib_LTLIBRARIES = libgeos.la
+
+ INCLUDES = -I$(top_srcdir)/source/headers -DGEOS_VERSION=""$(GEOS_VERSION)""
+diff -Naur geos-2.1.1.orig/source/geom/Makefile.in geos-2.1.1/source/geom/Makefile.in
+--- geos-2.1.1.orig/source/geom/Makefile.in 2004-12-17 03:01:32.000000000 +0900
++++ geos-2.1.1/source/geom/Makefile.in 2005-05-14 21:52:14.000000000 +0900
+@@ -38,7 +38,7 @@
+ target_triplet = @target@
+ top_srcdir = @top_srcdir@
+
+-pkglibdir = $(prefix)/lib
++pkglibdir = $(libdir)
+ ACLOCAL = @ACLOCAL@
+ ALLOCA = @ALLOCA@
+ AMDEP_FALSE = @AMDEP_FALSE@
diff --git a/sci-libs/geos/geos-2.1.1.ebuild b/sci-libs/geos/geos-2.1.1.ebuild
index 5828a142c6f5..e0d9ef3bff97 100644
--- a/sci-libs/geos/geos-2.1.1.ebuild
+++ b/sci-libs/geos/geos-2.1.1.ebuild
@@ -1,9 +1,11 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/geos/geos-2.1.1.ebuild,v 1.2 2005/05/14 04:19:22 matsuu Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/geos/geos-2.1.1.ebuild,v 1.3 2005/05/14 13:02:32 matsuu Exp $
+
+inherit eutils
DESCRIPTION="Geometry Engine - Open Source"
-HOMEPAGE="http://geos.refractions.net"
+HOMEPAGE="http://geos.refractions.net/"
SRC_URI="http://geos.refractions.net/${P}.tar.bz2"
LICENSE="GPL-2"
@@ -11,21 +13,25 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="static doc"
-DEPEND="doc? ( app-doc/doxygen)"
RDEPEND="virtual/libc"
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen )"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/${P}-multilib.patch
+}
-src_compile(){
- econf \
- $(use_enable static) \
- --prefix=/usr \
- || die "Error: econf failed"
+src_compile() {
+ econf $(use_enable static) || die "Error: econf failed"
emake || die "Error: emake failed"
}
-src_install(){
- into /usr
- einstall
- dodoc AUTHORS COPYING INSTALL NEWS README TODO
+src_install() {
+ make DESTDIR=${D} install || die
+
+ dodoc AUTHORS INSTALL NEWS README TODO
if use doc; then
cd ${S}/doc
make doxygen-html
@@ -34,6 +40,5 @@ src_install(){
}
src_test() {
- cd ${S}
make check || die "Tring make check without success."
}