summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-libs/openssl/ChangeLog6
-rw-r--r--dev-libs/openssl/files/openssl-1.0.2_beta1-perl-5.18.patch398
-rw-r--r--dev-libs/openssl/openssl-1.0.2_beta1.ebuild4
3 files changed, 405 insertions, 3 deletions
diff --git a/dev-libs/openssl/ChangeLog b/dev-libs/openssl/ChangeLog
index 732771978008..b842957b2a0d 100644
--- a/dev-libs/openssl/ChangeLog
+++ b/dev-libs/openssl/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-libs/openssl
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/openssl/ChangeLog,v 1.515 2014/03/20 05:47:31 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/openssl/ChangeLog,v 1.516 2014/03/21 19:12:26 polynomial-c Exp $
+
+ 21 Mar 2014; Lars Wendler <polynomial-c@gentoo.org>
+ openssl-1.0.2_beta1.ebuild, +files/openssl-1.0.2_beta1-perl-5.18.patch:
+ Fixed installation with perl-5.18
*openssl-1.0.2_beta1 (20 Mar 2014)
diff --git a/dev-libs/openssl/files/openssl-1.0.2_beta1-perl-5.18.patch b/dev-libs/openssl/files/openssl-1.0.2_beta1-perl-5.18.patch
new file mode 100644
index 000000000000..cbf9f0c940a8
--- /dev/null
+++ b/dev-libs/openssl/files/openssl-1.0.2_beta1-perl-5.18.patch
@@ -0,0 +1,398 @@
+Forward-ported from openssl-1.0.1f-perl-5.18.patch
+Fixes install with perl-5.18.
+
+Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
+
+--- openssl-1.0.2-beta1/doc/apps/cms.pod
++++ openssl-1.0.2-beta1/doc/apps/cms.pod
+@@ -463,28 +463,28 @@
+
+ =over 4
+
+-=item 0
++=item C<0>
+
+ the operation was completely successfully.
+
+-=item 1
++=item C<1>
+
+ an error occurred parsing the command options.
+
+-=item 2
++=item C<2>
+
+ one of the input files could not be read.
+
+-=item 3
++=item C<3>
+
+ an error occurred creating the CMS file or when reading the MIME
+ message.
+
+-=item 4
++=item C<4>
+
+ an error occurred decrypting or verifying the message.
+
+-=item 5
++=item C<5>
+
+ the message was verified correctly but an error occurred writing out
+ the signers certificates.
+--- openssl-1.0.2-beta1/doc/apps/smime.pod
++++ openssl-1.0.2-beta1/doc/apps/smime.pod
+@@ -308,28 +308,28 @@
+
+ =over 4
+
+-=item 0
++=item C<0>
+
+ the operation was completely successfully.
+
+-=item 1
++=item C<1>
+
+ an error occurred parsing the command options.
+
+-=item 2
++=item C<2>
+
+ one of the input files could not be read.
+
+-=item 3
++=item C<3>
+
+ an error occurred creating the PKCS#7 file or when reading the MIME
+ message.
+
+-=item 4
++=item C<4>
+
+ an error occurred decrypting or verifying the message.
+
+-=item 5
++=item C<5>
+
+ the message was verified correctly but an error occurred writing out
+ the signers certificates.
+--- openssl-1.0.2-beta1/doc/ssl/SSL_accept.pod
++++ openssl-1.0.2-beta1/doc/ssl/SSL_accept.pod
+@@ -44,13 +44,13 @@
+
+ =over 4
+
+-=item 0
++=item C<0>
+
+ The TLS/SSL handshake was not successful but was shut down controlled and
+ by the specifications of the TLS/SSL protocol. Call SSL_get_error() with the
+ return value B<ret> to find out the reason.
+
+-=item 1
++=item C<1>
+
+ The TLS/SSL handshake was successfully completed, a TLS/SSL connection has been
+ established.
+--- openssl-1.0.2-beta1/doc/ssl/SSL_clear.pod
++++ openssl-1.0.2-beta1/doc/ssl/SSL_clear.pod
+@@ -56,12 +56,12 @@
+
+ =over 4
+
+-=item 0
++=item C<0>
+
+ The SSL_clear() operation could not be performed. Check the error stack to
+ find out the reason.
+
+-=item 1
++=item C<1>
+
+ The SSL_clear() operation was successful.
+
+--- openssl-1.0.2-beta1/doc/ssl/SSL_COMP_add_compression_method.pod
++++ openssl-1.0.2-beta1/doc/ssl/SSL_COMP_add_compression_method.pod
+@@ -53,11 +53,11 @@
+
+ =over 4
+
+-=item 0
++=item C<0>
+
+ The operation succeeded.
+
+-=item 1
++=item C<1>
+
+ The operation failed. Check the error queue to find out the reason.
+
+--- openssl-1.0.2-beta1/doc/ssl/SSL_CONF_cmd.pod
++++ openssl-1.0.2-beta1/doc/ssl/SSL_CONF_cmd.pod
+@@ -320,6 +320,8 @@
+
+ The value is a directory name.
+
++=back
++
+ =head1 NOTES
+
+ The order of operations is significant. This can be used to set either defaults
+--- openssl-1.0.2-beta1/doc/ssl/SSL_connect.pod
++++ openssl-1.0.2-beta1/doc/ssl/SSL_connect.pod
+@@ -41,13 +41,13 @@
+
+ =over 4
+
+-=item 0
++=item C<0>
+
+ The TLS/SSL handshake was not successful but was shut down controlled and
+ by the specifications of the TLS/SSL protocol. Call SSL_get_error() with the
+ return value B<ret> to find out the reason.
+
+-=item 1
++=item C<1>
+
+ The TLS/SSL handshake was successfully completed, a TLS/SSL connection has been
+ established.
+--- openssl-1.0.2-beta1/doc/ssl/SSL_CTX_add1_chain_cert.pod
++++ openssl-1.0.2-beta1/doc/ssl/SSL_CTX_add1_chain_cert.pod
+@@ -128,6 +128,8 @@
+
+ All other functions return 1 for success and 0 for failure.
+
++=over
++
+ =back
+
+ =head1 SEE ALSO
+--- openssl-1.0.2-beta1/doc/ssl/SSL_CTX_add_session.pod
++++ openssl-1.0.2-beta1/doc/ssl/SSL_CTX_add_session.pod
+@@ -52,13 +52,13 @@
+
+ =over 4
+
+-=item 0
++=item C<0>
+
+ The operation failed. In case of the add operation, it was tried to add
+ the same (identical) session twice. In case of the remove operation, the
+ session was not found in the cache.
+
+-=item 1
++=item C<1>
+
+ The operation succeeded.
+
+--- openssl-1.0.2-beta1/doc/ssl/SSL_CTX_load_verify_locations.pod
++++ openssl-1.0.2-beta1/doc/ssl/SSL_CTX_load_verify_locations.pod
+@@ -100,13 +100,13 @@
+
+ =over 4
+
+-=item 0
++=item C<0>
+
+ The operation failed because B<CAfile> and B<CApath> are NULL or the
+ processing at one of the locations specified failed. Check the error
+ stack to find out the reason.
+
+-=item 1
++=item C<1>
+
+ The operation succeeded.
+
+--- openssl-1.0.2-beta1/doc/ssl/SSL_CTX_set1_curves.pod
++++ openssl-1.0.2-beta1/doc/ssl/SSL_CTX_set1_curves.pod
+@@ -87,6 +87,8 @@
+ SSL_get1_shared_curve() returns the NID of shared curve B<n> of zero if there
+ is no shared curve B<n> or the number of shared curves if B<n> is -1.
+
++=over
++
+ =back
+
+ =head1 SEE ALSO
+--- openssl-1.0.2-beta1/doc/ssl/SSL_CTX_set1_verify_cert_store.pod
++++ openssl-1.0.2-beta1/doc/ssl/SSL_CTX_set1_verify_cert_store.pod
+@@ -70,6 +70,8 @@
+
+ All these functions return 1 for success and 0 for failure.
+
++=over
++
+ =back
+
+ =head1 SEE ALSO
+--- openssl-1.0.2-beta1/doc/ssl/SSL_CTX_set_client_CA_list.pod
++++ openssl-1.0.2-beta1/doc/ssl/SSL_CTX_set_client_CA_list.pod
+@@ -66,13 +66,13 @@
+
+ =over 4
+
+-=item 0
++=item C<0>
+
+ A failure while manipulating the STACK_OF(X509_NAME) object occurred or
+ the X509_NAME could not be extracted from B<cacert>. Check the error stack
+ to find out the reason.
+
+-=item 1
++=item C<1>
+
+ The operation succeeded.
+
+--- openssl-1.0.2-beta1/doc/ssl/SSL_CTX_set_session_id_context.pod
++++ openssl-1.0.2-beta1/doc/ssl/SSL_CTX_set_session_id_context.pod
+@@ -64,13 +64,13 @@
+
+ =over 4
+
+-=item 0
++=item C<0>
+
+ The length B<sid_ctx_len> of the session id context B<sid_ctx> exceeded
+ the maximum allowed length of B<SSL_MAX_SSL_SESSION_ID_LENGTH>. The error
+ is logged to the error stack.
+
+-=item 1
++=item C<1>
+
+ The operation succeeded.
+
+--- openssl-1.0.2-beta1/doc/ssl/SSL_CTX_set_ssl_version.pod
++++ openssl-1.0.2-beta1/doc/ssl/SSL_CTX_set_ssl_version.pod
+@@ -42,11 +42,11 @@
+
+ =over 4
+
+-=item 0
++=item C<0>
+
+ The new choice failed, check the error stack to find out the reason.
+
+-=item 1
++=item C<1>
+
+ The operation succeeded.
+
+--- openssl-1.0.2-beta1/doc/ssl/SSL_CTX_use_psk_identity_hint.pod
++++ openssl-1.0.2-beta1/doc/ssl/SSL_CTX_use_psk_identity_hint.pod
+@@ -96,7 +96,7 @@
+ connection will fail with decryption_error before it will be finished
+ completely.
+
+-=item 0
++=item C<0>
+
+ PSK identity was not found. An "unknown_psk_identity" alert message
+ will be sent and the connection setup fails.
+--- openssl-1.0.2-beta1/doc/ssl/SSL_do_handshake.pod
++++ openssl-1.0.2-beta1/doc/ssl/SSL_do_handshake.pod
+@@ -45,13 +45,13 @@
+
+ =over 4
+
+-=item 0
++=item C<0>
+
+ The TLS/SSL handshake was not successful but was shut down controlled and
+ by the specifications of the TLS/SSL protocol. Call SSL_get_error() with the
+ return value B<ret> to find out the reason.
+
+-=item 1
++=item C<1>
+
+ The TLS/SSL handshake was successfully completed, a TLS/SSL connection has been
+ established.
+--- openssl-1.0.2-beta1/doc/ssl/SSL_read.pod
++++ openssl-1.0.2-beta1/doc/ssl/SSL_read.pod
+@@ -86,7 +86,7 @@
+ The read operation was successful; the return value is the number of
+ bytes actually read from the TLS/SSL connection.
+
+-=item 0
++=item C<0>
+
+ The read operation was not successful. The reason may either be a clean
+ shutdown due to a "close notify" alert sent by the peer (in which case
+--- openssl-1.0.2-beta1/doc/ssl/SSL_session_reused.pod
++++ openssl-1.0.2-beta1/doc/ssl/SSL_session_reused.pod
+@@ -27,11 +27,11 @@
+
+ =over 4
+
+-=item 0
++=item C<0>
+
+ A new session was negotiated.
+
+-=item 1
++=item C<1>
+
+ A session was reused.
+
+--- openssl-1.0.2-beta1/doc/ssl/SSL_set_fd.pod
++++ openssl-1.0.2-beta1/doc/ssl/SSL_set_fd.pod
+@@ -35,11 +35,11 @@
+
+ =over 4
+
+-=item 0
++=item C<0>
+
+ The operation failed. Check the error stack to find out why.
+
+-=item 1
++=item C<1>
+
+ The operation succeeded.
+
+--- openssl-1.0.2-beta1/doc/ssl/SSL_set_session.pod
++++ openssl-1.0.2-beta1/doc/ssl/SSL_set_session.pod
+@@ -37,11 +37,11 @@
+
+ =over 4
+
+-=item 0
++=item C<0>
+
+ The operation failed; check the error stack to find out the reason.
+
+-=item 1
++=item C<1>
+
+ The operation succeeded.
+
+--- openssl-1.0.2-beta1/doc/ssl/SSL_shutdown.pod
++++ openssl-1.0.2-beta1/doc/ssl/SSL_shutdown.pod
+@@ -92,14 +92,14 @@
+
+ =over 4
+
+-=item 0
++=item C<0>
+
+ The shutdown is not yet finished. Call SSL_shutdown() for a second time,
+ if a bidirectional shutdown shall be performed.
+ The output of L<SSL_get_error(3)|SSL_get_error(3)> may be misleading, as an
+ erroneous SSL_ERROR_SYSCALL may be flagged even though no error occurred.
+
+-=item 1
++=item C<1>
+
+ The shutdown was successfully completed. The "close notify" alert was sent
+ and the peer's "close notify" alert was received.
+--- openssl-1.0.2-beta1/doc/ssl/SSL_write.pod
++++ openssl-1.0.2-beta1/doc/ssl/SSL_write.pod
+@@ -79,7 +79,7 @@
+ The write operation was successful, the return value is the number of
+ bytes actually written to the TLS/SSL connection.
+
+-=item 0
++=item C<0>
+
+ The write operation was not successful. Probably the underlying connection
+ was closed. Call SSL_get_error() with the return value B<ret> to find out,
diff --git a/dev-libs/openssl/openssl-1.0.2_beta1.ebuild b/dev-libs/openssl/openssl-1.0.2_beta1.ebuild
index 90ab4ac70efa..af4b3dc3ce48 100644
--- a/dev-libs/openssl/openssl-1.0.2_beta1.ebuild
+++ b/dev-libs/openssl/openssl-1.0.2_beta1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/openssl/openssl-1.0.2_beta1.ebuild,v 1.1 2014/03/20 05:47:31 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/openssl/openssl-1.0.2_beta1.ebuild,v 1.2 2014/03/21 19:12:26 polynomial-c Exp $
EAPI="4"
@@ -59,7 +59,7 @@ src_prepare() {
epatch "${FILESDIR}"/${PN}-1.0.0h-pkg-config.patch
epatch "${FILESDIR}"/${PN}-1.0.2-parallel-build.patch
epatch "${FILESDIR}"/${PN}-1.0.2-ipv6.patch
- epatch "${FILESDIR}"/${PN}-1.0.1f-perl-5.18.patch #497286
+ epatch "${FILESDIR}"/${PN}-1.0.2_beta1-perl-5.18.patch #497286
epatch "${FILESDIR}"/${PN}-1.0.1e-s_client-verify.patch #472584
epatch "${FILESDIR}"/${PN}-1.0.1f-revert-alpha-perl-generation.patch #499086
epatch_user #332661