summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-text/aspell/Manifest4
-rw-r--r--app-text/aspell/aspell-0.50.3.ebuild5
-rw-r--r--app-text/aspell/files/01-gcc3.3-assert.patch10
-rw-r--r--app-text/aspell/files/02-gcc3.3-constcast.patch11
4 files changed, 28 insertions, 2 deletions
diff --git a/app-text/aspell/Manifest b/app-text/aspell/Manifest
index 00720d113673..81e8fb617176 100644
--- a/app-text/aspell/Manifest
+++ b/app-text/aspell/Manifest
@@ -1,3 +1,5 @@
+MD5 043791f028b9ffcc968bab1de3cf3194 aspell-0.50.3.ebuild 1809
MD5 516fea1d8e1524f84ffc01397d807a06 ChangeLog 5232
-MD5 fd4beacfad68682850ce9a69e38e4501 aspell-0.50.3.ebuild 1721
MD5 b266f4134f47fc1c8152daa6d4276f26 files/digest-aspell-0.50.3 65
+MD5 4fa550930c5e5fb38177ac9f77619891 files/01-gcc3.3-assert.patch 309
+MD5 f956a4b48687a0823d0d5d7608b567e9 files/02-gcc3.3-constcast.patch 453
diff --git a/app-text/aspell/aspell-0.50.3.ebuild b/app-text/aspell/aspell-0.50.3.ebuild
index 7875d8188414..675619c798f1 100644
--- a/app-text/aspell/aspell-0.50.3.ebuild
+++ b/app-text/aspell/aspell-0.50.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/aspell/aspell-0.50.3.ebuild,v 1.7 2003/03/27 11:58:07 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/aspell/aspell-0.50.3.ebuild,v 1.8 2003/06/11 21:40:36 johnm Exp $
inherit libtool
@@ -33,6 +33,9 @@ pkg_setup() {
}
src_compile() {
+ epatch ${FILESDIR}/01-gcc3.3-assert.patch
+ epatch ${FILESDIR}/02-gcc3.3-constcast.patch
+
elibtoolize --reverse-deps
econf \
diff --git a/app-text/aspell/files/01-gcc3.3-assert.patch b/app-text/aspell/files/01-gcc3.3-assert.patch
new file mode 100644
index 000000000000..c7ed293ed43b
--- /dev/null
+++ b/app-text/aspell/files/01-gcc3.3-assert.patch
@@ -0,0 +1,10 @@
+--- ./prog/checker_string.cpp 2002-09-26 03:42:42.000000000 +0100
++++ ./prog/checker_string.cpp 2003-06-11 22:05:01.840685592 +0100
+@@ -9,6 +9,7 @@
+ #include "document_checker.hpp"
+ #include "copy_ptr-t.hpp"
+ #include "asc_ctype.hpp"
++#include <assert.h>
+
+ static int get_line(FILE * in, CharVector & d)
+ {
diff --git a/app-text/aspell/files/02-gcc3.3-constcast.patch b/app-text/aspell/files/02-gcc3.3-constcast.patch
new file mode 100644
index 000000000000..bd83741d0bfe
--- /dev/null
+++ b/app-text/aspell/files/02-gcc3.3-constcast.patch
@@ -0,0 +1,11 @@
+--- ./common/posib_err.cpp.orig 2003-06-11 22:18:42.595911832 +0100
++++ ./common/posib_err.cpp 2003-06-11 22:19:05.749391968 +0100
+@@ -74,7 +74,7 @@
+ {
+ assert(err_ != 0);
+ assert(err_->refcount == 1);
+- char * & m = const_cast<char *>(err_->err->mesg);
++ char * m = const_cast<char *>(err_->err->mesg);
+ unsigned int orig_len = strlen(m);
+ unsigned int new_len = fn.size() + 2 + orig_len + 1;
+ char * s = new char[new_len];