summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--x11-misc/fbdesk/fbdesk-1.1.5.ebuild11
-rw-r--r--x11-misc/kpasscard/kpasscard-0.1.2.ebuild13
-rw-r--r--x11-misc/mixer_app/mixer_app-1.8.0.ebuild17
-rw-r--r--x11-misc/wmctrl/wmctrl-1.04.ebuild16
-rw-r--r--x11-misc/xsetleds/xsetleds-0.1.3.ebuild11
-rw-r--r--x11-plugins/wmnetmon/wmnetmon-0.2.ebuild18
6 files changed, 35 insertions, 51 deletions
diff --git a/x11-misc/fbdesk/fbdesk-1.1.5.ebuild b/x11-misc/fbdesk/fbdesk-1.1.5.ebuild
index 791fe226cbd7..6f3813a9f52c 100644
--- a/x11-misc/fbdesk/fbdesk-1.1.5.ebuild
+++ b/x11-misc/fbdesk/fbdesk-1.1.5.ebuild
@@ -1,12 +1,8 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/fbdesk/fbdesk-1.1.5.ebuild,v 1.4 2003/10/28 13:29:05 tseng Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/fbdesk/fbdesk-1.1.5.ebuild,v 1.5 2003/11/11 13:18:00 vapier Exp $
-IUSE=""
-
-S=${WORKDIR}/${P}
-
-DESCRIPTION="FbDesk is a fluxbox-util application that creates and manage icons on your Fluxbox desktop."
+DESCRIPTION="fluxbox-util application that creates and manage icons on your Fluxbox desktop"
HOMEPAGE="http://www.fluxbox.org/fbdesk/"
SRC_URI="http://www.fluxbox.org/download/${P}.tar.gz"
@@ -22,8 +18,7 @@ src_compile() {
emake || die
}
-src_install () {
+src_install() {
einstall || die
-
dodoc AUTHORS COPYING ChangeLog NEWS README
}
diff --git a/x11-misc/kpasscard/kpasscard-0.1.2.ebuild b/x11-misc/kpasscard/kpasscard-0.1.2.ebuild
index 02705d46d155..5fc4d36ef395 100644
--- a/x11-misc/kpasscard/kpasscard-0.1.2.ebuild
+++ b/x11-misc/kpasscard/kpasscard-0.1.2.ebuild
@@ -1,20 +1,17 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/kpasscard/kpasscard-0.1.2.ebuild,v 1.3 2003/09/08 07:07:44 msterret Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/kpasscard/kpasscard-0.1.2.ebuild,v 1.4 2003/11/11 13:20:43 vapier Exp $
inherit kde-base
need-kde 3
-DESCRIPTION="KPasscard is a kde application for storing several passwords to a chipcard encrypted by a master password."
+DESCRIPTION="app for storing several passwords to a chipcard encrypted by a master password"
HOMEPAGE="http://www.tobias-bayer.de/en/kpasscard.html"
SRC_URI="http://download.berlios.de/kpasscard/${P}.tar.gz"
-SLOT="0"
LICENSE="GPL-2"
+SLOT="0"
KEYWORDS="~x86"
-DEPEND="$DEPEND
- >=libchipcard-0.6"
-
-RDEPEND="${DEPEND}"
-
+DEPEND="${DEPEND}
+ >=sys-libs/libchipcard-0.6"
diff --git a/x11-misc/mixer_app/mixer_app-1.8.0.ebuild b/x11-misc/mixer_app/mixer_app-1.8.0.ebuild
index b3d0176c4537..5f97a095c948 100644
--- a/x11-misc/mixer_app/mixer_app-1.8.0.ebuild
+++ b/x11-misc/mixer_app/mixer_app-1.8.0.ebuild
@@ -1,31 +1,28 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/mixer_app/mixer_app-1.8.0.ebuild,v 1.1 2003/08/18 20:39:33 blkdeath Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/mixer_app/mixer_app-1.8.0.ebuild,v 1.2 2003/11/11 13:21:34 vapier Exp $
#need to do some name mangling
#so that ebuild name adheres to "standart"
Name=Mixer.app
S=${WORKDIR}/${Name}-${PV}
-DESCRIPTION="Mixer.app is a mixer utility that has three volume controllers that can be configured to handle any sound source, the default sources are master-, cd- and pcm-volume."
-SRC_URI="http://www.fukt.bth.se/~per/mixer/${Name}-${PV}.tar.gz"
+DESCRIPTION="mixer utility that has three volume controllers that can be configured to handle any sound source"
HOMEPAGE="http://www.fukt.bth.se/~per/mixer/"
-DEPEND="virtual/glibc x11-base/xfree "
+SRC_URI="http://www.fukt.bth.se/~per/mixer/${Name}-${PV}.tar.gz"
LICENSE="GPL-2"
-
SLOT="0"
-KEYWORDS="~x86 ~sparc ~ppc"
+KEYWORDS="~x86 ~ppc ~sparc"
+
+DEPEND="virtual/glibc x11-base/xfree "
src_compile() {
emake || die
-
}
-src_install () {
+src_install() {
#make DESTDIR=${D} install || die
dobin Mixer.app
-
dodoc COPYING README ChangeLog
}
-
diff --git a/x11-misc/wmctrl/wmctrl-1.04.ebuild b/x11-misc/wmctrl/wmctrl-1.04.ebuild
index e96bb202b9f4..1202a1e53b65 100644
--- a/x11-misc/wmctrl/wmctrl-1.04.ebuild
+++ b/x11-misc/wmctrl/wmctrl-1.04.ebuild
@@ -1,20 +1,18 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.<br>
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/wmctrl/wmctrl-1.04.ebuild,v 1.1 2003/11/05 15:49:55 tseng Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/wmctrl/wmctrl-1.04.ebuild,v 1.2 2003/11/11 13:20:06 vapier Exp $
-S=${WORKDIR}/${P}
-DESCRIPTION="The wmctrl program is a command line tool to interact with an EWMH/NetWM compatible X Window Manager."
-SRC_URI="http://sweb.cz/tripie/utils/wmctrl/dist/${P}.tar.gz"
+DESCRIPTION="command line tool to interact with an EWMH/NetWM compatible X Window Manager"
HOMEPAGE="http://sweb.cz/tripie/utils/wmctrl/"
+SRC_URI="http://sweb.cz/tripie/utils/wmctrl/dist/${P}.tar.gz"
+
LICENSE="GPL-2"
-KEYWORDS="~x86 ~ppc ~sparc"
-IUSE=""
SLOT="0"
+KEYWORDS="~x86 ~ppc ~sparc"
DEPEND="virtual/x11"
src_install () {
-
-dodoc AUTHORS COPYING ChangeLog INSTALL NEWS README
-make DESTDIR=${D} install || die
+ dodoc AUTHORS COPYING ChangeLog INSTALL NEWS README
+ make DESTDIR=${D} install || die
}
diff --git a/x11-misc/xsetleds/xsetleds-0.1.3.ebuild b/x11-misc/xsetleds/xsetleds-0.1.3.ebuild
index e1db73bf5ebf..3f85e07b56d3 100644
--- a/x11-misc/xsetleds/xsetleds-0.1.3.ebuild
+++ b/x11-misc/xsetleds/xsetleds-0.1.3.ebuild
@@ -1,14 +1,13 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/xsetleds/xsetleds-0.1.3.ebuild,v 1.1 2003/10/16 01:09:08 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/xsetleds/xsetleds-0.1.3.ebuild,v 1.2 2003/11/11 13:19:29 vapier Exp $
-IUSE=""
-DESCRIPTION="xsetleds is a small tool to report and change the keyboard LED states of an X display."
-HOMEPAGE="ftp://ftp.unix-ag.org/user/bmeurer/xsetleds"
-SRC_URI="${HOMEPAGE}/src/${P}.tar.gz"
+DESCRIPTION="small tool to report and change the keyboard LED states of an X display"
+HOMEPAGE="ftp://ftp.unix-ag.org/user/bmeurer/xsetleds/"
+SRC_URI="ftp://ftp.unix-ag.org/user/bmeurer/xsetleds/src/${P}.tar.gz"
-SLOT="0"
LICENSE="GPL-2"
+SLOT="0"
KEYWORDS="~x86 ~ppc ~sparc ~alpha ~hppa ~mips ~arm ~amd64 ~ia64"
DEPEND="virtual/x11"
diff --git a/x11-plugins/wmnetmon/wmnetmon-0.2.ebuild b/x11-plugins/wmnetmon/wmnetmon-0.2.ebuild
index 26c4cb755f4c..4aa972615cb7 100644
--- a/x11-plugins/wmnetmon/wmnetmon-0.2.ebuild
+++ b/x11-plugins/wmnetmon/wmnetmon-0.2.ebuild
@@ -1,33 +1,31 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmnetmon/wmnetmon-0.2.ebuild,v 1.1 2003/11/02 02:39:04 pyrania Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmnetmon/wmnetmon-0.2.ebuild,v 1.2 2003/11/11 13:22:41 vapier Exp $
S=${WORKDIR}/${P}p5/
-DESCRIPTION="wmnetmon is a dockapp that monitors up to 40 hosts or services and can execute something there is a problem with any of them."
-SRC_URI="http://www.linuks.mine.nu/dockapps/${P}p5.tar.gz"
+DESCRIPTION="dockapp that monitors up to 40 hosts/services and can execute something if there is a problem with any of them"
HOMEPAGE="http://freshmeat.net/projects/wmnetmon/?topic_id=876"
+SRC_URI="http://www.linuks.mine.nu/dockapps/${P}p5.tar.gz"
-DEPEND="virtual/x11"
-
-SLOT="0"
LICENSE="GPL-2"
+SLOT="0"
KEYWORDS="~x86"
+DEPEND="virtual/x11"
+
src_compile() {
econf --prefix=${D}/usr/bin || die "Configure failed."
emake || die "Make failed"
}
-src_install ()
-{
+src_install() {
dobin wmnetmon
fowners root:root /usr/bin/wmnetmon
fperms 4755 /usr/bin/wmnetmon
dodoc README Changes wmnetmonrc
}
-pkg_postinst ()
-{
+pkg_postinst() {
ewarn
ewarn "Before starting up wmnetmon, you must create a .wmnetmonrc in your home folder."
ewarn "Look at the sample wmnetmonrc.gz file in /usr/share/doc/${P}/."