summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-lang/python/python-2.2-r6.ebuild7
-rw-r--r--profiles/package.mask8
-rwxr-xr-xscripts/bootstrap.sh2
3 files changed, 6 insertions, 11 deletions
diff --git a/dev-lang/python/python-2.2-r6.ebuild b/dev-lang/python/python-2.2-r6.ebuild
index d2867bd7edf3..8d5ec4ac396d 100644
--- a/dev-lang/python/python-2.2-r6.ebuild
+++ b/dev-lang/python/python-2.2-r6.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Maintainer: Daniel Robbins <drobbins@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.2-r6.ebuild,v 1.2 2002/04/25 02:26:16 drobbins Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.2-r6.ebuild,v 1.3 2002/04/25 06:11:00 drobbins Exp $
PYVER_MAJOR="`echo ${PV} | cut -d '.' -f 1`"
PYVER_MINOR="`echo ${PV} | cut -d '.' -f 2`"
@@ -15,8 +15,11 @@ DEPEND="virtual/glibc >=sys-libs/zlib-1.1.3
readline? ( >=sys-libs/readline-4.1 >=sys-libs/ncurses-5.2 )
berkdb? ( >=sys-libs/db-3 )
tcltk? ( >=dev-lang/tk-8.0 )"
+RDEPEND="$DEPEND dev-python/python-fchksum"
+
+# The dev-python/python-fchksum RDEPEND is needed to that this python provides
+# the functionality expected from previous pythons.
-RDEPEND="$DEPEND"
PROVIDE="virtual/python"
SLOT="2.2"
diff --git a/profiles/package.mask b/profiles/package.mask
index ccf380222274..3810d35cc7e7 100644
--- a/profiles/package.mask
+++ b/profiles/package.mask
@@ -5,14 +5,6 @@
#this fixes that. devlopers give it a shot
=net-misc/rsync-2.5.4-r1
-# new python ebuild is half baked... it breaks portage (fchksum)
-=dev-lang/python-2.2-r6
-
-#for developers only -- right now (drobbins, 16 Apr 2002)
-=sys-apps/portage-1.9.0
-
-=sys-apps/portage-1.8.9.3
-
# Since azarah is the opengl dude here, i'll mask this untill he looks at
# it... Won't compile.. <Verwilst, 17 April 2002>
=app-games/crack-attack-1.1.7
diff --git a/scripts/bootstrap.sh b/scripts/bootstrap.sh
index d692155c12f2..9824dac14141 100755
--- a/scripts/bootstrap.sh
+++ b/scripts/bootstrap.sh
@@ -71,6 +71,6 @@ emerge $myPORTAGE #separate, so that the next command uses the *new* emerge
emerge $myBASELAYOUT $myGETTEXT $myBINUTILS $myGCC || cleanup 1
#make.conf has been overwritten, so we explicitly export our original settings
export USE="$ORIGUSE bootstrap"
-emerge $myGLIBC $myBASELAYOUT $myGETTEXT $myBINUTILS $myGCC $myPORTAGE || cleanup 1
+emerge $myGLIBC $myBASELAYOUT $myGETTEXT $myBINUTILS $myGCC || cleanup 1
#restore original make.conf
cleanup 0