summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--www-servers/mini_httpd/ChangeLog5
-rw-r--r--www-servers/mini_httpd/mini_httpd-1.19.ebuild10
2 files changed, 9 insertions, 6 deletions
diff --git a/www-servers/mini_httpd/ChangeLog b/www-servers/mini_httpd/ChangeLog
index e84578356561..4ba60ee80d2d 100644
--- a/www-servers/mini_httpd/ChangeLog
+++ b/www-servers/mini_httpd/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for www-servers/mini_httpd
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-servers/mini_httpd/ChangeLog,v 1.12 2009/08/08 22:19:53 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-servers/mini_httpd/ChangeLog,v 1.13 2009/10/14 12:02:59 bangert Exp $
+
+ 14 Oct 2009; Thilo Bangert <bangert@gentoo.org> mini_httpd-1.19.ebuild:
+ fix quoting - fix ssl support (bug #280509)
08 Aug 2009; Samuli Suominen <ssuominen@gentoo.org>
mini_httpd-1.19.ebuild, +files/mini_httpd-1.19-glibc-2.10.patch:
diff --git a/www-servers/mini_httpd/mini_httpd-1.19.ebuild b/www-servers/mini_httpd/mini_httpd-1.19.ebuild
index 943f9147ec1d..c4da6be01f24 100644
--- a/www-servers/mini_httpd/mini_httpd-1.19.ebuild
+++ b/www-servers/mini_httpd/mini_httpd-1.19.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-servers/mini_httpd/mini_httpd-1.19.ebuild,v 1.11 2009/08/08 22:19:53 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-servers/mini_httpd/mini_httpd-1.19.ebuild,v 1.12 2009/10/14 12:02:59 bangert Exp $
inherit eutils toolchain-funcs
@@ -47,18 +47,18 @@ src_compile() {
if ! use ipv6; then
sed -i 's@#define USE_IPV6@#undef USE_IPV6@' mini_httpd.c
fi
- emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}" || die
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS} \${CDEFS}" LDFLAGS="${LDFLAGS}" || die
}
src_install() {
make install || die
- mv ${D}/usr/sbin/{,mini_}htpasswd
- mv ${D}/usr/share/man/man1/{,mini_}htpasswd.1
+ mv "${D}"/usr/sbin/{,mini_}htpasswd
+ mv "${D}"/usr/share/man/man1/{,mini_}htpasswd.1
newinitd "${FILESDIR}"/mini_httpd.init mini_httpd
newconfd "${FILESDIR}"/mini_httpd.confd-${PV} mini_httpd
dodoc README
- newdoc ${FILESDIR}/mini_httpd.conf.sample-${PV} mini_httpd.conf.sample
+ newdoc "${FILESDIR}"/mini_httpd.conf.sample-${PV} mini_httpd.conf.sample
}
pkg_postinst() {