summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-libs/libp11/ChangeLog8
-rw-r--r--dev-libs/libp11/libp11-0.2.6.ebuild47
2 files changed, 54 insertions, 1 deletions
diff --git a/dev-libs/libp11/ChangeLog b/dev-libs/libp11/ChangeLog
index 49817fb97ca8..3681e47559ac 100644
--- a/dev-libs/libp11/ChangeLog
+++ b/dev-libs/libp11/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-libs/libp11
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libp11/ChangeLog,v 1.33 2009/06/27 20:28:29 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libp11/ChangeLog,v 1.34 2009/07/22 21:08:23 arfrever Exp $
+
+*libp11-0.2.6 (22 Jul 2009)
+
+ 22 Jul 2009; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ +libp11-0.2.6.ebuild:
+ Version bump.
*libp11-0.2.5 (27 Jun 2009)
diff --git a/dev-libs/libp11/libp11-0.2.6.ebuild b/dev-libs/libp11/libp11-0.2.6.ebuild
new file mode 100644
index 000000000000..d2db4c1dcad2
--- /dev/null
+++ b/dev-libs/libp11/libp11-0.2.6.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libp11/libp11-0.2.6.ebuild,v 1.1 2009/07/22 21:08:23 arfrever Exp $
+
+EAPI="2"
+
+DESCRIPTION="Libp11 is a library implementing a small layer on top of PKCS#11 API to make using PKCS#11 implementations easier."
+HOMEPAGE="http://www.opensc-project.org/libp11/"
+
+if [[ "${PV}" = "9999" ]]; then
+ inherit autotools subversion
+ ESVN_REPO_URI="http://www.opensc-project.org/svn/${PN}/trunk"
+else
+ SRC_URI="http://www.opensc-project.org/files/${PN}/${P}.tar.gz"
+fi
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="doc"
+
+RDEPEND="dev-libs/openssl"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ doc? ( app-doc/doxygen )"
+
+if [[ "${PV}" = "9999" ]]; then
+ DEPEND="${DEPEND}
+ app-text/docbook-xsl-stylesheets
+ dev-libs/libxslt"
+
+ src_prepare() {
+ eautoreconf
+ }
+fi
+
+src_configure() {
+ econf \
+ --docdir="/usr/share/doc/${PF}" \
+ --htmldir="/usr/share/doc/${PF}/html" \
+ $(use_enable doc) \
+ $(use_enable doc api-doc)
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die "emake install failed"
+}