summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--mail-client/ciphire-mail/ChangeLog8
-rw-r--r--mail-client/ciphire-mail/Manifest3
-rw-r--r--mail-client/ciphire-mail/ciphire-mail-1.1.009.ebuild167
-rw-r--r--mail-client/ciphire-mail/files/digest-ciphire-mail-1.1.0092
4 files changed, 179 insertions, 1 deletions
diff --git a/mail-client/ciphire-mail/ChangeLog b/mail-client/ciphire-mail/ChangeLog
index 7c70973a5f39..c364b445175b 100644
--- a/mail-client/ciphire-mail/ChangeLog
+++ b/mail-client/ciphire-mail/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for mail-client/ciphire-mail
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/mail-client/ciphire-mail/ChangeLog,v 1.2 2005/07/25 15:47:09 caleb Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-client/ciphire-mail/ChangeLog,v 1.3 2005/09/07 23:06:37 azarah Exp $
+
+*ciphire-mail-1.1.009 (07 Sep 2005)
+
+ 07 Sep 2005; Martin Schlemmer <azarah@gentoo.org>
+ +ciphire-mail-1.1.009.ebuild:
+ Update version. Add amd64 support.
25 Jul 2005; Caleb Tennis <caleb@gentoo.org> ciphire-mail-1.0.0.ebuild:
Fix qt dep per bug #100235
diff --git a/mail-client/ciphire-mail/Manifest b/mail-client/ciphire-mail/Manifest
index 31446850a5a0..089fe53642bf 100644
--- a/mail-client/ciphire-mail/Manifest
+++ b/mail-client/ciphire-mail/Manifest
@@ -1,4 +1,7 @@
MD5 64499cc4e3fa3b225f9e2eeaf03fc5ad ciphire-mail-1.0.0.ebuild 3533
+MD5 81fc2823cca8a4136739e4157d88bb5f ciphire-mail-1.1.009.ebuild 4040
MD5 78eaed30802c75cab725441f37d21e23 ChangeLog 481
+MD5 93aeaf7b571495023a142475d162d76a .ciphire-mail-1.1.009.ebuild.swp 24576
MD5 b612d343db3c54560665171eb7db245c metadata.xml 223
+MD5 bc3695b7104bb878d3e496ad4f7d6e10 files/digest-ciphire-mail-1.1.009 147
MD5 3ba822caed60cb1af266084b7298fe80 files/digest-ciphire-mail-1.0.0 83
diff --git a/mail-client/ciphire-mail/ciphire-mail-1.1.009.ebuild b/mail-client/ciphire-mail/ciphire-mail-1.1.009.ebuild
new file mode 100644
index 000000000000..837588467f80
--- /dev/null
+++ b/mail-client/ciphire-mail/ciphire-mail-1.1.009.ebuild
@@ -0,0 +1,167 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/mail-client/ciphire-mail/ciphire-mail-1.1.009.ebuild,v 1.1 2005/09/07 23:06:37 azarah Exp $
+
+inherit eutils qt3
+
+LOC="/opt/ciphire-mail"
+DESCRIPTION="Ciphire Mail is an email encryption tool, operating seamlessly in the background."
+HOMEPAGE="http://www.ciphire.com/"
+SRC_URI="${P}-linux-i686.tar.gz
+ amd64? ( ciphire-redir64.so )"
+LICENSE="Ciphire"
+SLOT="0"
+# Do not support amd64 as yet, as we need 64bit support
+KEYWORDS="-* ~x86 ~amd64"
+RESTRICT="nostrip fetch nomirror"
+IUSE="X gnome kde"
+
+DEPEND=
+RDEPEND="X? ( virtual/x11 )
+ x86? ( $(qt_min_version 3.2) )
+ amd64? ( app-emulation/emul-linux-x86-glibc
+ >=app-emulation/emul-linux-x86-baselibs-2.1.1
+ X? ( >=app-emulation/emul-linux-x86-xlibs-1.2
+ >=app-emulation/emul-linux-x86-qtlibs-1.1 ) )"
+
+pkg_nofetch() {
+ einfo "You need to perform the following steps to install this package:"
+ einfo " - Go here: https://www.ciphire.com/linux_download.html,"
+ einfo " - Download: ${P}-linux-i686.tar.gz"
+ einfo " and place it in ${DISTDIR}"
+ echo
+ if useq amd64 ; then
+ ewarn " - Go here: https://forum.ciphire.com/viewtopic.php?p=4173:"
+ ewarn " - Download: ciphire-redir64.so"
+ ewarn " and place it in ${DISTDIR}"
+ echo
+ fi
+ einfo " - emerge this package again"
+ echo
+}
+
+pkg_setup() {
+ if ( [[ -d /usr/local/ciphire ]] || type -p ciphire-ctl &>/dev/null ) && \
+ ! portageq has_version / ciphire-mail ; then
+ echo
+ einfo "If you have previously had Ciphire Mail manually installed,"
+ einfo "please uninstall it first (from dir you installed it):"
+ echo
+ einfo " # ./ciphire-uninstall system"
+ echo
+ einfo "and then remerge ciphire-mail."
+ echo
+ die "Old version of ciphire-mail installed"
+ fi
+
+ check_license || die "License check failed"
+}
+
+src_unpack() {
+ unpack "${P}-linux-i686.tar.gz"
+
+ # Do not run 'more' to show the license
+ sed -i -e 's:more\(.*LICENSE.txt\):echo\1:' \
+ "${S}/files/setupdata/libciphire.sh"
+}
+
+src_install() {
+ local x=
+
+ dodir "${LOC}"
+ keepdir "${LOC}/updates"
+
+ # Do not enable the graphical popups
+ env -u DISPLAY \
+ ./install-ciphire.sh "${D}${LOC}" <<-EOF
+ en
+ n
+ yes
+ y
+ n
+ n
+ EOF
+ [[ "$?" != 0 ]] && die "install-ciphire.sh failed"
+
+ # Revert the change in src_unpack()
+ dosed -e 's:echo\(.*LICENSE.txt\):more\1:' \
+ "${LOC}"/setupdata/libciphire.sh
+
+ # Fixup $D in setupdata
+ for x in "${D}${LOC}"/setupdata/*; do
+ sed -i -e "s:${D}::g" "${x}"
+ done
+
+ if useq amd64 ; then
+ # Install 64bit ciphire-redir.so
+ exeinto "${LOC}"
+ doexe "${DISTDIR}"/ciphire-redir64.so
+ # Make sure the redirector gets used.
+ dosed -e \
+ '/PRELOAD_VALUE=/ s|\$CITARGET/ciphire-redir.so|\$CITARGET/ciphire-redir64.so:\$CITARGET/ciphire-redir.so|' \
+ "${LOC}"/ciphire-systemsetup
+ [[ -z $(grep 'ciphire-redir64.so' "${D}${LOC}/ciphire-systemsetup") ]] && \
+ die "Could not add 'ciphire-redir64.so'!"
+ fi
+
+ # Enable X support
+ useq X && dosed -e 's:^XSUPPORT=.*:XSUPPORT=1:' \
+ "${LOC}"/setupdata/ciphire.distconfig
+
+ cm_make_wrapper ciphire-setup ciphire-setup "${LOC}"
+ cm_make_wrapper ciphire-ctl ciphire-ctl "${LOC}"
+ cm_make_wrapper ciphire-msg ciphire-msg "${LOC}"
+
+ if useq X && ( useq gnome || useq kde ) ; then
+ make_desktop_entry ciphire-setup \
+ "Ciphire Mail User Setup" \
+ "${LOC}"/data/logo32.png \
+ "Network" \
+ "${LOC}"
+ fi
+}
+
+pkg_postinst() {
+ if [[ ${ROOT} == "/" ]] ; then
+ use X && env -u DISPLAY "${LOC}"/ciphire-systemsetup xreinstall \
+ || env -u DISPLAY "${LOC}"/ciphire-systemsetup reinstall
+ fi
+
+ echo
+ einfo "To setup Ciphire Mail for a user, please run as that user:"
+ echo
+ einfo " ${LOC}/ciphire-setup"
+ echo
+ einfo "If you have previously had Ciphire Mail manually installed,"
+ einfo "please uninstall it first (from dir you installed it):"
+ echo
+ einfo " # ./ciphire-uninstall system"
+ echo
+ einfo "and then remerge ciphire-mail."
+ echo
+ if useq amd64 ; then
+ ewarn "Please note that the AMD64 support (ciphire-redir64.so) is"
+ ewarn "Beta, and not officially supported!"
+ echo
+ ebeep
+ fi
+}
+
+cm_make_wrapper() {
+ local wrapper=$1 bin=$2 dir=$3
+ local tmpwrapper=$(emktemp)
+
+ cat << EOF > "${tmpwrapper}"
+#!/bin/bash
+
+exec ${dir}/${bin} "\$@"
+EOF
+ chmod go+rx "${tmpwrapper}"
+ if [[ -n $5 ]] ; then
+ exeinto "${5}"
+ newexe "${tmpwrapper}" "${wrapper}"
+ else
+ newbin "${tmpwrapper}" "${wrapper}"
+ fi
+}
+
diff --git a/mail-client/ciphire-mail/files/digest-ciphire-mail-1.1.009 b/mail-client/ciphire-mail/files/digest-ciphire-mail-1.1.009
new file mode 100644
index 000000000000..af937b92c967
--- /dev/null
+++ b/mail-client/ciphire-mail/files/digest-ciphire-mail-1.1.009
@@ -0,0 +1,2 @@
+MD5 864e76da3b2d280086f2dbe31bf29069 ciphire-mail-1.1.009-linux-i686.tar.gz 10583387
+MD5 b46b5d2a785d82185230c0ab7bcc1e82 ciphire-redir64.so 24792