summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-util/shunit2/ChangeLog9
-rw-r--r--dev-util/shunit2/shunit2-2.1.5.ebuild46
2 files changed, 53 insertions, 2 deletions
diff --git a/dev-util/shunit2/ChangeLog b/dev-util/shunit2/ChangeLog
index b66a5e56a2a5..bf1eb4b54a6a 100644
--- a/dev-util/shunit2/ChangeLog
+++ b/dev-util/shunit2/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-util/shunit2
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/shunit2/ChangeLog,v 1.2 2008/10/25 13:15:40 pvdabeel Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/shunit2/ChangeLog,v 1.3 2010/06/26 07:40:10 jlec Exp $
+
+*shunit2-2.1.5 (26 Jun 2010)
+
+ 26 Jun 2010; Justin Lecher <jlec@gentoo.org> +shunit2-2.1.5.ebuild:
+ Version bump, #294036
*shunit2-2.1.4 (15 Sep 2008)
diff --git a/dev-util/shunit2/shunit2-2.1.5.ebuild b/dev-util/shunit2/shunit2-2.1.5.ebuild
new file mode 100644
index 000000000000..bacef12cc8c8
--- /dev/null
+++ b/dev-util/shunit2/shunit2-2.1.5.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/shunit2/shunit2-2.1.5.ebuild,v 1.1 2010/06/26 07:40:10 jlec Exp $
+
+EAPI="3"
+
+DESCRIPTION="Unit-test framework for Bourne-based shell scripts."
+HOMEPAGE="http://code.google.com/p/shunit2/wiki/ProjectInfo"
+SRC_URI="http://shunit2.googlecode.com/files/${P}.tgz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="doc test"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ dev-lang/perl
+ net-misc/curl"
+
+src_prepare() {
+ sed -i -e '/^__SHUNIT_SHELL_FLAGS/s:u::' src/shell/shunit2 || die
+}
+
+src_compile() {
+ local myconf="build"
+ use doc && myconf="${myconf} docs"
+ use test && myconf="${myconf} test"
+
+ emake ${myconf} || die
+}
+
+src_install() {
+ if use doc; then
+ for DOC in build/{docbook/*,shunit2.html,shunit2_shelldoc.xml}; do
+ dodoc ${DOC} || die
+ rm ${DOC}
+ done
+ fi
+
+ dodoc doc/*.txt || die
+ dohtml doc/*.html || die
+
+ insinto /usr/share/${PN}
+ doins build/* || die
+}