summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sys-apps/sandbox/ChangeLog10
-rw-r--r--sys-apps/sandbox/Manifest3
-rw-r--r--sys-apps/sandbox/files/digest-sandbox-1.2.5-r11
-rw-r--r--sys-apps/sandbox/sandbox-1.2.5-r1.ebuild88
4 files changed, 100 insertions, 2 deletions
diff --git a/sys-apps/sandbox/ChangeLog b/sys-apps/sandbox/ChangeLog
index 21ce265e3660..6bb08fc7d77d 100644
--- a/sys-apps/sandbox/ChangeLog
+++ b/sys-apps/sandbox/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for sys-apps/sandbox
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/sandbox/ChangeLog,v 1.11 2005/05/04 23:25:00 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/sandbox/ChangeLog,v 1.12 2005/05/06 09:48:15 eradicator Exp $
+
+*sandbox-1.2.5-r1 (06 May 2005)
+
+ 06 May 2005; Jeremy Huddleston <eradicator@gentoo.org>
+ +sandbox-1.2.5-r1.ebuild:
+ Revbump to fix problems with amd64 2004.3's multilib. Cleaned up multilib
+ handling in general. 2004.3 amd64 users should have working 32bit sandbox
+ again.
04 May 2005; Mike Frysinger <vapier@gentoo.org> sandbox-1.2.5.ebuild:
Fix multilib building on amd64/2004.3 profiles.
diff --git a/sys-apps/sandbox/Manifest b/sys-apps/sandbox/Manifest
index 32633c3b4a52..a134e98072e7 100644
--- a/sys-apps/sandbox/Manifest
+++ b/sys-apps/sandbox/Manifest
@@ -3,8 +3,9 @@ MD5 968e2965b0b6f620634dae6d28d8b4c4 metadata.xml 455
MD5 7ed1125d24e2a98b0832f84d9ab637da sandbox-1.2.4.ebuild 2145
MD5 3c85f7c72e45afadde1025fc0ef3a205 sandbox-1.2.2.ebuild 2235
MD5 734eba450db4538f0e38ee876d28dacc sandbox-1.2.3.ebuild 2145
-MD5 2dbe688eca05e86a1b4679ede08c45cf sandbox-1.2.5.ebuild 2775
+MD5 39ad47a60e1a39ffa6708eaa6943390e sandbox-1.2.5-r1.ebuild 2309
MD5 fb651b249c3214a6d0fa321e1d419e07 files/digest-sandbox-1.2.2 66
MD5 bf2c5f346fcc11659401c9240b1b8db9 files/digest-sandbox-1.2.3 66
MD5 608cba289865ac916fb83ba5dc9daa2f files/digest-sandbox-1.2.4 66
MD5 54b60d2b6f5d3b74312b47c02e3f169e files/digest-sandbox-1.2.5 66
+MD5 54b60d2b6f5d3b74312b47c02e3f169e files/digest-sandbox-1.2.5-r1 66
diff --git a/sys-apps/sandbox/files/digest-sandbox-1.2.5-r1 b/sys-apps/sandbox/files/digest-sandbox-1.2.5-r1
new file mode 100644
index 000000000000..bd94a7de2c45
--- /dev/null
+++ b/sys-apps/sandbox/files/digest-sandbox-1.2.5-r1
@@ -0,0 +1 @@
+MD5 46da10934739b14cd9999d6f52227dca sandbox-1.2.5.tar.bz2 221605
diff --git a/sys-apps/sandbox/sandbox-1.2.5-r1.ebuild b/sys-apps/sandbox/sandbox-1.2.5-r1.ebuild
new file mode 100644
index 000000000000..8acd17da1108
--- /dev/null
+++ b/sys-apps/sandbox/sandbox-1.2.5-r1.ebuild
@@ -0,0 +1,88 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/sandbox/sandbox-1.2.5-r1.ebuild,v 1.1 2005/05/06 09:48:15 eradicator Exp $
+
+#
+# don't monkey with this ebuild unless contacting portage devs.
+# period.
+#
+
+inherit eutils flag-o-matic eutils toolchain-funcs multilib
+
+DESCRIPTION="sandbox'd LD_PRELOAD hack"
+SRC_URI="mirror://gentoo/${P}.tar.bz2
+ http://dev.gentoo.org/~azarah/sandbox/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+#KEYWORDS=" alpha amd64 arm hppa ia64 mips ppc ppc-macos ppc64 s390 sh sparc x86"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc-macos ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE=""
+RESTRICT="multilib-pkg-force"
+
+DEPEND="virtual/libc"
+
+pkg_setup() {
+ if ! has_multilib_profile && has_m32 && [[ ${CONF_MULTILIBDIR} == "lib32" ]] && use amd64; then
+ export DEFAULT_ABI="amd64"
+ export MULTILIB_ABIS="x86 amd64"
+ export CFLAGS_amd64="-m64"
+ export CFLAGS_x86="-m32 -L/emul/linux/x86/lib -L/emul/linux/x86/usr/lib"
+ export LIBDIR_amd64="${CONF_LIBDIR}"
+ export LIBDIR_x86="${CONF_MULTILIBDIR}"
+ fi
+}
+
+src_unpack() {
+ for ABI in $(get_install_abis) ; do
+ unpack ${A}
+ cd ${WORKDIR}
+ einfo "Unpacking sandbox for ABI=${ABI}..."
+ mv ${S} ${S%/}-${ABI} || die "failed moving \$S to ${ABI}"
+ done
+}
+
+abi_fail_check() {
+ local ABI=$1
+ if [[ ${ABI} == "x86" ]] ; then
+ echo
+ eerror "Building failed for ABI=x86!. This usually means a broken"
+ eerror "multilib setup. Please fix that before filling a bugreport"
+ eerror "against sandbox."
+ echo
+ fi
+}
+
+src_compile() {
+ filter-lfs-flags #90228
+
+ has_multilib_profile && append-flags -DSB_HAVE_64BIT_ARCH
+
+ OABI="${ABI}"
+ for ABI in $(get_install_abis); do
+ export ABI
+ cd ${S}-${ABI}
+ einfo "Configuring sandbox for ABI=${ABI}..."
+ econf --libdir="/usr/$(get_libdir)" || {
+ abi_fail_check "${ABI}"
+ die "econf failed for ${ABI}"
+ }
+ einfo "Building sandbox for ABI=${ABI}..."
+ emake || {
+ abi_fail_check "${ABI}"
+ die "emake failed for ${ABI}"
+ }
+ done
+ ABI="${OABI}"
+}
+
+src_install() {
+ OABI="${ABI}"
+ for ABI in $(get_install_abis); do
+ export ABI
+ cd ${S}-${ABI}
+ einfo "Installing sandbox for ABI=${ABI}..."
+ make DESTDIR="${D}" install || die "make install failed for ${ABI}"
+ done
+ ABI="${OABI}"
+}