summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sys-libs/cracklib/cracklib-2.7-r1.ebuild39
-rw-r--r--sys-libs/gdbm/gdbm-1.8.0-r1.ebuild37
-rw-r--r--sys-libs/gettext/gettext-0.10.35-r1.ebuild29
-rw-r--r--sys-libs/glibc/glibc-2.1.3-r1.ebuild88
-rw-r--r--sys-libs/gpm/gpm-1.19.2-r1.ebuild37
-rw-r--r--sys-libs/lib-compat/lib-compat-1.0-r1.ebuild29
-rw-r--r--sys-libs/ncurses/ncurses-5.1-r1.ebuild50
-rw-r--r--sys-libs/pam/pam-0.72-r1.ebuild47
-rw-r--r--sys-libs/pwdb/pwdb-0.61-r1.ebuild40
-rw-r--r--sys-libs/readline/readline-4.1-r1.ebuild41
-rw-r--r--sys-libs/slang/slang-1.4.1-r1.ebuild42
-rw-r--r--sys-libs/zlib/zlib-1.1.3-r1.ebuild33
12 files changed, 512 insertions, 0 deletions
diff --git a/sys-libs/cracklib/cracklib-2.7-r1.ebuild b/sys-libs/cracklib/cracklib-2.7-r1.ebuild
new file mode 100644
index 000000000000..6665bb472bec
--- /dev/null
+++ b/sys-libs/cracklib/cracklib-2.7-r1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/cracklib/cracklib-2.7-r1.ebuild,v 1.1 2000/08/03 16:22:36 achim Exp $
+
+P=cracklib-2.7
+A=cracklib_2.7.tar.gz
+A0=${P}-redhat.patch
+S=${WORKDIR}/cracklib,2.7
+CATEGORY="sys-libs"
+DESCRIPTION="Cracklib"
+SRC_URI="ftp://gentoolinux.sourceforge.net/pub/gentoolinux/current/distfiles/"${A}
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ patch -p1 <${O}/files/${A0}
+ cp Makefile Makefile.orig
+# sed -e "s/DICTPATH=.*/DICTPATH=\"\/usr\/share\/cracklib\/pw_dict\"/" Makefile.orig > Makefile
+}
+
+src_compile() {
+ cd ${S}
+ make all
+}
+
+src_install() {
+ cd ${S}
+ into /usr
+ dodir /usr/lib
+ dodir /usr/sbin
+ dodir /usr/include
+ ROOT=${D} make install
+ dodoc HISTORY LICENCE MANIFEST POSTER README
+}
+
+
+
+
diff --git a/sys-libs/gdbm/gdbm-1.8.0-r1.ebuild b/sys-libs/gdbm/gdbm-1.8.0-r1.ebuild
new file mode 100644
index 000000000000..f011435770e2
--- /dev/null
+++ b/sys-libs/gdbm/gdbm-1.8.0-r1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Daniel Robbins <drobbins@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/gdbm/gdbm-1.8.0-r1.ebuild,v 1.1 2000/08/03 16:22:36 achim Exp $
+
+# FOR SOME REASON, THE CONFIGURE SCRIPT DOES NOT USE THE EXPORTED CFLAGS, SO
+# THIS LIBRARY ONLY HAS -O OPTS, WE WON'T WORRY ABOUT THIS FOR SUCH AN
+# INSIGNIFICANT LIB, but one day...
+
+P=gdbm-1.8.0
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+DESCRIPTION="Standard GNU database libraries included for compatibility with Perl"
+CATEGORY="sys-libs"
+SRC_URI="ftp://prep.ai.mit.edu/gnu/gdbm/gdbm-1.8.0.tar.gz"
+HOMEPAGE="http://www.gnu.org/software/gdbm/gdbm.html"
+
+src_compile() {
+ ./configure --host=${CHOST} --prefix=/usr
+ make
+}
+
+src_install() {
+ into /usr
+ dolib.a libgdbm.la .libs/libgdbm.a
+ dolib.so .libs/libgdbm.so.2.0.0
+ dosym libgdbm.so.2.0.0 /usr/lib/libgdbm.so.2
+ dosym libgdbm.so.2.0.0 /usr/lib/libgdbm.so
+ insinto /usr/include
+ doins gdbm.h
+ doman gdbm.3
+ doinfo gdbm.info
+ dodoc COPYING ChangeLog NEWS README
+}
+
+
+
diff --git a/sys-libs/gettext/gettext-0.10.35-r1.ebuild b/sys-libs/gettext/gettext-0.10.35-r1.ebuild
new file mode 100644
index 000000000000..ff956d358fec
--- /dev/null
+++ b/sys-libs/gettext/gettext-0.10.35-r1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Daniel Robbins <drobbins@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/gettext/gettext-0.10.35-r1.ebuild,v 1.1 2000/08/03 16:22:36 achim Exp $
+
+P=gettext-0.10.35
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+DESCRIPTION="GNU locale utilities"
+CATEGORY="sys-libs"
+SRC_URI="ftp://prep.ai.mit.edu/gnu/gettext/${A}"
+HOMEPAGE="http://www.gnu.org/software/gettext/gettext.html"
+
+src_compile() {
+ ./configure --prefix=/usr --with-included-gettext --host=${CHOST}
+ make
+}
+
+src_install() {
+ cd ${S}
+ make prefix=${D}/usr install
+ prepinfo
+ dodoc AUTHORS BUGS COPYING ChangeLog DISCLAIM NEWS README README-alpha THANKS TODO
+ exeopts -m0755
+ exeinto /usr/bin
+ doexe misc/gettextize
+}
+
+
diff --git a/sys-libs/glibc/glibc-2.1.3-r1.ebuild b/sys-libs/glibc/glibc-2.1.3-r1.ebuild
new file mode 100644
index 000000000000..f1a9238cdef6
--- /dev/null
+++ b/sys-libs/glibc/glibc-2.1.3-r1.ebuild
@@ -0,0 +1,88 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.1.3-r1.ebuild,v 1.1 2000/08/03 16:22:36 achim Exp $
+
+P=glibc-2.1.3
+A="glibc-2.1.3.tar.gz glibc-crypt-2.1.tar.gz
+ glibc-linuxthreads-2.1.3.tar.gz glibc-compat-2.1.2.tar.gz"
+S=${WORKDIR}/${P}
+DESCRIPTION="GNU libc6 (also called glibc2) C library"
+CATEGORY="sys-libs"
+SRC_URI="ftp://prep.ai.mit.edu/gnu/glibc/glibc-2.1.3.tar.gz
+ ftp://prep.ai.mit.edu/gnu/glibc/glibc-crypt-2.1.tar.gz
+ ftp://prep.ai.mit.edu/gnu/glibc/glibc-linuxthreads-2.1.3.tar.gz
+ ftp://jurix.jura.uni-sb.de/pub/linux/source/libc/glibc/glibc-compat-2.1.2.tar.gz"
+HOMEPAGE="http://www.gnu.org/software/libc/libc.html"
+
+src_compile() {
+ if [ "$CHOST" = "i686-pc-linux-gnu" ]
+ then
+ CHOST=i586-pc-linux-gnu #this is so there's no PII specific stuff
+ fi
+ rm -rf buildhere
+ mkdir buildhere
+ cd buildhere
+ ../configure --host=${CHOST} --without-cvs \
+ --enable-add-ons=linuxthreads,glibc-compat,crypt \
+ --disable-profile --prefix=/usr
+ make
+ make check
+}
+
+src_unpack() {
+ unpack glibc-2.1.3.tar.gz
+ cd ${S}
+ unpack glibc-crypt-2.1.tar.gz
+ unpack glibc-linuxthreads-2.1.3.tar.gz
+ unpack glibc-compat-2.1.2.tar.gz
+
+ # This patch is required to compile with binutils higher than
+ # 2.9.5.0.42
+ cp ${O}/files/setjmp.S ${S}/sysdeps/i386/elf/setjmp.S
+}
+
+src_install() {
+ cd ${S}
+ rm -rf ${D}
+ mkdir ${D}
+ dodir /etc/rc.d/init.d
+ make install_root=${D} install -C buildhere
+ make -C linuxthreads/man
+ mkdir -p ${D}/usr/man/man3
+ install -m 0644 linuxthreads/man/*.3thr ${D}/usr/man/man3
+ chmod 755 ${D}/usr/libexec/pt_chown
+ install -m 644 nscd/nscd.conf ${D}/etc
+ install -m 755 ${O}/files/nscd ${D}/etc/rc.d/init.d/nscd
+ dodir /var/db
+ install -m 644 nss/db-Makefile ${D}/var/db/Makefile
+ strip ${D}/sbin/*
+ strip ${D}/usr/bin/*
+ strip ${D}/usr/sbin/*
+ prepinfo
+ prepman
+ rm -rf documentation
+ mkdir documentation
+ mkdir documentation/html
+ cp linuxthreads/ChangeLog documentation/ChangeLog.threads
+ cp linuxthreads/Changes documentation/Changes.threads
+ cp linuxthreads/README documentation/README.threads
+ cp linuxthreads/FAQ.html documentation/html/FAQ-threads.html
+ cp crypt/README documentation/README.crypt
+ cp db2/README documentation/README.db2
+ cp db2/mutex/README documentation/README.db2.mutex
+ cp timezone/README documentation/README.timezone
+ cp ChangeLog* documentation
+ dodoc documentation/*
+ docinto html
+ dodoc documentation/html/*.html
+ dodir /usr/doc/${P}/examples.threads
+ install -m0644 linuxthreads/Examples/*.c ${D}/usr/doc/${P}/examples.threads
+ install -m0644 linuxthreads/Examples/Makefile ${D}/usr/doc/${P}/examples.threads
+ # Patch ucontext.h (needed for lynx, xfree)
+ cd ${D}/usr/include/sys
+ cp ucontext.h ucontext.h.orig
+ sed -e "s/ERR/GLIBCBUG/g" ucontext.h.orig > ucontext.h
+}
+
+
diff --git a/sys-libs/gpm/gpm-1.19.2-r1.ebuild b/sys-libs/gpm/gpm-1.19.2-r1.ebuild
new file mode 100644
index 000000000000..6a4d55310ddf
--- /dev/null
+++ b/sys-libs/gpm/gpm-1.19.2-r1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Daniel Robbins <drobbins@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/gpm/gpm-1.19.2-r1.ebuild,v 1.1 2000/08/03 16:22:36 achim Exp $
+
+P=gpm-1.19.2
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+CATEGORY="sys-libs"
+DESCRIPTION="Console-based mouse driver"
+SRC_URI="ftp://metalab.unc.edu/pub/Linux/system/mouse/${A}"
+
+src_compile() {
+ cd ${S}
+ ./configure --prefix=/usr
+ cp Makefile Makefile.orig
+ sed -e "s/doc//" Makefile.orig > Makefile
+ make
+}
+
+src_install() {
+ into /usr
+ dolib.a libgpm.a
+ dolib.so libgpm.so.1.18.0
+ dosym libgpm.so.1.18.0 /usr/lib/libgpm.so.1
+ dosym libgpm.so.1.18.0 /usr/lib/libgpm.so
+ dosbin gpm
+ dobin disable-paste gpm-root mev
+ insinto /usr/include
+ doins gpm.h
+ dodoc Announce COPYING ChangeLog FAQ MANIFEST README.* doc/gpmdoc.txt
+ doinfo doc/gpm.info
+ doman doc/*.1 doc/*.8 doc/*.7
+}
+
+
+
diff --git a/sys-libs/lib-compat/lib-compat-1.0-r1.ebuild b/sys-libs/lib-compat/lib-compat-1.0-r1.ebuild
new file mode 100644
index 000000000000..22eeac16a4d1
--- /dev/null
+++ b/sys-libs/lib-compat/lib-compat-1.0-r1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/lib-compat/lib-compat-1.0-r1.ebuild,v 1.1 2000/08/03 16:22:36 achim Exp $
+
+P=lib-compat-1.0
+A=lib-compat.tar.gz
+S=${WORKDIR}/${P}
+CATEGORY="sys-libs"
+DESCRIPTION="Compatibility c++ and libc5 libraries for programs new and old"
+SRC_URI="ftp://gentoolinux.sourceforge.net/pub/gentoolinux/current/distfiles/"${A}
+
+src_unpack () {
+ mkdir ${S}
+ cd ${S}
+ unpack ${A}
+}
+
+src_compile() {
+ echo
+}
+
+src_install() {
+ into /usr
+ dolib.so *.so*
+}
+
+
+
diff --git a/sys-libs/ncurses/ncurses-5.1-r1.ebuild b/sys-libs/ncurses/ncurses-5.1-r1.ebuild
new file mode 100644
index 000000000000..cf54b8124989
--- /dev/null
+++ b/sys-libs/ncurses/ncurses-5.1-r1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Daniel Robbins <drobbins@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/ncurses/ncurses-5.1-r1.ebuild,v 1.1 2000/08/03 16:22:36 achim Exp $
+
+P=ncurses-5.1
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+DESCRIPTION="Linux console display libarary"
+CATEGORY="sys-libs"
+SRC_URI="ftp://ftp.gnu.org/pub/gnu/ncurses/${A}"
+HOMEPAGE="http://www.gnu.org/software/ncurses/ncurses.html"
+
+src_compile() {
+ ./configure --prefix=/usr --enable-symlinks --disable-termcap \
+ --with-gpm --with-shared --without-debug --with-rcs-ids --host=${CHOST}
+ make
+}
+
+src_install() {
+ make prefix=${D}/usr install
+
+ if [ -z "$DBUG" ]
+ then
+ strip --strip-unneeded ${D}/usr/lib/*.so.5.1
+ strip ${D}/usr/bin/*
+ fi
+
+ #move to root so that we can use ncurses on boot
+ cd ${D}/usr/lib
+ dodir /lib
+ mv *.so* ../../lib
+ cd ${S}
+ dodoc ANNOUNCE MANIFEST NEWS README* TO-DO
+ dodoc doc/*.doc
+ docinto html
+ dodoc doc/html/*.html
+ docinto html/ada
+ dodoc doc/html/ada/*.htm
+ docinto html/ada/files
+ dodoc doc/html/ada/files/*.htm
+ docinto html/ada/funcs
+ dodoc doc/html/ada/funcs/*.htm
+ docinto html/man
+ dodoc doc/html/man/*.html
+ gzip ${D}/usr/man/man1/tack.1
+}
+
+
+
diff --git a/sys-libs/pam/pam-0.72-r1.ebuild b/sys-libs/pam/pam-0.72-r1.ebuild
new file mode 100644
index 000000000000..3a946d9af618
--- /dev/null
+++ b/sys-libs/pam/pam-0.72-r1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/pam/pam-0.72-r1.ebuild,v 1.1 2000/08/03 16:22:36 achim Exp $
+
+P=pam-0.72
+A=Linux-PAM-0.72.tar.gz
+S=${WORKDIR}/Linux-PAM-0.72
+CATEGORY="sys-libs"
+DESCRIPTION="PAM"
+SRC_URI="http://openrock.net/pub/linux/libs/pam/pre/library/${A}"
+HOMEPAGE="http://www.redhat.com/linux-info/pam/"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ rm default.defs
+ sed -e "s/CFLAGS=.*/CFLAGS=${CFLAGS} -pipe -D_REENTRANT/" \
+ -e "s:FAKEROOT=.*:FAKEROOT=${WORKDIR}/../image:" defs/linux.defs > default.defs
+ echo "EXTRALS=-lcrypt" >> default.defs
+ cp Makefile Makefile.orig
+ sed -e "s/DIRS = modules libpam/DIRS = libpam modules/" Makefile.orig > Makefile
+ cd modules/pam_mkhomedir
+ cp Makefile Makefile.orig
+ sed -e "s:-lpam:-L../../libpam -lpam:" Makefile.orig > Makefile
+
+}
+src_compile() {
+ make
+ make
+}
+
+src_install() {
+ cd ${S}
+ touch conf/.ignore_age
+ make install
+ dosbin bin/pam_conv1
+ dodoc CHANGELOG Copyright README
+ dodoc
+ cd ${D}/usr/lib
+ ln -sf libpamc.so.0.72 libpamc.so.0
+ ln -sf libpam.so.0.72 libpam.so.0
+ ln -sf libpam_misc.so.0.72 libpam_misc.so.0
+}
+
+
+
diff --git a/sys-libs/pwdb/pwdb-0.61-r1.ebuild b/sys-libs/pwdb/pwdb-0.61-r1.ebuild
new file mode 100644
index 000000000000..31fc7fea9c88
--- /dev/null
+++ b/sys-libs/pwdb/pwdb-0.61-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/pwdb/pwdb-0.61-r1.ebuild,v 1.1 2000/08/03 16:22:36 achim Exp $
+
+P=pwdb-0.61
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+CATEGORY="sys-libs"
+DESCRIPTION="Password Database"
+SRC_URI="ftp://gentoolinux.sourceforge.net/pub/gentoolinux/current/distfiles/${A}"
+
+src_unpack () {
+ mkdir ${S}
+ cd ${S}
+ unpack ${A}
+}
+src_compile() {
+ cd ${S}
+ cp Makefile Makefile.orig
+ sed -e "s/^DIRS = .*/DIRS = libpwdb/" Makefile.orig > Makefile
+ make
+}
+
+src_install() {
+ cd ${S}
+ into /usr
+ dodir /usr/include/pwdb
+ dodir /usr/lib
+ dodoc doc/pwdb.txt CHANGES Copyright CREDITS README
+ docinto html
+ dodoc doc/html/*
+ insinto /etc
+ doins conf/pwdb.conf
+ make INCLUDED=${D}/usr/include/pwdb LIBDIR=${D}/usr/lib install
+}
+
+
+
+
diff --git a/sys-libs/readline/readline-4.1-r1.ebuild b/sys-libs/readline/readline-4.1-r1.ebuild
new file mode 100644
index 000000000000..d93ca4b66cda
--- /dev/null
+++ b/sys-libs/readline/readline-4.1-r1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Daniel Robbins <drobbins@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/readline/readline-4.1-r1.ebuild,v 1.1 2000/08/03 16:22:36 achim Exp $
+
+P=readline-4.1
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+DESCRIPTION="Another cute console display library"
+CATEGORY="sys-libs"
+SRC_URI="ftp://ftp.gnu.org/gnu/readline/${A}"
+
+src_compile() {
+ ./configure --host=${CHOST} --with-curses --prefix=/usr
+ make
+ cd shlib
+ make
+ cd ..
+
+}
+
+src_install() {
+ cd ${S}
+ make prefix=${D}/usr install
+ cd shlib
+ make prefix=${D}/usr install
+ cd ..
+ prepman
+ prepinfo
+ dodoc CHANGELOG CHANGES COPYING INSTALL MANIFEST README USAGE
+ dodoc doc/*.ps
+ docinto html
+ dodoc doc/*.html
+ dosym libhistory.so.4.1 /usr/lib/libhistory.so.4
+ dosym libhistory.so.4.1 /usr/lib/libhistory.so
+ dosym libreadline.so.4.1 /usr/lib/libreadline.so.4
+ dosym libreadline.so.4.1 /usr/lib/libreadline.so
+}
+
+
+
diff --git a/sys-libs/slang/slang-1.4.1-r1.ebuild b/sys-libs/slang/slang-1.4.1-r1.ebuild
new file mode 100644
index 000000000000..bca7cdd9155f
--- /dev/null
+++ b/sys-libs/slang/slang-1.4.1-r1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Daniel Robbins <drobbins@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/slang/slang-1.4.1-r1.ebuild,v 1.1 2000/08/03 16:22:36 achim Exp $
+
+P=slang-1.4.1
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+DESCRIPTION="Console display library used by most text viewer"
+CATEGORY="sys-libs"
+SRC_URI="ftp://space.mit.edu/pub/davis/slang/v1.4/${A}"
+
+src_compile() {
+ ./configure --host=${CHOST} --prefix=/usr
+ make elf
+}
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ cp configure configure.orig
+ sed -e "s/ELF_CFLAGS=\"-O2/ELF_CFLAGS=\"${CFLAGS}/" configure.orig > configure
+}
+
+src_install() {
+ into /usr
+ libopts -m0755
+ dolib src/elfobjs/libslang.so.1.4.1
+ dosym libslang.so.1.4.1 /usr/lib/libslang.so.1
+ dosym libslang.so.1 /usr/lib/libslang.so
+ dodoc COPYING* NEWS README *.txt
+ dodoc doc/*.txt doc/internal/*.txt doc/text/*.txt
+ docinto html
+ dodoc doc/*.html
+ dodir /usr/include
+ insinto /usr/include
+ cd ${S}/src
+ doins slang.h slcurses.h
+}
+
+
+
diff --git a/sys-libs/zlib/zlib-1.1.3-r1.ebuild b/sys-libs/zlib/zlib-1.1.3-r1.ebuild
new file mode 100644
index 000000000000..8dd919f67038
--- /dev/null
+++ b/sys-libs/zlib/zlib-1.1.3-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Daniel Robbins <drobbins@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/zlib/zlib-1.1.3-r1.ebuild,v 1.1 2000/08/03 16:22:36 achim Exp $
+
+P=zlib-1.1.3
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+DESCRIPTION="Standard (de)compression library"
+CATEGORY="sys-libs"
+SRC_URI="ftp://ftp.freesoftware.com/pub/infozip/zlib/${A}"
+
+src_compile() {
+ cd ${S}
+ ./configure --shared --prefix=/usr
+ make
+ make test
+ ./configure --prefix=/usr
+ make
+}
+
+src_install() {
+ into /usr
+ dodir /usr/include
+ insinto /usr/include
+ doins zconf.h zlib.h
+ dolib libz.so.1.1.3
+ dolib libz.a
+ dosym libz.so.1.1.3 /usr/lib/libz.so
+ dosym libz.so.1.1.3 /usr/lib/libz.so.1
+ dodoc FAQ README algorithm.txt ChangeLog
+}
+