summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-analyzer/nb/ChangeLog8
-rw-r--r--net-analyzer/nb/files/nb-0.8.3-configure.patch49
-rw-r--r--net-analyzer/nb/nb-0.8.3.ebuild21
3 files changed, 69 insertions, 9 deletions
diff --git a/net-analyzer/nb/ChangeLog b/net-analyzer/nb/ChangeLog
index f25ec7e98b26..77661df27f19 100644
--- a/net-analyzer/nb/ChangeLog
+++ b/net-analyzer/nb/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-analyzer/nb
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nb/ChangeLog,v 1.10 2011/10/27 18:42:06 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nb/ChangeLog,v 1.11 2011/11/18 04:34:54 jer Exp $
+
+ 18 Nov 2011; Jeroen Roovers <jer@gentoo.org> nb-0.8.3.ebuild,
+ +files/nb-0.8.3-configure.patch:
+ Respect CFLAGS/LDFLAGS. Fix underlinking issue by using pkg-config to obtain
+ a list of libraries (bug #371893). Build nbTutorial.info without including
+ fdl.texi.
27 Oct 2011; Jeroen Roovers <jer@gentoo.org> nb-0.6.5-r1.ebuild,
nb-0.8.3.ebuild:
diff --git a/net-analyzer/nb/files/nb-0.8.3-configure.patch b/net-analyzer/nb/files/nb-0.8.3-configure.patch
new file mode 100644
index 000000000000..645c80d0279b
--- /dev/null
+++ b/net-analyzer/nb/files/nb-0.8.3-configure.patch
@@ -0,0 +1,49 @@
+1) Use pkg-config to figure out openssl libraries (also fixes underlinking with
+ ld.gold, bug #371893).
+2) Respect CFLAGS/LDFLAGS.
+
+-jer
+
+
+--- a/lib/configure.ac
++++ b/lib/configure.ac
+@@ -113,7 +113,7 @@
+ AC_CHECK_LIB([pcre],[pcre_compile],,[AC_MSG_ERROR(Required library -lpcre not found. You may want to download it from http://www.pcre.org or locate it and include directory in LD_LIBRARY_PATH to support this build.)])
+ AC_CHECK_LIB([readline],[readline],,[AC_MSG_ERROR(Required library -lreadline not found. You may want to download it from http://cnswww.cns.cwru.edu/php/chet/readline/rltop.html or locate it and include directory in LD_LIBRARY_PATH to support this build.)])
+ AC_CHECK_LIB(history,add_history,,[AC_MSG_ERROR(Required library -lhistory not found. You may want to download it from http://cnswww.cns.cwru.edu/php/chet/readline/rltop.html or locate it and include directory in LD_LIBRARY_PATH to support this build.)])
+-AC_CHECK_LIB(ssl,SSL_library_init,,[AC_MSG_ERROR(Required library -lssl not found. You may want to download it from http://cnswww.cns.cwru.edu/php/chet/readline/rltop.html or locate it and include directory in LD_LIBRARY_PATH to support this build.)])
++PKG_CHECK_MODULES(libssl,openssl,LIBS="$LIBS `$PKG_CONFIG --cflags --libs openssl`",[AC_MSG_ERROR(Required library -lssl not found. You may want to download it from http://www.openssl.org/ or locate it and include directory in LD_LIBRARY_PATH to support this build.)])
+
+ AC_SEARCH_LIBS(socket,socket)
+ AC_SEARCH_LIBS(inet_ntoa,nsl)
+@@ -152,8 +152,6 @@
+ # define a release date variable
+ AC_DEFINE_UNQUOTED(NB_COMPILE_PLATFORM,"$host",[Define compile platform])
+
+-CFLAGS="-Wall -I/usr/local/include -I/usr/local/ssl/include"
+-LDFLAGS="-L/usr/local/ssl/lib"
+ case "$host" in
+ *-netbsd*)
+ AC_DEFINE(NETBSD,,[Define if NetBSD])
+--- a/module/configure.ac
++++ b/module/configure.ac
+@@ -100,8 +100,6 @@
+
+ AC_SUBST([NB_MOD_PATH],[../.libs])
+
+-CFLAGS="-Wall -I/usr/local/include -I/usr/local/ssl/include"
+-LDFLAGS="-L/usr/local/ssl/lib"
+
+ #=====================================
+ # Checks for header files.
+--- a/module/webster/configure.ac
++++ b/module/webster/configure.ac
+@@ -87,8 +87,6 @@
+ # AC_PATH_PROGS([NB],[nb-0.7.5 nb-0.7.4 nb-0.7.3 nb-0.7.2 nb-0.7.1 nb])
+ #fi
+
+-CFLAGS="-I/usr/local/include -I/usr/local/ssl/include"
+-LDFLAGS="-L/usr/local/ssl/lib"
+
+ #=====================================
+ # Checks for libraries.
diff --git a/net-analyzer/nb/nb-0.8.3.ebuild b/net-analyzer/nb/nb-0.8.3.ebuild
index 68c1b729be61..7047d33016c5 100644
--- a/net-analyzer/nb/nb-0.8.3.ebuild
+++ b/net-analyzer/nb/nb-0.8.3.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nb/nb-0.8.3.ebuild,v 1.2 2011/10/27 18:42:06 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nb/nb-0.8.3.ebuild,v 1.3 2011/11/18 04:34:54 jer Exp $
EAPI="3"
-inherit autotools-utils
+inherit autotools autotools-utils eutils
DESCRIPTION="Nodebrain is a tool to monitor and do event correlation."
HOMEPAGE="http://nodebrain.sourceforge.net/"
@@ -15,7 +15,10 @@ SLOT="0"
KEYWORDS="~ppc ~x86"
IUSE="static-libs"
-DEPEND="dev-lang/perl"
+DEPEND="
+ dev-lang/perl
+ sys-apps/texinfo
+"
RDEPEND="
!sys-boot/netboot
!www-apps/nanoblogger
@@ -24,13 +27,16 @@ RDEPEND="
S="${WORKDIR}/nodebrain-${PV}"
src_prepare() {
- # Prevent make from rebuilding this target, since
- # fdl.texi is not included in the distribution
- touch doc/nbTutorial/nbTutorial.info || die
+ epatch "${FILESDIR}"/${P}-configure.patch
+
+ # fdl.texi is not included in the sources
+ sed -i doc/nbTutorial/nbTutorial.texi -e '/@include fdl.texi/d' || die
+
+ eautoreconf
}
src_configure() {
- econf $(use_enable static-libs static)
+ econf $(use_enable static-libs static) --include=/usr/include
}
src_compile() {
@@ -39,7 +45,6 @@ src_compile() {
}
src_install() {
- #DIR="${D}/usr" ./install-nb || die "install failed"
emake DESTDIR="${D}" install || die
use static-libs || remove_libtool_files
dodoc AUTHORS NEWS README THANKS sample/*