summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-ada/florist/ChangeLog8
-rw-r--r--dev-ada/florist/files/digest-florist-2006.03
-rw-r--r--dev-ada/florist/florist-2006.0.ebuild55
-rw-r--r--dev-ada/florist/metadata.xml11
4 files changed, 74 insertions, 3 deletions
diff --git a/dev-ada/florist/ChangeLog b/dev-ada/florist/ChangeLog
index 62fab29c1b3e..2bec451dc07e 100644
--- a/dev-ada/florist/ChangeLog
+++ b/dev-ada/florist/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-ada/florist
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ada/florist/ChangeLog,v 1.12 2007/01/25 23:52:28 genone Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ada/florist/ChangeLog,v 1.13 2007/02/03 22:25:57 george Exp $
+
+*florist-2006.0 (03 Feb 2007)
+
+ 03 Feb 2007; George Shapovalov <george@gentoo.org> metadata.xml,
+ +florist-2006.0.ebuild:
+ added new, new-style, version
26 Jan 2007; Marius Mauch <genone@gentoo.org> florist-3.15p.ebuild:
Replacing einfo with elog
diff --git a/dev-ada/florist/files/digest-florist-2006.0 b/dev-ada/florist/files/digest-florist-2006.0
new file mode 100644
index 000000000000..3dde39269d96
--- /dev/null
+++ b/dev-ada/florist/files/digest-florist-2006.0
@@ -0,0 +1,3 @@
+MD5 debe281880d5ef7fe1f46ddfb119e715 florist-2006.0.tar.bz2 177530
+RMD160 ee8956074a7ec04e69d24447551f6ae5a8e3285a florist-2006.0.tar.bz2 177530
+SHA256 ed379c0e1f5d57342dfb199b014ec5ce41cc81d109951de00f8ea2757e433d10 florist-2006.0.tar.bz2 177530
diff --git a/dev-ada/florist/florist-2006.0.ebuild b/dev-ada/florist/florist-2006.0.ebuild
new file mode 100644
index 000000000000..f82d292c4e1b
--- /dev/null
+++ b/dev-ada/florist/florist-2006.0.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ada/florist/florist-2006.0.ebuild,v 1.1 2007/02/03 22:25:57 george Exp $
+
+inherit gnat libtool
+
+IUSE=""
+
+DESCRIPTION="Posix bindings for Ada"
+HOMEPAGE="http://libre2.adacore.com/"
+SRC_URI="http://dev.gentoo.org/~george/src/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+
+DEPEND="virtual/gnat"
+
+
+lib_compile()
+{
+ elibtoolize
+ econf || die "econf failed"
+ emake || die "make failed"
+ make floristlib || die "building library failed"
+ einfo "lib_compile completed"
+}
+
+# NOTE: we are using $1 - the passed gnat profile name
+lib_install()
+{
+ # install goal is just (access violating) mkdir and 2 cp's
+ # instead move stuff properly here
+ cp -rp ${SL}/floristlib/{libflorist.a,*.ali} ${DL}
+ chmod 0444 ${DL}/*.ali
+}
+
+src_install ()
+{
+ cd ${S}
+ # install sources
+ dodir ${AdalibSpecsDir}/${PN}
+ insinto ${AdalibSpecsDir}/${PN}
+ doins -r *.ad{b,s} *.c *.gpb gnatsocks/
+
+ #set up environment
+ #echo "PATH=%DL%/bin" > ${LibEnv}
+ echo "LDPATH=%DL%" >> ${LibEnv}
+ echo "ADA_OBJECTS_PATH=%DL%" >> ${LibEnv}
+ echo "ADA_INCLUDE_PATH=/usr/include/ada/${PN}" >> ${LibEnv}
+
+ gnat_src_install
+
+ dodoc COPYING README
+}
diff --git a/dev-ada/florist/metadata.xml b/dev-ada/florist/metadata.xml
index 11e4d0de53dd..2a8540864847 100644
--- a/dev-ada/florist/metadata.xml
+++ b/dev-ada/florist/metadata.xml
@@ -1,6 +1,13 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<herd>ada</herd>
-<longdescription>Florist is the (F)lorida (S)tate (U)niversity open-source implementaton of IEEE Standard 1003.5b-1996, the POSIX Ada binding, including real-time extensions. This software provides access to the UNIX operating system services for application programs written in the Ada programming language. It is designed to be self-configuring for a POSIX-compliant system. A suite of test programs is included.</longdescription>
+ <herd>ada</herd>
+ <longdescription>
+ Florist is the (F)lorida (S)tate (U)niversity open-source implementaton
+ of IEEE Standard 1003.5b-1996, the POSIX Ada binding, including real-time
+ extensions. This software provides access to the UNIX operating system services
+ for application programs written in the Ada programming language. It is
+ designed to be self-configuring for a POSIX-compliant system. A suite of
+ test programs is included.
+ </longdescription>
</pkgmetadata>