summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-www/mplayerplug-in/ChangeLog7
-rw-r--r--net-www/mplayerplug-in/files/digest-mplayerplug-in-3.313
-rw-r--r--net-www/mplayerplug-in/mplayerplug-in-3.31.ebuild81
3 files changed, 90 insertions, 1 deletions
diff --git a/net-www/mplayerplug-in/ChangeLog b/net-www/mplayerplug-in/ChangeLog
index 79ba29594659..82a1e227d2ec 100644
--- a/net-www/mplayerplug-in/ChangeLog
+++ b/net-www/mplayerplug-in/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-www/mplayerplug-in
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/mplayerplug-in/ChangeLog,v 1.67 2006/08/06 15:18:28 josejx Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/mplayerplug-in/ChangeLog,v 1.68 2006/08/29 17:26:00 josejx Exp $
+
+*mplayerplug-in-3.31 (29 Aug 2006)
+
+ 29 Aug 2006; Joseph Jezak <josejx@gentoo.org> +mplayerplug-in-3.31.ebuild:
+ Added latest version.
*mplayerplug-in-3.30 (06 Aug 2006)
diff --git a/net-www/mplayerplug-in/files/digest-mplayerplug-in-3.31 b/net-www/mplayerplug-in/files/digest-mplayerplug-in-3.31
new file mode 100644
index 000000000000..5d15b045462e
--- /dev/null
+++ b/net-www/mplayerplug-in/files/digest-mplayerplug-in-3.31
@@ -0,0 +1,3 @@
+MD5 be26b17cde385c7a34fc634d2c88c5c9 mplayerplug-in-3.31.tar.gz 211714
+RMD160 eea819f428dd8797387b11e5dbfda010cc36a2e9 mplayerplug-in-3.31.tar.gz 211714
+SHA256 359b33927eb2837a544592afc00b55671e02694a8c54d3e7af3c81600bc38885 mplayerplug-in-3.31.tar.gz 211714
diff --git a/net-www/mplayerplug-in/mplayerplug-in-3.31.ebuild b/net-www/mplayerplug-in/mplayerplug-in-3.31.ebuild
new file mode 100644
index 000000000000..e25d97ecf491
--- /dev/null
+++ b/net-www/mplayerplug-in/mplayerplug-in-3.31.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-www/mplayerplug-in/mplayerplug-in-3.31.ebuild,v 1.1 2006/08/29 17:26:00 josejx Exp $
+
+inherit eutils multilib nsplugins
+
+DESCRIPTION="mplayer plug-in for Gecko based browsers"
+HOMEPAGE="http://mplayerplug-in.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 -hppa ~ia64 ~ppc ~sparc ~x86"
+IUSE="gtk"
+
+DEPEND=">=media-video/mplayer-1.0_pre5
+ || ( www-client/mozilla-firefox
+ www-client/seamonkey
+ )
+ || ( ( x11-libs/libXpm
+ x11-proto/xextproto
+ )
+ virtual/x11
+ )
+ gtk? (
+ >=x11-libs/gtk+-2.2.0
+ dev-libs/atk
+ >=dev-libs/glib-2.2.0
+ >=x11-libs/pango-1.2.1
+ )"
+
+S=${WORKDIR}/${PN}
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/3.30-fix-cflags.patch
+}
+
+src_compile() {
+ local myconf
+
+ # We force gtk2 now because moz only compiles against gtk2
+ if use gtk; then
+ myconf="${myconf} --enable-gtk2"
+ else
+ ewarn "For playback controls, you must enable gtk support."
+ myconf="${myconf} --enable-x"
+ fi
+
+ econf ${myconf} || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ exeinto /opt/netscape/plugins
+ doexe mplayerplug-in.so || die "plugin failed"
+ inst_plugin /opt/netscape/plugins/mplayerplug-in.so
+
+ insinto /opt/netscape/plugins
+ doins mplayerplug-in.xpt || die "xpt failed"
+ inst_plugin /opt/netscape/plugins/mplayerplug-in.xpt
+
+ PLUGINS="gmp rm qt wmp"
+
+ for plugin in ${PLUGINS}; do
+ ### Install the plugin
+ exeinto /opt/netscape/plugins
+ doexe "mplayerplug-in-${plugin}.so" || die "plugin ${plugin} failed"
+ inst_plugin "/opt/netscape/plugins/mplayerplug-in-${plugin}.so"
+ ### Install the xpt
+ insinto /opt/netscape/plugins
+ doins "mplayerplug-in-${plugin}.xpt" || die "plugin ${plugin} xpt failed"
+ inst_plugin "/opt/netscape/plugins/mplayerplug-in-${plugin}.xpt"
+ done
+
+ insinto /etc
+ doins mplayerplug-in.conf
+
+ dodoc ChangeLog INSTALL README DOCS/tech/*.txt
+}