summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-lang/tk/ChangeLog7
-rw-r--r--dev-lang/tk/files/tk-configure-LANG.patch41
-rw-r--r--dev-lang/tk/tk-8.4.11-r1.ebuild21
-rw-r--r--dev-lang/tk/tk-8.4.11.ebuild9
-rw-r--r--dev-lang/tk/tk-8.4.9.ebuild8
5 files changed, 76 insertions, 10 deletions
diff --git a/dev-lang/tk/ChangeLog b/dev-lang/tk/ChangeLog
index d048d028948b..ff9f909c2d78 100644
--- a/dev-lang/tk/ChangeLog
+++ b/dev-lang/tk/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-lang/tk
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/tk/ChangeLog,v 1.64 2006/01/30 07:15:01 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/tk/ChangeLog,v 1.65 2006/02/08 04:07:10 vapier Exp $
+
+ 03 Feb 2006; Mike Frysinger <vapier@gentoo.org>
+ +files/tk-configure-LANG.patch, tk-8.4.9.ebuild, tk-8.4.11.ebuild,
+ tk-8.4.11-r1.ebuild:
+ Fix nls breakage #120133 by J.
30 Jan 2006; Michael Sterrett <mr_bones_@gentoo.org> tk-8.4.6.ebuild,
tk-8.4.6-r1.ebuild, tk-8.4.9.ebuild:
diff --git a/dev-lang/tk/files/tk-configure-LANG.patch b/dev-lang/tk/files/tk-configure-LANG.patch
new file mode 100644
index 000000000000..3ef76ef911c0
--- /dev/null
+++ b/dev-lang/tk/files/tk-configure-LANG.patch
@@ -0,0 +1,41 @@
+The LANG vars aren't reset early enough so when sed tries to use [a-zA-Z] in
+option parsing, it may break.
+
+http://bugs.gentoo.org/103483
+
+--- configure
++++ configure
+@@ -54,6 +54,16 @@
+ infodir='${prefix}/info'
+ mandir='${prefix}/man'
+
++# NLS nuisances.
++# Only set these to C if already set. These must not be set unconditionally
++# because not all systems understand e.g. LANG=C (notably SCO).
++# Fixing LC_MESSAGES prevents Solaris sh from translating var values in `set'!
++# Non-C LC_CTYPE values break the ctype check.
++if test "${LANG+set}" = set; then LANG=C; export LANG; fi
++if test "${LC_ALL+set}" = set; then LC_ALL=C; export LC_ALL; fi
++if test "${LC_MESSAGES+set}" = set; then LC_MESSAGES=C; export LC_MESSAGES; fi
++if test "${LC_CTYPE+set}" = set; then LC_CTYPE=C; export LC_CTYPE; fi
++
+ # Initialize some other variables.
+ subdirs=
+ MFLAGS= MAKEFLAGS=
+@@ -452,16 +463,6 @@
+ esac
+ done
+
+-# NLS nuisances.
+-# Only set these to C if already set. These must not be set unconditionally
+-# because not all systems understand e.g. LANG=C (notably SCO).
+-# Fixing LC_MESSAGES prevents Solaris sh from translating var values in `set'!
+-# Non-C LC_CTYPE values break the ctype check.
+-if test "${LANG+set}" = set; then LANG=C; export LANG; fi
+-if test "${LC_ALL+set}" = set; then LC_ALL=C; export LC_ALL; fi
+-if test "${LC_MESSAGES+set}" = set; then LC_MESSAGES=C; export LC_MESSAGES; fi
+-if test "${LC_CTYPE+set}" = set; then LC_CTYPE=C; export LC_CTYPE; fi
+-
+ # confdefs.h avoids OS command line length limits that DEFS can exceed.
+ rm -rf conftest* confdefs.h
+ # AIX cpp loses on an empty file, so make sure it contains at least a newline.
diff --git a/dev-lang/tk/tk-8.4.11-r1.ebuild b/dev-lang/tk/tk-8.4.11-r1.ebuild
index 671bb2537cb2..7a538bab1b60 100644
--- a/dev-lang/tk/tk-8.4.11-r1.ebuild
+++ b/dev-lang/tk/tk-8.4.11-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/tk/tk-8.4.11-r1.ebuild,v 1.1 2006/01/08 14:13:22 matsuu Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/tk/tk-8.4.11-r1.ebuild,v 1.2 2006/02/08 04:07:10 vapier Exp $
inherit eutils
@@ -39,17 +39,24 @@ pkg_setup() {
src_unpack() {
unpack ${A}
- cd ${S}
- epatch ${FILESDIR}/remove-control-v-8.4.9.diff
- epatch ${FILESDIR}/${PN}-8.4.9-man.patch
- epatch ${FILESDIR}/${P}-multilib.patch
+ cd "${S}"
+ epatch "${FILESDIR}"/remove-control-v-8.4.9.diff
+ epatch "${FILESDIR}"/${PN}-8.4.9-man.patch
+ epatch "${FILESDIR}"/${P}-multilib.patch
# Bug 117982
sed -i -e "s/relid'/relid/" "${S}"/unix/{configure,tcl.m4} || die
+
+ local d
+ for d in */configure ; do
+ cd "${S}"/${d%%/*}
+ EPATCH_SINGLE_MSG="Patching nls cruft in ${d}" \
+ epatch "${FILESDIR}"/tk-configure-LANG.patch
+ done
}
src_compile() {
- cd ${S}/unix
+ cd "${S}"/unix
local mylibdir=$(get_libdir) ; mylibdir=${mylibdir//\/}
local local_config_use=""
@@ -70,7 +77,7 @@ src_install() {
local v1
v1=${PV%.*}
- cd ${S}/unix
+ cd "${S}"/unix
make DESTDIR=${D} install || die
# fix the tkConfig.sh to eliminate refs to the build directory
diff --git a/dev-lang/tk/tk-8.4.11.ebuild b/dev-lang/tk/tk-8.4.11.ebuild
index f92545e10a13..06fabaaed31e 100644
--- a/dev-lang/tk/tk-8.4.11.ebuild
+++ b/dev-lang/tk/tk-8.4.11.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/tk/tk-8.4.11.ebuild,v 1.4 2006/01/02 21:27:48 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/tk/tk-8.4.11.ebuild,v 1.5 2006/02/08 04:07:10 vapier Exp $
inherit eutils
@@ -43,6 +43,13 @@ src_unpack() {
epatch ${FILESDIR}/remove-control-v-8.4.9.diff
epatch ${FILESDIR}/${PN}-8.4.9-man.patch
epatch ${FILESDIR}/${P}-multilib.patch
+
+ local d
+ for d in */configure ; do
+ cd "${S}"/${d%%/*}
+ EPATCH_SINGLE_MSG="Patching nls cruft in ${d}" \
+ epatch "${FILESDIR}"/tk-configure-LANG.patch
+ done
}
src_compile() {
diff --git a/dev-lang/tk/tk-8.4.9.ebuild b/dev-lang/tk/tk-8.4.9.ebuild
index 3edf1df85fc1..247518fd4699 100644
--- a/dev-lang/tk/tk-8.4.9.ebuild
+++ b/dev-lang/tk/tk-8.4.9.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/tk/tk-8.4.9.ebuild,v 1.12 2006/01/30 07:15:02 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/tk/tk-8.4.9.ebuild,v 1.13 2006/02/08 04:07:10 vapier Exp $
inherit eutils
@@ -42,6 +42,12 @@ src_unpack() {
cd ${S}
epatch ${FILESDIR}/remove-control-v-${PV}.diff || die
epatch ${FILESDIR}/${P}-man.patch || die
+ local d
+ for d in */configure ; do
+ cd "${S}"/${d%%/*}
+ EPATCH_SINGLE_MSG="Patching nls cruft in ${d}" \
+ epatch "${FILESDIR}"/tk-configure-LANG.patch
+ done
}
src_compile() {