summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--games-action/btanks/ChangeLog10
-rw-r--r--games-action/btanks/Manifest16
-rw-r--r--games-action/btanks/btanks-0.5.4740.ebuild52
-rw-r--r--games-action/btanks/files/digest-btanks-0.5.47403
-rw-r--r--games-action/btanks/metadata.xml13
5 files changed, 94 insertions, 0 deletions
diff --git a/games-action/btanks/ChangeLog b/games-action/btanks/ChangeLog
new file mode 100644
index 000000000000..e308b7a9740c
--- /dev/null
+++ b/games-action/btanks/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for games-action/btanks
+# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-action/btanks/ChangeLog,v 1.1 2007/08/20 23:41:14 tupone Exp $
+
+*btanks-0.5.4740 (20 Aug 2007)
+
+ 20 Aug 2007; Tupone Alfredo <tupone@gentoo.org> +metadata.xml,
+ +btanks-0.5.4740.ebuild:
+ New ebuild requested via bug #172772 by Maks Polunin
+
diff --git a/games-action/btanks/Manifest b/games-action/btanks/Manifest
new file mode 100644
index 000000000000..f89f3000336a
--- /dev/null
+++ b/games-action/btanks/Manifest
@@ -0,0 +1,16 @@
+DIST btanks-0.5.4740.tar.bz2 47302958 RMD160 adcced45f120a26de0a36a88849232231535bd7f SHA1 ff62c7adb3a3008c349623514ef8acd18568ab2e SHA256 2eb3d691f84c3933bde270212ad71565e168a5b67fe7332b3bc8fac1de232403
+EBUILD btanks-0.5.4740.ebuild 1252 RMD160 662f7aef30ec981d075cd77cb039e63ec81ecbef SHA1 d3bd8730eb63ebdea8cfc144ccbded2054f0cccc SHA256 ff18ff94d340dd5a3c62f55a7524c308d39cfe2e30b65e3126e95c4e33054669
+MD5 7a951f9f61251068bc8949f557fae1a4 btanks-0.5.4740.ebuild 1252
+RMD160 662f7aef30ec981d075cd77cb039e63ec81ecbef btanks-0.5.4740.ebuild 1252
+SHA256 ff18ff94d340dd5a3c62f55a7524c308d39cfe2e30b65e3126e95c4e33054669 btanks-0.5.4740.ebuild 1252
+MISC ChangeLog 300 RMD160 438afc3343327f62cb1dd5015eebde80c0d930ed SHA1 fcf36c2a8efcad960f7ddd104eea6709f3649856 SHA256 1a4e461962d267bfe05ff9355efbf09bebd263803b536b853956dfa7bd1d28a7
+MD5 b9d5d851f8c4a8295d941cc521562bad ChangeLog 300
+RMD160 438afc3343327f62cb1dd5015eebde80c0d930ed ChangeLog 300
+SHA256 1a4e461962d267bfe05ff9355efbf09bebd263803b536b853956dfa7bd1d28a7 ChangeLog 300
+MISC metadata.xml 602 RMD160 7bcf0da779e8e1cc2a225f25cba147e7d743d671 SHA1 2a04ca616e925cb64cd5df0f4dd96e1512b4aeb0 SHA256 f2fba9fde47806ea5f4d7a16dfe1a5edd4869619118f28a30a91ec8a629cfb2c
+MD5 9c9f7d14dde57ff55c042998e68c2ec5 metadata.xml 602
+RMD160 7bcf0da779e8e1cc2a225f25cba147e7d743d671 metadata.xml 602
+SHA256 f2fba9fde47806ea5f4d7a16dfe1a5edd4869619118f28a30a91ec8a629cfb2c metadata.xml 602
+MD5 05f99c3218c1b22fe2f337775e760d7f files/digest-btanks-0.5.4740 256
+RMD160 d6c696a3dda2290fb02c5c19b93301f7b279de1e files/digest-btanks-0.5.4740 256
+SHA256 43ebdcfe7d03155a5765384aca5d82c6e48b481bbdc2b33b78f67046c806c25d files/digest-btanks-0.5.4740 256
diff --git a/games-action/btanks/btanks-0.5.4740.ebuild b/games-action/btanks/btanks-0.5.4740.ebuild
new file mode 100644
index 000000000000..20001f4af8e3
--- /dev/null
+++ b/games-action/btanks/btanks-0.5.4740.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-action/btanks/btanks-0.5.4740.ebuild,v 1.1 2007/08/20 23:41:14 tupone Exp $
+
+inherit eutils games
+
+DESCRIPTION="Fast 2D tank arcade game with multiplayer and split-screen modes"
+HOMEPAGE="http://btanks.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND=">=dev-libs/libsigc++-2.0
+ media-libs/openal
+ media-libs/libsdl
+ media-libs/libvorbis
+ virtual/opengl
+ dev-libs/expat
+ media-libs/sdl-image"
+DEPEND="${RDEPEND}
+ dev-util/scons"
+
+src_compile() {
+ scons \
+ mode="release" \
+ prefix=/usr \
+ resources_dir="${GAMES_DATADIR}/${PN}" \
+ || die "scons"
+}
+
+src_install() {
+ newgamesbin bt ${PN}.bin || die "newgamesbin"
+
+ insinto "$(games_get_libdir)"/${PN}
+ doins lib{mrt,bt,sdlx}.so || die "doins for lib.so failed"
+
+ exeinto "${GAMES_DATADIR}/${PN}"
+ doexe libbt_objects.so || die "doins for libbt_objects.so failed"
+ insinto "${GAMES_DATADIR}/${PN}"
+ doins -r data || die "doins for data failed"
+ dodoc ChangeLog *.txt
+
+ games_make_wrapper ${PN} ${PN}.bin "${GAMES_DATADIR}/${PN}" \
+ "$(games_get_libdir)/${PN}"
+ newicon src/bt.xpm ${PN}.xpm || die "newicon"
+ make_desktop_entry ${PN} "Battle Tanks" ${PN}.xpm
+
+ prepgamesdirs
+}
diff --git a/games-action/btanks/files/digest-btanks-0.5.4740 b/games-action/btanks/files/digest-btanks-0.5.4740
new file mode 100644
index 000000000000..689fd211413a
--- /dev/null
+++ b/games-action/btanks/files/digest-btanks-0.5.4740
@@ -0,0 +1,3 @@
+MD5 ab532befed2166a1f722ec1a59df926b btanks-0.5.4740.tar.bz2 47302958
+RMD160 adcced45f120a26de0a36a88849232231535bd7f btanks-0.5.4740.tar.bz2 47302958
+SHA256 2eb3d691f84c3933bde270212ad71565e168a5b67fe7332b3bc8fac1de232403 btanks-0.5.4740.tar.bz2 47302958
diff --git a/games-action/btanks/metadata.xml b/games-action/btanks/metadata.xml
new file mode 100644
index 000000000000..6c1c6f79dbc5
--- /dev/null
+++ b/games-action/btanks/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>games</herd>
+<longdescription lang="en">
+"Battle Tanks" is a funny battle on your desk, where you can choose one of three
+vehicles and eliminate your enemy using the whole arsenal of weapons. It has
+original cartoon-like graphics and cool music, it's fun and dynamic, it has
+several network modes for deathmatch and cooperative --- what else is needed to
+have fun with your friends? And all is packed and ready for you in "Battle
+Tanks".
+</longdescription>
+</pkgmetadata>