summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-db/xbase/ChangeLog9
-rw-r--r--dev-db/xbase/files/xbase-2.0.0-fixconfig.patch11
-rw-r--r--dev-db/xbase/files/xbase-2.0.0-fixheader.patch11
-rw-r--r--dev-db/xbase/files/xbase-2.0.0-gcc43.patch573
-rw-r--r--dev-db/xbase/files/xbase-2.0.0-gcc47.patch21
-rw-r--r--dev-db/xbase/files/xbase-2.0.0-x86_64.patch12
-rw-r--r--dev-db/xbase/xbase-2.0.0-r1.ebuild42
-rw-r--r--dev-db/xbase/xbase-2.0.0-r2.ebuild49
-rw-r--r--dev-db/xbase/xbase-2.0.0.ebuild38
9 files changed, 8 insertions, 758 deletions
diff --git a/dev-db/xbase/ChangeLog b/dev-db/xbase/ChangeLog
index 0c9f38b43386..2cb9046ba224 100644
--- a/dev-db/xbase/ChangeLog
+++ b/dev-db/xbase/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-db/xbase
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/xbase/ChangeLog,v 1.34 2012/08/15 11:00:48 blueness Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/xbase/ChangeLog,v 1.35 2012/12/27 14:13:32 kensington Exp $
+
+ 27 Dec 2012; Michael Palimaka <kensington@gentoo.org>
+ -files/xbase-2.0.0-fixconfig.patch, -files/xbase-2.0.0-fixheader.patch,
+ -files/xbase-2.0.0-gcc43.patch, -files/xbase-2.0.0-gcc47.patch,
+ -files/xbase-2.0.0-x86_64.patch, -xbase-2.0.0-r1.ebuild,
+ -xbase-2.0.0-r2.ebuild, -xbase-2.0.0.ebuild:
+ Remove old.
15 Aug 2012; Anthony G. Basile <blueness@gentoo.org> xbase-3.1.2.ebuild:
Stable ppc, bug #428926
diff --git a/dev-db/xbase/files/xbase-2.0.0-fixconfig.patch b/dev-db/xbase/files/xbase-2.0.0-fixconfig.patch
deleted file mode 100644
index 99a023976c6f..000000000000
--- a/dev-db/xbase/files/xbase-2.0.0-fixconfig.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- xbase-2.0.0/xbase-config.in.BAD 2005-07-10 08:38:03.000000000 -0500
-+++ xbase-2.0.0/xbase-config.in 2005-07-10 08:37:25.000000000 -0500
-@@ -5,7 +5,7 @@
- exec_prefix_set=no
- CC="@CC@"
- CXX="@CXX@"
--LD="@SHARED_LD@"
-+LD="@LD@"
-
- usage="\
- Usage: xbase-config [--prefix[=DIR]] [--exec-prefix[=DIR]] [--version] [--libs] [--cflags] [--cc] [--cxx] [--ld]"
diff --git a/dev-db/xbase/files/xbase-2.0.0-fixheader.patch b/dev-db/xbase/files/xbase-2.0.0-fixheader.patch
deleted file mode 100644
index fad32ac516f8..000000000000
--- a/dev-db/xbase/files/xbase-2.0.0-fixheader.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- xbase-2.0.0/xbase/ntx.h.BAD 2006-06-04 08:36:08.000000000 -0500
-+++ xbase-2.0.0/xbase/ntx.h 2006-06-04 08:36:13.000000000 -0500
-@@ -218,7 +218,7 @@
- xbShort KeyExists( char * Key ) { return FindKey( Key, strlen( Key ), 0 ); }
- xbShort KeyExists( xbDouble );
-
-- xbShort xbNtx::AllocKeyBufs(void);
-+ xbShort AllocKeyBufs(void);
-
- virtual void GetExpression(char *buf, int len);
- };
diff --git a/dev-db/xbase/files/xbase-2.0.0-gcc43.patch b/dev-db/xbase/files/xbase-2.0.0-gcc43.patch
deleted file mode 100644
index 933682a2cb49..000000000000
--- a/dev-db/xbase/files/xbase-2.0.0-gcc43.patch
+++ /dev/null
@@ -1,573 +0,0 @@
-diff -up xbase-2.0.0/xbase/xbstring.h.gcc43 xbase-2.0.0/xbase/xbstring.h
---- xbase-2.0.0/xbase/xbstring.h.gcc43 2001-01-27 06:00:32.000000000 +0100
-+++ xbase-2.0.0/xbase/xbstring.h 2008-03-11 20:21:20.000000000 +0100
-@@ -56,7 +56,7 @@
- #endif
-
- #include <stdlib.h>
--#include <iostream.h>
-+#include <iostream>
-
- /*! \file xbstring.h
- */
-@@ -119,7 +119,7 @@ public:
- bool operator <= ( const xbString& ) const;
- bool operator >= ( const xbString& ) const;
-
-- friend ostream& operator << ( ostream&, const xbString& );
-+ friend std::ostream& operator << ( std::ostream&, const xbString& );
-
- xbString &remove(size_t pos = 0, int n = npos);
- xbString mid(size_t pos = 0, int n = npos) const;
-diff -up xbase-2.0.0/xbase/dbf.cpp.gcc43 xbase-2.0.0/xbase/dbf.cpp
---- xbase-2.0.0/xbase/dbf.cpp.gcc43 2008-03-11 20:24:01.000000000 +0100
-+++ xbase-2.0.0/xbase/dbf.cpp 2008-03-11 20:25:01.000000000 +0100
-@@ -79,6 +79,9 @@
-
- #include <xbase/xbexcept.h>
-
-+using std::cout;
-+using std::endl;
-+
- /*! \file dbf.cpp
- */
-
-diff -up xbase-2.0.0/xbase/xbstring.cpp.gcc43 xbase-2.0.0/xbase/xbstring.cpp
---- xbase-2.0.0/xbase/xbstring.cpp.gcc43 2008-03-11 20:33:00.000000000 +0100
-+++ xbase-2.0.0/xbase/xbstring.cpp 2008-03-11 20:33:00.000000000 +0100
-@@ -582,7 +582,7 @@ bool xbString::operator>=( const xbStrin
- //! Short description.
- /*!
- */
--XBDLLEXPORT ostream& operator << ( ostream& os, const xbString& xbs ) {
-+XBDLLEXPORT std::ostream& operator << ( std::ostream& os, const xbString& xbs ) {
- return os << xbs.data;
- }
-
-diff -up xbase-2.0.0/xbase/exp.cpp.gcc43 xbase-2.0.0/xbase/exp.cpp
---- xbase-2.0.0/xbase/exp.cpp.gcc43 2008-03-11 20:23:54.000000000 +0100
-+++ xbase-2.0.0/xbase/exp.cpp 2008-03-11 20:24:30.000000000 +0100
-@@ -64,6 +64,8 @@
-
- #include <xbase/xbexcept.h>
-
-+using std::cout;
-+
- /*! \file exp.cpp
- */
-
-diff -up xbase-2.0.0/xbase/html.cpp.gcc43 xbase-2.0.0/xbase/html.cpp
---- xbase-2.0.0/xbase/html.cpp.gcc43 2008-03-11 20:27:18.000000000 +0100
-+++ xbase-2.0.0/xbase/html.cpp 2008-03-11 20:28:56.000000000 +0100
-@@ -68,6 +68,9 @@
-
- #include <xbase/xbexcept.h>
-
-+using std::cout;
-+using std::endl;
-+
- /*! \file html.cpp
- */
-
-diff -up xbase-2.0.0/xbase/ntx.cpp.gcc43 xbase-2.0.0/xbase/ntx.cpp
---- xbase-2.0.0/xbase/ntx.cpp.gcc43 2008-03-11 20:33:48.000000000 +0100
-+++ xbase-2.0.0/xbase/ntx.cpp 2008-03-11 20:33:59.000000000 +0100
-@@ -75,6 +75,9 @@
-
- #include <xbase/xbexcept.h>
-
-+using std::cout;
-+using std::endl;
-+
- /*! \file ntx.cpp
- */
-
-diff -up xbase-2.0.0/xbase/xbase.cpp.gcc43 xbase-2.0.0/xbase/xbase.cpp
---- xbase-2.0.0/xbase/xbase.cpp.gcc43 2008-03-11 20:32:08.000000000 +0100
-+++ xbase-2.0.0/xbase/xbase.cpp 2008-03-11 20:32:08.000000000 +0100
-@@ -62,6 +62,9 @@
-
- #include <xbase/xbexcept.h>
-
-+using std::cout;
-+using std::endl;
-+
- /*! \file xbase.cpp
- */
-
-diff -up xbase-2.0.0/xbase/stack.cpp.gcc43 xbase-2.0.0/xbase/stack.cpp
---- xbase-2.0.0/xbase/stack.cpp.gcc43 2000-11-10 20:04:17.000000000 +0100
-+++ xbase-2.0.0/xbase/stack.cpp 2008-03-11 20:31:16.000000000 +0100
-@@ -59,10 +59,12 @@
-
- #include <string.h>
- #include <stdlib.h>
--#include <iostream.h>
-+#include <iostream>
-
- #include <xbase/xstack.h>
-
-+using std::cout;
-+
- /*! \file stack.cpp
- */
-
-diff -up xbase-2.0.0/xbase/ndx.cpp.gcc43 xbase-2.0.0/xbase/ndx.cpp
---- xbase-2.0.0/xbase/ndx.cpp.gcc43 2001-03-21 01:28:53.000000000 +0100
-+++ xbase-2.0.0/xbase/ndx.cpp 2008-03-11 20:21:20.000000000 +0100
-@@ -66,7 +66,9 @@
- #endif
-
- #include <xbase/xbase.h>
--#include <iostream.h>
-+#include <iostream>
-+
-+using std::cout;
-
- #ifdef XB_INDEX_NDX
-
-diff -up xbase-2.0.0/xbase/expfunc.cpp.gcc43 xbase-2.0.0/xbase/expfunc.cpp
---- xbase-2.0.0/xbase/expfunc.cpp.gcc43 2008-03-11 20:26:54.000000000 +0100
-+++ xbase-2.0.0/xbase/expfunc.cpp 2008-03-11 20:26:54.000000000 +0100
-@@ -64,6 +64,7 @@
- #include <xbase/exp.h>
- #include <xbase/xbexcept.h>
-
-+using std::cout;
-
- /*! \file expfunc.cpp
- */
-diff -up xbase-2.0.0/xbase/memo.cpp.gcc43 xbase-2.0.0/xbase/memo.cpp
---- xbase-2.0.0/xbase/memo.cpp.gcc43 2008-03-11 20:30:29.000000000 +0100
-+++ xbase-2.0.0/xbase/memo.cpp 2008-03-11 20:30:40.000000000 +0100
-@@ -59,6 +59,8 @@
- #include <stdio.h>
- #include <xbase/xbexcept.h>
-
-+using std::cout;
-+
- /*! \file memo.cpp
- */
-
-diff -up xbase-2.0.0/xbase/xbfilter.cpp.gcc43 xbase-2.0.0/xbase/xbfilter.cpp
---- xbase-2.0.0/xbase/xbfilter.cpp.gcc43 2008-03-11 20:34:21.000000000 +0100
-+++ xbase-2.0.0/xbase/xbfilter.cpp 2008-03-11 20:34:25.000000000 +0100
-@@ -60,6 +60,9 @@
- #include <xbase/xbase.h>
- #include <xbase/xbexcept.h>
-
-+using std::cout;
-+using std::endl;
-+
- /*! \file xbfilter.cpp
- */
-
-diff -up xbase-2.0.0/xbase/html.h.gcc43 xbase-2.0.0/xbase/html.h
---- xbase-2.0.0/xbase/html.h.gcc43 2008-03-11 20:25:52.000000000 +0100
-+++ xbase-2.0.0/xbase/html.h 2008-03-11 20:26:22.000000000 +0100
-@@ -66,6 +66,8 @@
-
- #include <xbase/xtypes.h>
-
-+#include <iostream>
-+
- /*! \file html.h
- */
-
-@@ -92,28 +94,28 @@ public:
- //! Short description.
- /*!
- */
-- void BoldOff( void ) { cout << "</b>\n"; };
-+ void BoldOff( void ) { std::cout << "</b>\n"; };
- //! Short description.
- /*!
- */
-- void BoldOn( void ) { cout << "<b>"; };
-+ void BoldOn( void ) { std::cout << "<b>"; };
- //! Short description.
- /*!
- */
-- void Bullet( void ) { cout << "<li>"; };
-+ void Bullet( void ) { std::cout << "<li>"; };
- void DumpArray( void );
- //! Short description.
- /*!
- */
-- void EmphasizeOff( void ) { cout << "</em>\n"; };
-+ void EmphasizeOff( void ) { std::cout << "</em>\n"; };
- //! Short description.
- /*!
- */
-- void EmphasizeOn( void ) { cout << "<em>"; };
-+ void EmphasizeOn( void ) { std::cout << "<em>"; };
- //! Short description.
- /*!
- */
-- void EndHtmlPage( void ) { cout << "</BODY>\n</HTML>\n"; }
-+ void EndHtmlPage( void ) { std::cout << "</BODY>\n</HTML>\n"; }
- xbShort GenFormFields(xbDbf *d, xbShort Option,const char * Title,xbFieldList *fl);
- xbShort GetArrayNo( const char * FieldName );
- const char * GetCookie( const char *CookieName );
-@@ -124,47 +126,47 @@ public:
- //! Short description.
- /*!
- */
-- void HeaderOff( xbShort i ){ cout << "</h" << i << ">\n"; };
-+ void HeaderOff( xbShort i ){ std::cout << "</h" << i << ">\n"; };
- //! Short description.
- /*!
- */
-- void HeaderOn( xbShort i ){ cout << "<h" << i << ">\n"; };
-+ void HeaderOn( xbShort i ){ std::cout << "<h" << i << ">\n"; };
- //! Short description.
- /*!
- */
-- void ItalicOff( void ) { cout << "</i>\n"; };
-+ void ItalicOff( void ) { std::cout << "</i>\n"; };
- //! Short description.
- /*!
- */
-- void ItalicOn( void ) { cout << "<i>"; };
-+ void ItalicOn( void ) { std::cout << "<i>"; };
- //! Short description.
- /*!
- */
-- void NewLine( void ) { cout << "<br>"; }
-+ void NewLine( void ) { std::cout << "<br>"; }
- xbShort PostMethod( void );
- void PrintEncodedChar( char );
- void PrintEncodedString( const char *s );
- //! Short description.
- /*!
- */
-- void PrintHtml( char * s ) { cout << s; };
-+ void PrintHtml( char * s ) { std::cout << s; };
- //! Short description.
- /*!
- */
-- void PrintHtml( xbLong l ) { cout << l; };
-+ void PrintHtml( xbLong l ) { std::cout << l; };
- //! Short description.
- /*!
- */
-- void PrintHtml( xbShort i ) { cout << i; };
-+ void PrintHtml( xbShort i ) { std::cout << i; };
- //! Short description.
- /*!
- */
-- void PrintHtml( int i ) { cout << i; };
-+ void PrintHtml( int i ) { std::cout << i; };
- void StartHtmlPage( const char *Title );
- //! Short description.
- /*!
- */
-- void StartTextPage( void ) { cout << "Content-type: text/plain\n\n"; }
-+ void StartTextPage( void ) { std::cout << "Content-type: text/plain\n\n"; }
- void TextOut( const char *String );
- xbLong Tally( const char *FileName );
- xbShort SetCookie(const char *Name, const char *Value, const char *ExpDate,
-diff -up xbase-2.0.0/xbase/dbf.h.gcc43 xbase-2.0.0/xbase/dbf.h
---- xbase-2.0.0/xbase/dbf.h.gcc43 2001-01-13 21:20:53.000000000 +0100
-+++ xbase-2.0.0/xbase/dbf.h 2008-03-11 20:21:20.000000000 +0100
-@@ -65,7 +65,6 @@
- #include <xbase/xtypes.h>
- #include <xbase/xdate.h>
-
--#include <iostream.h>
- #include <stdio.h>
-
- /*! \file dbf.h
-diff -up xbase-2.0.0/examples/sample1.cpp.gcc43 xbase-2.0.0/examples/sample1.cpp
---- xbase-2.0.0/examples/sample1.cpp.gcc43 2008-03-11 20:35:01.000000000 +0100
-+++ xbase-2.0.0/examples/sample1.cpp 2008-03-11 20:36:40.000000000 +0100
-@@ -47,6 +47,8 @@
-
- #include <xbase/xbase.h>
-
-+using std::cout;
-+
- /* set the stack large for dos compiles */
- #ifdef __XBDOS
- #include <stdio.h>
-diff -up xbase-2.0.0/examples/sample2.cpp.gcc43 xbase-2.0.0/examples/sample2.cpp
---- xbase-2.0.0/examples/sample2.cpp.gcc43 2008-03-11 20:36:03.000000000 +0100
-+++ xbase-2.0.0/examples/sample2.cpp 2008-03-11 20:36:41.000000000 +0100
-@@ -53,6 +53,8 @@
-
- #include <xbase/xbase.h>
-
-+using std::cout;
-+
- /* set the stack large for dos compiles */
- #ifdef __XBDOS
- #include <stdio.h>
-diff -up xbase-2.0.0/examples/sample5.cpp.gcc43 xbase-2.0.0/examples/sample5.cpp
---- xbase-2.0.0/examples/sample5.cpp.gcc43 2008-03-11 20:36:36.000000000 +0100
-+++ xbase-2.0.0/examples/sample5.cpp 2008-03-11 20:36:40.000000000 +0100
-@@ -45,6 +45,8 @@
-
- #include <xbase/xbase.h>
-
-+using std::cout;
-+
- /* set the stack large for dos compiles */
- #ifdef __XBDOS
- #include <stdio.h>
-diff -up xbase-2.0.0/examples/sample4.cpp.gcc43 xbase-2.0.0/examples/sample4.cpp
---- xbase-2.0.0/examples/sample4.cpp.gcc43 2008-03-11 20:36:25.000000000 +0100
-+++ xbase-2.0.0/examples/sample4.cpp 2008-03-11 20:36:47.000000000 +0100
-@@ -51,6 +51,8 @@
-
- #include <xbase/xbase.h>
-
-+using std::cout;
-+
- #ifdef __XBDOS
- #include <stdio.h>
- extern unsigned _stklen = 100000;
-diff -up xbase-2.0.0/examples/exfilter.cpp.gcc43 xbase-2.0.0/examples/exfilter.cpp
---- xbase-2.0.0/examples/exfilter.cpp.gcc43 2008-03-11 20:37:14.000000000 +0100
-+++ xbase-2.0.0/examples/exfilter.cpp 2008-03-11 20:37:28.000000000 +0100
-@@ -50,6 +50,8 @@
-
- #include <xbase/xbase.h>
-
-+using std::cout;
-+using std::endl;
-
- int main()
- {
-diff -up xbase-2.0.0/examples/sample3.cpp.gcc43 xbase-2.0.0/examples/sample3.cpp
---- xbase-2.0.0/examples/sample3.cpp.gcc43 2008-03-11 20:36:10.000000000 +0100
-+++ xbase-2.0.0/examples/sample3.cpp 2008-03-11 20:36:46.000000000 +0100
-@@ -54,6 +54,9 @@
-
- #include <xbase/xbase.h>
-
-+using std::cout;
-+using std::endl;
-+
- /* set the stack large for dos compiles */
- #ifdef __XBDOS
- #include <stdio.h>
-diff -up xbase-2.0.0/bin/undelall.cpp.gcc43 xbase-2.0.0/bin/undelall.cpp
---- xbase-2.0.0/bin/undelall.cpp.gcc43 2008-03-11 20:39:22.000000000 +0100
-+++ xbase-2.0.0/bin/undelall.cpp 2008-03-11 20:40:33.000000000 +0100
-@@ -45,6 +45,9 @@
-
- #include <xbase/xbase.h>
-
-+using std::cout;
-+using std::endl;
-+
- int main(int ac,char** av)
- {
- if (ac <= 1) {
-diff -up xbase-2.0.0/bin/checkndx.cpp.gcc43 xbase-2.0.0/bin/checkndx.cpp
---- xbase-2.0.0/bin/checkndx.cpp.gcc43 2008-03-11 20:39:22.000000000 +0100
-+++ xbase-2.0.0/bin/checkndx.cpp 2008-03-11 20:40:29.000000000 +0100
-@@ -45,6 +45,8 @@
-
- #include "xbase/xbase.h"
-
-+using std::cout;
-+
- int main(int ac,char** av)
- {
- #ifdef XBASE_DEBUG
-diff -up xbase-2.0.0/bin/packdbf.cpp.gcc43 xbase-2.0.0/bin/packdbf.cpp
---- xbase-2.0.0/bin/packdbf.cpp.gcc43 2008-03-11 20:39:22.000000000 +0100
-+++ xbase-2.0.0/bin/packdbf.cpp 2008-03-11 20:40:32.000000000 +0100
-@@ -46,6 +46,9 @@
-
- #include <xbase/xbase.h>
-
-+using std::cout;
-+using std::endl;
-+
- int main(int ac,char** av)
- {
- if (ac <= 1) {
-diff -up xbase-2.0.0/bin/zap.cpp.gcc43 xbase-2.0.0/bin/zap.cpp
---- xbase-2.0.0/bin/zap.cpp.gcc43 2008-03-11 20:39:22.000000000 +0100
-+++ xbase-2.0.0/bin/zap.cpp 2008-03-11 20:40:33.000000000 +0100
-@@ -45,6 +45,9 @@
-
- #include <xbase/xbase.h>
-
-+using std::cout;
-+using std::endl;
-+
- int main(int ac,char** av)
- {
- if (ac <= 1) {
-diff -up xbase-2.0.0/bin/reindex.cpp.gcc43 xbase-2.0.0/bin/reindex.cpp
---- xbase-2.0.0/bin/reindex.cpp.gcc43 2008-03-11 20:39:22.000000000 +0100
-+++ xbase-2.0.0/bin/reindex.cpp 2008-03-11 20:40:32.000000000 +0100
-@@ -47,6 +47,9 @@
-
- #include <xbase/xbase.h>
-
-+using std::cout;
-+using std::endl;
-+
- static void
- showStatus(xbLong itemNum, xbLong numItems)
- {
-diff -up xbase-2.0.0/bin/copydbf.cpp.gcc43 xbase-2.0.0/bin/copydbf.cpp
---- xbase-2.0.0/bin/copydbf.cpp.gcc43 2008-03-11 20:39:22.000000000 +0100
-+++ xbase-2.0.0/bin/copydbf.cpp 2008-03-11 20:40:29.000000000 +0100
-@@ -44,6 +44,8 @@
-
- #include <xbase/xbase.h>
-
-+using std::cout;
-+
- int main(int ac,char** av)
- {
- if (3 != ac) {
-diff -up xbase-2.0.0/bin/deletall.cpp.gcc43 xbase-2.0.0/bin/deletall.cpp
---- xbase-2.0.0/bin/deletall.cpp.gcc43 2008-03-11 20:39:22.000000000 +0100
-+++ xbase-2.0.0/bin/deletall.cpp 2008-03-11 20:40:30.000000000 +0100
-@@ -45,6 +45,9 @@
-
- #include <xbase/xbase.h>
-
-+using std::cout;
-+using std::endl;
-+
- int main(int ac,char** av)
- {
- if (ac <= 1) {
-diff -up xbase-2.0.0/bin/dumphdr.cpp.gcc43 xbase-2.0.0/bin/dumphdr.cpp
---- xbase-2.0.0/bin/dumphdr.cpp.gcc43 2008-03-11 20:39:22.000000000 +0100
-+++ xbase-2.0.0/bin/dumphdr.cpp 2008-03-11 20:40:31.000000000 +0100
-@@ -47,6 +47,9 @@
-
- #include <xbase/xbase.h>
-
-+using std::cout;
-+using std::endl;
-+
- int main( int ac, char ** av )
- {
- #ifdef XBASE_DEBUG
-diff -up xbase-2.0.0/bin/dumprecs.cpp.gcc43 xbase-2.0.0/bin/dumprecs.cpp
---- xbase-2.0.0/bin/dumprecs.cpp.gcc43 2008-03-11 20:39:22.000000000 +0100
-+++ xbase-2.0.0/bin/dumprecs.cpp 2008-03-11 20:40:31.000000000 +0100
-@@ -52,6 +52,9 @@
- #include <xbase/xbexcept.h>
- #endif
-
-+using std::cout;
-+using std::endl;
-+
- int main(int ac,char** av)
- {
- if (ac <= 1) {
-diff -up xbase-2.0.0/bin/dumpdbt.cpp.gcc43 xbase-2.0.0/bin/dumpdbt.cpp
---- xbase-2.0.0/bin/dumpdbt.cpp.gcc43 2008-03-11 20:39:22.000000000 +0100
-+++ xbase-2.0.0/bin/dumpdbt.cpp 2008-03-11 20:40:31.000000000 +0100
-@@ -47,6 +47,9 @@
-
- #include <xbase/xbase.h>
-
-+using std::cout;
-+using std::endl;
-+
- int main( int ac, char **av )
- {
- #ifdef XB_MEMO_FIELDS
-diff -up xbase-2.0.0/bin/dbfxtrct.cpp.gcc43 xbase-2.0.0/bin/dbfxtrct.cpp
---- xbase-2.0.0/bin/dbfxtrct.cpp.gcc43 2008-03-11 20:39:22.000000000 +0100
-+++ xbase-2.0.0/bin/dbfxtrct.cpp 2008-03-11 20:40:30.000000000 +0100
-@@ -47,6 +47,9 @@
-
- #include "xbase/xbase.h"
-
-+using std::cout;
-+using std::endl;
-+
- /*************************************************************************/
- void Usage();
- void Usage()
-diff -up xbase-2.0.0/bin/dbfutil1.cpp.gcc43 xbase-2.0.0/bin/dbfutil1.cpp
---- xbase-2.0.0/bin/dbfutil1.cpp.gcc43 2008-03-11 20:39:22.000000000 +0100
-+++ xbase-2.0.0/bin/dbfutil1.cpp 2008-03-11 20:41:22.000000000 +0100
-@@ -42,6 +42,10 @@
-
- #include <xbase/xbase.h>
-
-+using std::cout;
-+using std::cin;
-+using std::endl;
-+
- xbXBase x;
- xbDbf d( &x );
- xbIndex *ix;
-diff -up xbase-2.0.0/libtest/indextst.cpp.gcc43 xbase-2.0.0/libtest/indextst.cpp
---- xbase-2.0.0/libtest/indextst.cpp.gcc43 2008-03-11 20:41:46.000000000 +0100
-+++ xbase-2.0.0/libtest/indextst.cpp 2008-03-11 20:42:30.000000000 +0100
-@@ -31,6 +31,9 @@
-
- #include <xbase/xbase.h>
-
-+using std::cout;
-+using std::endl;
-+
- /* set the stack large for dos compiles */
- #ifdef __XBDOS
- #include <stdio.h>
-diff -up xbase-2.0.0/libtest/exptest.cpp.gcc43 xbase-2.0.0/libtest/exptest.cpp
---- xbase-2.0.0/libtest/exptest.cpp.gcc43 2008-03-11 20:41:46.000000000 +0100
-+++ xbase-2.0.0/libtest/exptest.cpp 2008-03-11 20:42:30.000000000 +0100
-@@ -27,6 +27,9 @@
-
- #include "xbase/xbase.h"
-
-+using std::cout;
-+using std::endl;
-+
- class ExpTestor{
- public:
- ExpTestor( xbDbf * );
-diff -up xbase-2.0.0/libtest/locktest.cpp.gcc43 xbase-2.0.0/libtest/locktest.cpp
---- xbase-2.0.0/libtest/locktest.cpp.gcc43 2008-03-11 20:41:46.000000000 +0100
-+++ xbase-2.0.0/libtest/locktest.cpp 2008-03-11 20:42:31.000000000 +0100
-@@ -7,6 +7,9 @@
- #include <stdlib.h>
- #include <stdio.h>
-
-+using std::cout;
-+using std::endl;
-+
- int main(int, char**)
- {
- #if 0 // FIXME - seriously
-diff -up xbase-2.0.0/libtest/testdate.cpp.gcc43 xbase-2.0.0/libtest/testdate.cpp
---- xbase-2.0.0/libtest/testdate.cpp.gcc43 2008-03-11 20:41:46.000000000 +0100
-+++ xbase-2.0.0/libtest/testdate.cpp 2008-03-11 20:42:32.000000000 +0100
-@@ -56,6 +56,9 @@
-
- #include <xbase/xbase.h>
-
-+using std::cout;
-+using std::endl;
-+
- int main()
- {
- xbString StringDate( "19601007" ); /* oct 7 1960 */
-diff -up xbase-2.0.0/libtest/testhtml.cpp.gcc43 xbase-2.0.0/libtest/testhtml.cpp
---- xbase-2.0.0/libtest/testhtml.cpp.gcc43 2008-03-11 20:41:46.000000000 +0100
-+++ xbase-2.0.0/libtest/testhtml.cpp 2008-03-11 20:42:33.000000000 +0100
-@@ -48,6 +48,9 @@
-
- #include <xbase/xbase.h>
-
-+using std::cout;
-+using std::endl;
-+
- int main()
- {
- #ifdef XB_HTML
diff --git a/dev-db/xbase/files/xbase-2.0.0-gcc47.patch b/dev-db/xbase/files/xbase-2.0.0-gcc47.patch
deleted file mode 100644
index 74829e2c5d4e..000000000000
--- a/dev-db/xbase/files/xbase-2.0.0-gcc47.patch
+++ /dev/null
@@ -1,21 +0,0 @@
- bin/dumprecs.cpp | 6 +++---
- 1 files changed, 3 insertions(+), 3 deletions(-)
-
-diff --git a/bin/dumprecs.cpp b/bin/dumprecs.cpp
-index 94baab0..b7eaa57 100644
---- a/bin/dumprecs.cpp
-+++ b/bin/dumprecs.cpp
-@@ -80,10 +80,10 @@ int main(int ac,char** av)
- }
-
- cout << "\nLoop through forwards...\n";
-- int i = 0;
-+ int j = 0;
- while(i<MyFile.NoOfRecords()) {
-- MyFile.DumpRecord(i+1);
-- i++;
-+ MyFile.DumpRecord(j+1);
-+ j++;
- }
-
- MyFile.CloseDatabase(); /* close database */
diff --git a/dev-db/xbase/files/xbase-2.0.0-x86_64.patch b/dev-db/xbase/files/xbase-2.0.0-x86_64.patch
deleted file mode 100644
index 56f1b7c6bda9..000000000000
--- a/dev-db/xbase/files/xbase-2.0.0-x86_64.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff -up xbase-2.0.0/config.sub.BAD xbase-2.0.0/config.sub
---- xbase-2.0.0/config.sub.BAD 2008-06-05 15:47:20.000000000 -0400
-+++ xbase-2.0.0/config.sub 2008-06-05 15:49:10.000000000 -0400
-@@ -182,7 +182,7 @@ case $basic_machine in
- | sparc64-* | mips64-* | mipsel-* \
- | mips64el-* | mips64orion-* | mips64orionel-* \
- | mipstx39-* | mipstx39el-* \
-- | f301-*)
-+ | f301-* | x86_64-* | ppc64-*)
- ;;
- # Recognize the various machine names and aliases which stand
- # for a CPU type and a company and sometimes even an OS.
diff --git a/dev-db/xbase/xbase-2.0.0-r1.ebuild b/dev-db/xbase/xbase-2.0.0-r1.ebuild
deleted file mode 100644
index bde9ca495823..000000000000
--- a/dev-db/xbase/xbase-2.0.0-r1.ebuild
+++ /dev/null
@@ -1,42 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/xbase/xbase-2.0.0-r1.ebuild,v 1.7 2012/07/29 18:19:41 armin76 Exp $
-
-EAPI="4"
-inherit base eutils
-
-DESCRIPTION="XBase is an xbase (i.e. dBase, FoxPro, etc.) compatible C++ class library"
-HOMEPAGE="http://www.rekallrevealed.org/"
-SRC_URI="http://www.rekallrevealed.org/packages/${P}.tgz"
-
-SLOT="0"
-LICENSE="GPL-2"
-KEYWORDS="amd64 hppa ppc ppc64 x86 ~x86-fbsd"
-IUSE="doc"
-
-RDEPEND=""
-DEPEND="${DEPEND}
- sys-devel/automake
- sys-devel/libtool"
-
-src_prepare() {
- epatch "${FILESDIR}"/${P}-gcc43.patch
-}
-
-src_compile() {
- emake CC="$(tc-getCC)"
-}
-
-src_install() {
- base_src_install
- # media-tv/linuxtv-dvb-apps collision, bug #208596
- mv "${ED}/usr/bin/zap" "${ED}/usr/bin/xbase-zap" || die
- find "${D}" -name '*.la' -exec rm -f {} +
-
- dodoc AUTHORS ChangeLog NEWS README TODO
- if use doc; then
- dohtml html/*
- insinto /usr/share/doc/${PF}/examples
- doins examples/{*.cpp,examples.ide,makefile.g95}
- fi
-}
diff --git a/dev-db/xbase/xbase-2.0.0-r2.ebuild b/dev-db/xbase/xbase-2.0.0-r2.ebuild
deleted file mode 100644
index e2302806f8d3..000000000000
--- a/dev-db/xbase/xbase-2.0.0-r2.ebuild
+++ /dev/null
@@ -1,49 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/xbase/xbase-2.0.0-r2.ebuild,v 1.2 2012/07/29 18:19:41 armin76 Exp $
-
-EAPI=4
-
-inherit autotools-utils
-
-DESCRIPTION="xbase (i.e. dBase, FoxPro, etc.) compatible C++ class library"
-HOMEPAGE="http://www.rekallrevealed.org/"
-SRC_URI="http://www.rekallrevealed.org/packages/${P}.tgz"
-
-SLOT="0"
-LICENSE="GPL-2"
-KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~x86 ~x86-fbsd"
-IUSE="doc static-libs"
-
-RDEPEND=""
-DEPEND="${DEPEND}
- sys-devel/automake
- sys-devel/libtool"
-
-PATCHES=(
- "${FILESDIR}"/${P}-gcc43.patch
- "${FILESDIR}"/${P}-gcc47.patch
- "${FILESDIR}"/${P}-fixconfig.patch
- "${FILESDIR}"/${P}-x86_64.patch
- "${FILESDIR}"/${P}-ldflags.patch
-)
-
-AUTOTOOLS_IN_SOURCE_BUILD=1
-
-src_compile() {
- autotools-utils_src_compile \
- CC="$(tc-getCC)" \
- CXX="$(tc-getCXX)"
-}
-
-src_install() {
- autotools-utils_src_install
- # media-tv/linuxtv-dvb-apps collision, bug #208596
- mv "${ED}/usr/bin/zap" "${ED}/usr/bin/xbase-zap" || die
-
- if use doc; then
- dohtml html/*
- insinto /usr/share/doc/${PF}/examples
- doins examples/{*.cpp,examples.ide,makefile.g95}
- fi
-}
diff --git a/dev-db/xbase/xbase-2.0.0.ebuild b/dev-db/xbase/xbase-2.0.0.ebuild
deleted file mode 100644
index 9e9bf775874a..000000000000
--- a/dev-db/xbase/xbase-2.0.0.ebuild
+++ /dev/null
@@ -1,38 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/xbase/xbase-2.0.0.ebuild,v 1.20 2012/07/29 18:19:41 armin76 Exp $
-
-inherit base eutils
-
-DESCRIPTION="xbase (i.e. dBase, FoxPro, etc.) compatible C++ class library"
-HOMEPAGE="http://www.rekallrevealed.org/"
-SRC_URI="http://www.rekallrevealed.org/packages/${P}.tgz"
-
-SLOT="0"
-LICENSE="GPL-2"
-KEYWORDS="amd64 hppa ppc ppc64 x86 ~x86-fbsd"
-IUSE="doc"
-
-# !media-tv/linuxtv-dvb-apps (bug #208596)
-RDEPEND="!media-tv/linuxtv-dvb-apps"
-DEPEND="${DEPEND}
- sys-devel/automake
- sys-devel/libtool"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
- epatch "${FILESDIR}"/${P}-gcc43.patch
-}
-
-src_install() {
- base_src_install
- dodoc AUTHORS Changelog INSTALL NEWS README TODO
- if use doc; then
- rm html/Makefile*
- dohtml html/*
- insinto /usr/share/doc/${PF}/examples
- doins examples/*.cpp examples/Makefile.95
- fi
-}