summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sys-apps/textutils/files/digest-textutils-2.0g1
-rw-r--r--sys-apps/textutils/textutils-2.0g.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/sys-apps/textutils/files/digest-textutils-2.0g b/sys-apps/textutils/files/digest-textutils-2.0g
new file mode 100644
index 000000000000..793ef574c0cb
--- /dev/null
+++ b/sys-apps/textutils/files/digest-textutils-2.0g
@@ -0,0 +1 @@
+MD5 0d0788841c0b2ebf6347a5377625d73d textutils-2.0g.tar.gz
diff --git a/sys-apps/textutils/textutils-2.0g.ebuild b/sys-apps/textutils/textutils-2.0g.ebuild
new file mode 100644
index 000000000000..40de2ffcbc92
--- /dev/null
+++ b/sys-apps/textutils/textutils-2.0g.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Daniel Robbins <drobbins@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/textutils/textutils-2.0g.ebuild,v 1.1 2000/08/25 10:55:44 achim Exp $
+
+P=textutils-2.0g
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+
+DESCRIPTION="Standard GNU text utilities"
+SRC_URI="ftp://alpha.gnu.org/gnu/fetish/${A}"
+
+src_compile() {
+ ./configure --prefix=/usr --host=${CHOST} \
+ --with-catgets --without-included-regex
+ make
+}
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}/src
+ mv tr.c tr.c.orig
+ sed -e "234d" tr.c.orig > tr.c
+# cp sys2.h sys2.h.orig
+# sed -e "s:^char \*strndup://:" sys2.h.orig > sys2.h
+}
+
+src_install() {
+ cd ${S}
+ make prefix=${D}/usr install
+ prepman
+ prepinfo
+ dodoc AUTHORS COPYING ChangeLog NEWS README* THANKS TODO
+ dodir /bin
+ dosym /usr/bin/cat /bin/cat
+ rmdir ${D}/usr/lib
+}
+
+
+
+