summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-benchmarks/acovea/ChangeLog7
-rw-r--r--app-benchmarks/acovea/acovea-4.0.0.ebuild6
-rw-r--r--app-benchmarks/acovea/acovea-5.1.1.ebuild7
-rw-r--r--app-benchmarks/acovea/files/acovea-5.1.1-libevocosm.patch119
4 files changed, 133 insertions, 6 deletions
diff --git a/app-benchmarks/acovea/ChangeLog b/app-benchmarks/acovea/ChangeLog
index f0318f4e3c64..6ff42c11fc06 100644
--- a/app-benchmarks/acovea/ChangeLog
+++ b/app-benchmarks/acovea/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-benchmarks/acovea
# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-benchmarks/acovea/ChangeLog,v 1.11 2008/04/21 16:31:28 phreak Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-benchmarks/acovea/ChangeLog,v 1.12 2008/06/01 16:58:14 pchrist Exp $
+
+ 01 Jun 2008; Panagiotis Christopoulos <pchrist@gentoo.org>
+ +files/acovea-5.1.1-libevocosm.patch, acovea-5.1.1.ebuild:
+ Apply patch which fixes dev-libs/libevocosm issue. Patch created by John
+ Brooks <aspecialj@gmail.com>, bug 219998
21 Apr 2008; Christian Heim <phreak@gentoo.org> metadata.xml:
Fix up metadata.xml. If there's no maintainer for the package, the metadata
diff --git a/app-benchmarks/acovea/acovea-4.0.0.ebuild b/app-benchmarks/acovea/acovea-4.0.0.ebuild
index d85d772e7db4..b1fc400f36cb 100644
--- a/app-benchmarks/acovea/acovea-4.0.0.ebuild
+++ b/app-benchmarks/acovea/acovea-4.0.0.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-benchmarks/acovea/acovea-4.0.0.ebuild,v 1.6 2005/01/01 12:02:57 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-benchmarks/acovea/acovea-4.0.0.ebuild,v 1.7 2008/06/01 16:58:14 pchrist Exp $
DESCRIPTION="Analysis of Compiler Options via Evolutionary Algorithm"
HOMEPAGE="http://www.coyotegulch.com/products/acovea/"
@@ -15,6 +15,6 @@ DEPEND="dev-libs/libcoyotl
>=sys-devel/gcc-3.3"
src_install() {
- make DESTDIR=${D} install
+ make DESTDIR="${D}" install
dodoc ChangeLog NEWS README
}
diff --git a/app-benchmarks/acovea/acovea-5.1.1.ebuild b/app-benchmarks/acovea/acovea-5.1.1.ebuild
index 73ea3ff7e58a..79893b686c6f 100644
--- a/app-benchmarks/acovea/acovea-5.1.1.ebuild
+++ b/app-benchmarks/acovea/acovea-5.1.1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-benchmarks/acovea/acovea-5.1.1.ebuild,v 1.2 2006/10/02 09:50:03 exg Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-benchmarks/acovea/acovea-5.1.1.ebuild,v 1.3 2008/06/01 16:58:14 pchrist Exp $
inherit autotools
@@ -25,6 +25,9 @@ src_unpack() {
cd "${S}"
epatch "${FILESDIR}"/${P}-asneeded.patch
epatch "${FILESDIR}"/${P}-free-fix.patch
+ if has_version ">=libevocosm-3.3.0" ; then
+ epatch ${FILESDIR}"/${P}-libevocosm.patch"
+ fi
eautomake
}
diff --git a/app-benchmarks/acovea/files/acovea-5.1.1-libevocosm.patch b/app-benchmarks/acovea/files/acovea-5.1.1-libevocosm.patch
new file mode 100644
index 000000000000..ec30ce644925
--- /dev/null
+++ b/app-benchmarks/acovea/files/acovea-5.1.1-libevocosm.patch
@@ -0,0 +1,119 @@
+--- - 2008-05-30 21:03:16.545065718 -0600
++++ libacovea-5.1.1/libacovea/acovea.cpp 2008-05-30 20:55:48.000000000 -0600
+@@ -86,7 +86,7 @@
+ // randomize settings of this option
+ void option::randomize()
+ {
+- m_enabled = (g_random.get_rand_real2() < 0.5);
++ m_enabled = (g_random.get_real() < 0.5);
+ }
+
+ // mutate this option
+@@ -246,7 +246,7 @@
+ m_step = 1;
+
+ // possibly adjust value to randomize populations
+- size_t choice = g_random.get_rand_index(3);
++ size_t choice = g_random.get_index(3);
+
+ switch (choice)
+ {
+@@ -304,12 +304,12 @@
+ void tuning_option::mutate()
+ {
+ // select our mutation
+- if (g_random.get_rand_real2() < 0.5)
++ if (g_random.get_real() < 0.5)
+ option::mutate();
+ else
+ {
+ // mutate value of this option, up or down randomly
+- if (g_random.get_rand_real2() < 0.5)
++ if (g_random.get_real() < 0.5)
+ m_value -= m_step;
+ else
+ m_value += m_step;
+@@ -335,7 +335,7 @@
+ enum_option::enum_option(const vector<string> & a_choices, bool a_enabled)
+ : option(a_enabled),
+ m_choices(a_choices),
+- m_setting(g_random.get_rand_index(a_choices.size()))
++ m_setting(g_random.get_index(a_choices.size()))
+ {
+ // nada
+ }
+@@ -344,7 +344,7 @@
+ enum_option::enum_option(const char ** a_choices, size_t a_num_choices, bool a_enabled)
+ : option(a_enabled),
+ m_choices(),
+- m_setting(g_random.get_rand_index(a_num_choices))
++ m_setting(g_random.get_index(a_num_choices))
+ {
+ for (int n = 0; n < a_num_choices; ++n)
+ m_choices.push_back(string(a_choices[n]));
+@@ -369,7 +369,7 @@
+ token = strtok(NULL,"|");
+ }
+
+- m_setting = g_random.get_rand_index(m_choices.size());
++ m_setting = g_random.get_index(m_choices.size());
+
+ free(choices);
+ }
+@@ -407,17 +407,17 @@
+ void enum_option::randomize()
+ {
+ // randomize enabled
+- m_enabled = (g_random.get_rand_real2() < 0.5);
++ m_enabled = (g_random.get_real() < 0.5);
+
+ // randomize setting
+- m_setting = g_random.get_rand_index(m_choices.size());
++ m_setting = g_random.get_index(m_choices.size());
+ }
+
+ // mutate this option
+ void enum_option::mutate()
+ {
+ // select our mutation
+- if (g_random.get_rand() & 1)
++ if (g_random.get_real() < 0.5)
+ option::mutate();
+ else
+ {
+@@ -435,7 +435,7 @@
+
+ // find a different setting
+ while (new_setting == m_setting)
+- new_setting = g_random.get_rand_index(m_choices.size());
++ new_setting = g_random.get_index(m_choices.size());
+
+ m_setting = new_setting;
+ }
+@@ -915,7 +915,7 @@
+ // randomly pick an option from one of the parents
+ for (int n = 0; n < a_parent1.size(); ++n)
+ {
+- if (g_random.get_rand() & 1)
++ if (g_random.get_real() < 0.5)
+ child.push_back(a_parent1[n]->clone());
+ else
+ child.push_back(a_parent2[n]->clone());
+@@ -931,7 +931,7 @@
+ {
+ for (int n = 0; n < a_options.size(); ++n)
+ {
+- if (g_random.get_rand_real2() < a_mutation_chance)
++ if (g_random.get_real() < a_mutation_chance)
+ a_options[n]->mutate();
+ }
+ }
+@@ -1096,7 +1096,7 @@
+ acovea_organism * child;
+
+ // do we crossover?
+- if (g_random.get_rand_real2() <= m_crossover_rate)
++ if (g_random.get_real() <= m_crossover_rate)
+ {
+ // select a second parent
+ size_t second_index = first_index;