summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-crypt/newpg/ChangeLog8
-rw-r--r--app-crypt/newpg/Manifest4
-rw-r--r--app-crypt/newpg/files/digest-newpg-0.9.4-r11
-rw-r--r--app-crypt/newpg/newpg-0.9.4-r1.ebuild49
4 files changed, 60 insertions, 2 deletions
diff --git a/app-crypt/newpg/ChangeLog b/app-crypt/newpg/ChangeLog
index 786f3c0143dc..3abb55399bf3 100644
--- a/app-crypt/newpg/ChangeLog
+++ b/app-crypt/newpg/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-crypt/newpg
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/newpg/ChangeLog,v 1.3 2003/03/05 04:40:15 darkspecter Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/newpg/ChangeLog,v 1.4 2003/07/15 09:21:06 pauldv Exp $
+
+*newpg-0.9.4-r1 (15 Jul 2003)
+
+ 15 Jul 2003; <paul@gentoo.org> newpg-0.9.4-r1.ebuild:
+ Fix the ebuild to set sensible default locations for aux programs. Fixes bug
+ #15842
*newpg-0.9.4 (06 Feb 2003)
diff --git a/app-crypt/newpg/Manifest b/app-crypt/newpg/Manifest
index f525934a9615..e99a9869a743 100644
--- a/app-crypt/newpg/Manifest
+++ b/app-crypt/newpg/Manifest
@@ -1,3 +1,5 @@
-MD5 a6d82d159e9a0fb3786f6786de853ac0 ChangeLog 627
+MD5 b808dfcd1cad4d4715eece70734d9206 newpg-0.9.4-r1.ebuild 1475
MD5 89546e01ba00b1ed9484809a7b44f48d newpg-0.9.4.ebuild 1172
+MD5 c4202227e96fa85bc2e8f1fe6589d4db ChangeLog 798
MD5 a9acadec0e49f4e8fe6a549107124b52 files/digest-newpg-0.9.4 63
+MD5 a9acadec0e49f4e8fe6a549107124b52 files/digest-newpg-0.9.4-r1 63
diff --git a/app-crypt/newpg/files/digest-newpg-0.9.4-r1 b/app-crypt/newpg/files/digest-newpg-0.9.4-r1
new file mode 100644
index 000000000000..2117898946c9
--- /dev/null
+++ b/app-crypt/newpg/files/digest-newpg-0.9.4-r1
@@ -0,0 +1 @@
+MD5 6b478f1ce8e37a55064ffc69b7325ea8 newpg-0.9.4.tar.gz 606811
diff --git a/app-crypt/newpg/newpg-0.9.4-r1.ebuild b/app-crypt/newpg/newpg-0.9.4-r1.ebuild
new file mode 100644
index 000000000000..90e4c899a10c
--- /dev/null
+++ b/app-crypt/newpg/newpg-0.9.4-r1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/newpg/newpg-0.9.4-r1.ebuild,v 1.1 2003/07/15 09:21:06 pauldv Exp $
+
+DESCRIPTION="NewPG is the S/MIME variant of GnuPG which does also include the gpg-agent, useful even for GnuPG"
+HOMEPAGE="http://www.gnupg.org/"
+SRC_URI="ftp://ftp.gnupg.org/gcrypt/alpha/aegypten/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~ppc"
+IUSE="nls"
+
+DEPEND="dev-lang/perl
+ >=dev-libs/libksba-0.4.6
+ >=dev-libs/libgcrypt-1.1.8
+ dev-libs/pth"
+RDEPEND="nls? ( sys-devel/gettext )"
+
+src_compile() {
+ local myconf
+ use nls || myconf="${myconf} --disable-nls"
+
+ #set the default pinentry program to a sensible location
+ if [ -x /usr/bin/pinentry-qt ]; then
+ myconf="${myconf} --with-pinentry-pgm=/usr/bin/pinentry-qt"
+ else
+ if [ -x /usr/bin/pinentry-gtk ]; then
+ myconf="${myconf} --with-pinentry-pgm=/usr/bin/pinentry-gtk"
+ fi
+ fi
+
+ econf ${myconf} --disable-dependency-tracking \
+ --exec-prefix=/usr
+ make || die
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die
+ dodoc ABOUT-NLS AUTHORS COPYING ChangeLog INSTALL NEWS README THANKS TODO VERSION
+
+ chmod +s "${D}/usr/bin/gpgsm"
+}
+
+pkg_postinst() {
+ einfo "gpgsm is installed SUID root to make use of protected memory space"
+ einfo "This is needed in order to have a secure place to store your passphrases,"
+ einfo "etc. at runtime but may make some sysadmins nervous"
+}