summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-lisp/cmucl/ChangeLog8
-rw-r--r--dev-lisp/cmucl/cmucl-19d_pre1.ebuild66
-rw-r--r--dev-lisp/cmucl/files/19d-gentoo.patch24
-rw-r--r--dev-lisp/cmucl/files/digest-cmucl-19d_pre16
4 files changed, 103 insertions, 1 deletions
diff --git a/dev-lisp/cmucl/ChangeLog b/dev-lisp/cmucl/ChangeLog
index 938e79eb337f..8188859e19b7 100644
--- a/dev-lisp/cmucl/ChangeLog
+++ b/dev-lisp/cmucl/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-lisp/cmucl
# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cmucl/ChangeLog,v 1.22 2006/09/21 15:55:13 ticho Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cmucl/ChangeLog,v 1.23 2006/11/09 02:28:47 mkennedy Exp $
+
+*cmucl-19d_pre1 (09 Nov 2006)
+
+ 09 Nov 2006; Matthew Kennedy <mkennedy@gentoo.org>
+ +files/19d-gentoo.patch, +cmucl-19d_pre1.ebuild:
+ New upstream version; Remove support for Common Lisp Controller.
21 Sep 2006; <ticho@gentoo.org> cmucl-19c.ebuild:
Stable on x86, bug #146102.
diff --git a/dev-lisp/cmucl/cmucl-19d_pre1.ebuild b/dev-lisp/cmucl/cmucl-19d_pre1.ebuild
new file mode 100644
index 000000000000..51e80e755e4e
--- /dev/null
+++ b/dev-lisp/cmucl/cmucl-19d_pre1.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cmucl/cmucl-19d_pre1.ebuild,v 1.1 2006/11/09 02:28:47 mkennedy Exp $
+
+inherit common-lisp-common-3 eutils toolchain-funcs
+
+MY_PVL=${PV/_/-}
+MY_PV=${PV:0:3}
+
+DESCRIPTION="CMU Common Lisp is an implementation of ANSI Common Lisp"
+HOMEPAGE="http://www.cons.org/cmucl/"
+SRC_URI="http://common-lisp.net/project/cmucl/downloads/release/${MY_PV}/pre-release/cmucl-src-${MY_PVL}.tar.bz2
+ http://common-lisp.net/project/cmucl/downloads/release/${MY_PV}/pre-release/cmucl-${MY_PVL}-x86-linux.tar.bz2"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="doc lesstif source"
+
+DEPEND="lesstif? ( x11-libs/lesstif )
+ !lesstif? ( x11-libs/openmotif )
+ sys-devel/bc"
+
+PROVIDE="virtual/commonlisp"
+
+S=${WORKDIR}
+
+src_unpack() {
+ unpack ${A}
+ epatch ${FILESDIR}/${MY_PV}-gentoo.patch || die
+ find ${S} -type f \( -name \*.sh -o -name linux-nm \) \
+ -exec chmod +x '{}' \;
+ # non-x86 maintainers, add to the the following and verify
+ if use lesstif || test -d /usr/X11R6/include/lesstif; then
+ sed -i -e 's,-I/usr/X11R6/include,-I/usr/X11R6/include/lesstif,g' \
+ -e 's,-L/usr/X11R6/lib,-L/usr/X11R6/lib/lesstif -L/usr/X11R6/lib,g' \
+ src/motif/server/Config.x86
+ fi
+ sed -i -e "s,CC = .*,CC = $(tc-getCC),g" src/lisp/Config.linux_gencgc
+ sed -i -e 's,"time","",g' src/tools/build.sh
+ sed -i -e "s,@CFLAGS@,$CFLAGS,g" src/lisp/Config.linux_gencgc src/motif/server/Config.x86
+}
+
+src_compile() {
+ export SANDBOX_ON=0
+ src/tools/build.sh -C "" -o "bin/lisp -core lib/cmucl/lib/lisp.core -batch -noinit -nositeinit" || die
+}
+
+src_install() {
+ src/tools/make-dist.sh -g -G root -O root build-4 ${MY_PVL} x86 linux
+ dodir /usr/share/doc
+ for i in cmucl-${MY_PVL}-x86-linux.{,extra.}tar.gz; do
+ tar xzpf $i -C ${D}/usr
+ done
+ mv ${D}/usr/doc ${D}/usr/share/doc/${PF}
+ mv ${D}/usr/man ${D}/usr/share/
+ impl-save-timestamp-hack cmucl || die
+}
+
+pkg_postinst() {
+ standard-impl-postinst cmucl
+}
+
+pkg_prerm() {
+ standard-impl-postrm cmucl /usr/bin/lisp
+}
diff --git a/dev-lisp/cmucl/files/19d-gentoo.patch b/dev-lisp/cmucl/files/19d-gentoo.patch
new file mode 100644
index 000000000000..3be6ee339420
--- /dev/null
+++ b/dev-lisp/cmucl/files/19d-gentoo.patch
@@ -0,0 +1,24 @@
+diff -ur cmucl.orig/src/lisp/Config.linux_gencgc cmucl/src/lisp/Config.linux_gencgc
+--- cmucl.orig/src/lisp/Config.linux_gencgc 2006-07-18 21:54:31.000000000 -0500
++++ cmucl/src/lisp/Config.linux_gencgc 2006-10-21 11:59:40.000000000 -0500
+@@ -21,7 +21,7 @@
+ RUNTIME = $(GENCGC) $(LINKAGE)
+ # __NO_CTYPE so builds on glibc 2.3 will run on (some) older glibc's.
+ CPPFLAGS = -D__NO_CTYPE -I. -I$(PATH1) -I- -I/usr/X11R6/include $(RUNTIME)
+-CFLAGS = -rdynamic -Wstrict-prototypes -Wall -g $(RUNTIME)
++CFLAGS = @CFLAGS@ -rdynamic -Wstrict-prototypes -Wall -g $(RUNTIME)
+ ASFLAGS = -g -DGENCGC -DLINKAGE_TABLE
+ NM = $(PATH1)/linux-nm
+ UNDEFSYMPATTERN = -Xlinker -u -Xlinker &
+diff -ur cmucl.orig/src/motif/server/Config.x86 cmucl/src/motif/server/Config.x86
+--- cmucl.orig/src/motif/server/Config.x86 2004-04-26 07:07:36.000000000 -0500
++++ cmucl/src/motif/server/Config.x86 2006-10-21 11:59:13.000000000 -0500
+@@ -1,6 +1,6 @@
+-CFLAGS = -O2 -I/usr/X11R6/include -I. -I$(VPATH)
++CFLAGS = @CFLAGS@ -I/usr/X11R6/include -I. -I$(VPATH)
+ LDFLAGS = -L/usr/X11R6/lib
+-LIBS = -static -lXm -dynamic -lXt -lXext -lX11 -lSM -lICE -lXp -ldl -lpthread
++LIBS = -lXm -lXt -lXext -lX11 -lSM -lICE -lXp -ldl -lpthread
+ # This def assumes you are building in the same or parallel
+ # tree to the CVS souce layout. Sites may need to customize
+ # this path.
diff --git a/dev-lisp/cmucl/files/digest-cmucl-19d_pre1 b/dev-lisp/cmucl/files/digest-cmucl-19d_pre1
new file mode 100644
index 000000000000..5485748a52e8
--- /dev/null
+++ b/dev-lisp/cmucl/files/digest-cmucl-19d_pre1
@@ -0,0 +1,6 @@
+MD5 06dba01693757fb57bcad374cf720b9e cmucl-19d-pre1-x86-linux.tar.bz2 7600456
+RMD160 59d8e1211fb2e37ecabfd6cda9a706b57913d9ec cmucl-19d-pre1-x86-linux.tar.bz2 7600456
+SHA256 959157ee365d499d065f08d9ab385d2fff6adda11ce78d79ede0247fb4ba6e6e cmucl-19d-pre1-x86-linux.tar.bz2 7600456
+MD5 f759dc6fc7dc04d0bc4037b57575f659 cmucl-src-19d-pre1.tar.bz2 3780423
+RMD160 19a536c4492d1ef6a59f09b6e9d9b90da6a88408 cmucl-src-19d-pre1.tar.bz2 3780423
+SHA256 117e8fd8c7c02a7bcdbc055a23431ffc895c9766c1459b5daaf91203cbc9ad05 cmucl-src-19d-pre1.tar.bz2 3780423