summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-lang/php/ChangeLog7
-rw-r--r--dev-lang/php/files/eblits/src_configure-v53.eblit12
-rw-r--r--dev-lang/php/files/eblits/src_configure-v54.eblit12
3 files changed, 14 insertions, 17 deletions
diff --git a/dev-lang/php/ChangeLog b/dev-lang/php/ChangeLog
index 041204d53bfd..1463ab6e04a9 100644
--- a/dev-lang/php/ChangeLog
+++ b/dev-lang/php/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-lang/php
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/php/ChangeLog,v 1.563 2012/02/18 19:42:03 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/php/ChangeLog,v 1.564 2012/02/27 22:04:47 mabi Exp $
+
+ 27 Feb 2012; Matti Bickel <mabi@gentoo.org>
+ files/eblits/src_configure-v53.eblit, files/eblits/src_configure-v54.eblit:
+ rely on /etc/env.d/50oracle-instantclient-basic to provide oci configuration
+ for php (bug #380581)
18 Feb 2012; Raúl Porcel <armin76@gentoo.org> php-5.3.10.ebuild:
ia64/s390/sh/sparc stable wrt #401997
diff --git a/dev-lang/php/files/eblits/src_configure-v53.eblit b/dev-lang/php/files/eblits/src_configure-v53.eblit
index 00b7275318d9..027758dbd57c 100644
--- a/dev-lang/php/files/eblits/src_configure-v53.eblit
+++ b/dev-lang/php/files/eblits/src_configure-v53.eblit
@@ -1,6 +1,6 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/php/files/eblits/src_configure-v53.eblit,v 1.2 2011/12/23 17:16:42 olemarkus Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/php/files/eblits/src_configure-v53.eblit,v 1.3 2012/02/27 22:04:47 mabi Exp $
eblit-php-src_configure() {
addpredict /usr/share/snmp/mibs/.index
@@ -163,12 +163,8 @@ eblit-php-src_configure() {
# Oracle support
if use oci8-instant-client ; then
- OCI8IC_PKG="$(best_version dev-db/oracle-instantclient-basic | \
- sed -e 's|dev-db/oracle-instantclient-basic-||g' | \
- sed -e 's|-r.*||g')"
-
my_conf+="
- $(use_with oci8-instant-client oci8 "instantclient,/usr/lib/oracle/${OCI8IC_PKG}/client/lib")"
+ $(use_with oci8-instant-client oci8)
fi
# PDO support
@@ -188,7 +184,7 @@ eblit-php-src_configure() {
$(use_with odbc pdo-odbc unixODBC,/usr)"
if use oci8-instant-client ; then
my_conf+="
- $(use_with oci8-instant-client pdo-oci "instantclient,/usr,${OCI8IC_PKG}" )"
+ $(use_with oci8-instant-client pdo-oci)"
fi
fi
diff --git a/dev-lang/php/files/eblits/src_configure-v54.eblit b/dev-lang/php/files/eblits/src_configure-v54.eblit
index 9e6b2950018e..09ebc14959b1 100644
--- a/dev-lang/php/files/eblits/src_configure-v54.eblit
+++ b/dev-lang/php/files/eblits/src_configure-v54.eblit
@@ -1,6 +1,6 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/php/files/eblits/src_configure-v54.eblit,v 1.1 2011/12/18 09:00:26 olemarkus Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/php/files/eblits/src_configure-v54.eblit,v 1.2 2012/02/27 22:04:47 mabi Exp $
eblit-php-src_configure() {
addpredict /usr/share/snmp/mibs/.index
@@ -161,12 +161,8 @@ eblit-php-src_configure() {
# Oracle support
if use oci8-instant-client ; then
- OCI8IC_PKG="$(best_version dev-db/oracle-instantclient-basic | \
- sed -e 's|dev-db/oracle-instantclient-basic-||g' | \
- sed -e 's|-r.*||g')"
-
my_conf+="
- $(use_with oci8-instant-client oci8 "instantclient,/usr/lib/oracle/${OCI8IC_PKG}/client/lib")"
+ $(use_with oci8-instant-client oci8)
fi
# PDO support
@@ -186,7 +182,7 @@ eblit-php-src_configure() {
$(use_with odbc pdo-odbc unixODBC,/usr)"
if use oci8-instant-client ; then
my_conf+="
- $(use_with oci8-instant-client pdo-oci "instantclient,/usr,${OCI8IC_PKG}" )"
+ $(use_with oci8-instant-client pdo-oci)"
fi
fi