summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2011-01-30 00:02:55 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2011-01-30 00:02:55 +0000
commit383617be6f502cdcdc2b3d038c19a2c527acff8c (patch)
tree6df296f4b8bebea149fba8edba44815b340fb639 /xfce-extra
parenteapi3, array (diff)
downloadgentoo-2-383617be6f502cdcdc2b3d038c19a2c527acff8c.tar.gz
gentoo-2-383617be6f502cdcdc2b3d038c19a2c527acff8c.tar.bz2
gentoo-2-383617be6f502cdcdc2b3d038c19a2c527acff8c.zip
eapi3, array
(Portage version: 2.2.0_alpha19/cvs/Linux x86_64)
Diffstat (limited to 'xfce-extra')
-rw-r--r--xfce-extra/xfce4-datetime-plugin/xfce4-datetime-plugin-0.6.1.ebuild28
1 files changed, 13 insertions, 15 deletions
diff --git a/xfce-extra/xfce4-datetime-plugin/xfce4-datetime-plugin-0.6.1.ebuild b/xfce-extra/xfce4-datetime-plugin/xfce4-datetime-plugin-0.6.1.ebuild
index 362ffc6a186c..7b8b7b667fcb 100644
--- a/xfce-extra/xfce4-datetime-plugin/xfce4-datetime-plugin-0.6.1.ebuild
+++ b/xfce-extra/xfce4-datetime-plugin/xfce4-datetime-plugin-0.6.1.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/xfce-extra/xfce4-datetime-plugin/xfce4-datetime-plugin-0.6.1.ebuild,v 1.5 2010/08/24 03:06:21 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/xfce-extra/xfce4-datetime-plugin/xfce4-datetime-plugin-0.6.1.ebuild,v 1.6 2011/01/30 00:02:55 ssuominen Exp $
-EAPI=2
+EAPI=3
inherit xfconf
DESCRIPTION="Panel plugin displaying date, time and small calendar"
@@ -15,26 +15,24 @@ KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 sparc x86 ~x86-fbsd ~x86-freebsd ~
IUSE="debug"
RDEPEND=">=x11-libs/gtk+-2.6:2
- >=xfce-base/xfce4-panel-4.3.99.2
>=xfce-base/libxfce4util-4.3.99.2
- >=xfce-base/libxfcegui4-4.3.99.2"
+ >=xfce-base/libxfcegui4-4.3.99.2
+ >=xfce-base/xfce4-panel-4.3.99.2"
DEPEND="${RDEPEND}
- dev-util/pkgconfig
- dev-util/intltool"
+ dev-util/intltool
+ dev-util/pkgconfig"
pkg_setup() {
- # static, http://bugzilla.xfce.org/show_bug.cgi?id=6659
- XFCONF="--disable-dependency-tracking
+ XFCONF=(
+ --disable-dependency-tracking
--disable-static
- $(xfconf_use_debug)"
+ $(xfconf_use_debug)
+ )
+
DOCS="AUTHORS ChangeLog NEWS THANKS"
}
src_prepare() {
- # Encoding, http://bugzilla.xfce.org/show_bug.cgi?id=6660
- sed -i \
- -e '/Encoding/d' \
- panel-plugin/datetime.desktop.in.in || die
-
+ sed -i -e '/Encoding/d' panel-plugin/datetime.desktop.in.in || die
xfconf_src_prepare
}