summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoshua Nichols <nichoj@gentoo.org>2006-12-12 03:42:10 +0000
committerJoshua Nichols <nichoj@gentoo.org>2006-12-12 03:42:10 +0000
commit17881b6ab7b194caa3e72068f607af4c7657b4d6 (patch)
treea3b748a40220f081bda73401be55f4a62da870ad /xfce-extra/xfce4-weather
parentPruned old versions with new versions with same or better keywords. (diff)
downloadgentoo-2-17881b6ab7b194caa3e72068f607af4c7657b4d6.tar.gz
gentoo-2-17881b6ab7b194caa3e72068f607af4c7657b4d6.tar.bz2
gentoo-2-17881b6ab7b194caa3e72068f607af4c7657b4d6.zip
Fix for bug #133772 provided by Thomas Green <e_l_p_i_s@yahoo.co.uk>.
(Portage version: 2.1.2_rc2-r5)
Diffstat (limited to 'xfce-extra/xfce4-weather')
-rw-r--r--xfce-extra/xfce4-weather/ChangeLog8
-rw-r--r--xfce-extra/xfce4-weather/files/digest-xfce4-weather-0.4.9-r23
-rw-r--r--xfce-extra/xfce4-weather/files/scrollbox.c.patch30
-rw-r--r--xfce-extra/xfce4-weather/xfce4-weather-0.4.9-r2.ebuild16
4 files changed, 56 insertions, 1 deletions
diff --git a/xfce-extra/xfce4-weather/ChangeLog b/xfce-extra/xfce4-weather/ChangeLog
index 44002684880d..40b37a07b003 100644
--- a/xfce-extra/xfce4-weather/ChangeLog
+++ b/xfce-extra/xfce4-weather/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for xfce-extra/xfce4-weather
# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/xfce-extra/xfce4-weather/ChangeLog,v 1.19 2006/12/12 03:14:02 nichoj Exp $
+# $Header: /var/cvsroot/gentoo-x86/xfce-extra/xfce4-weather/ChangeLog,v 1.20 2006/12/12 03:42:10 nichoj Exp $
+
+*xfce4-weather-0.4.9-r2 (12 Dec 2006)
+
+ 12 Dec 2006; Joshua Nichols <nichoj@gentoo.org> +files/scrollbox.c.patch,
+ +xfce4-weather-0.4.9-r2.ebuild:
+ Fix for bug #133772 provided by Thomas Green <e_l_p_i_s@yahoo.co.uk>.
12 Dec 2006; Joshua Nichols <nichoj@gentoo.org>
-xfce4-weather-0.3.9.1-r1.ebuild, -xfce4-weather-0.4.0.ebuild,
diff --git a/xfce-extra/xfce4-weather/files/digest-xfce4-weather-0.4.9-r2 b/xfce-extra/xfce4-weather/files/digest-xfce4-weather-0.4.9-r2
new file mode 100644
index 000000000000..0423d15ec993
--- /dev/null
+++ b/xfce-extra/xfce4-weather/files/digest-xfce4-weather-0.4.9-r2
@@ -0,0 +1,3 @@
+MD5 1d5ba253c8eae5a9ad5e3d7002a0dae0 xfce4-weather-plugin-0.4.9.tar.gz 642215
+RMD160 0c7048a46e21cb12408c284b9be66c27db85c71f xfce4-weather-plugin-0.4.9.tar.gz 642215
+SHA256 c82044a943f3b43bf0b973c4859a3061e963c8ebd7e61e03342e646523fac669 xfce4-weather-plugin-0.4.9.tar.gz 642215
diff --git a/xfce-extra/xfce4-weather/files/scrollbox.c.patch b/xfce-extra/xfce4-weather/files/scrollbox.c.patch
new file mode 100644
index 000000000000..0e07d6226694
--- /dev/null
+++ b/xfce-extra/xfce4-weather/files/scrollbox.c.patch
@@ -0,0 +1,30 @@
+diff -r -u xfce4-weather-plugin-0.4.9/panel-plugin/scrollbox.c xfce4-weather-plugin-0.4.9-updated/panel-plugin/scrollbox.c
+--- xfce4-weather-plugin-0.4.9/panel-plugin/scrollbox.c 2006-06-11 12:27:28.000000000 +0100
++++ xfce4-weather-plugin-0.4.9-updated/panel-plugin/scrollbox.c 2006-06-11 12:26:19.000000000 +0100
+@@ -17,7 +17,7 @@
+ void free_label(struct label *lbl)
+ {
+ if (lbl->pixmap)
+- g_free(lbl->pixmap);
++ g_object_unref(lbl->pixmap);
+ if (lbl->msg)
+ g_free(lbl->msg);
+ }
+@@ -305,7 +305,7 @@
+ {
+ struct label *lbl = (struct label*)g_ptr_array_index(self->labels, i);
+
+- g_free(lbl->pixmap);
++ g_object_unref(lbl->pixmap);
+ g_free(lbl->msg);
+ }
+ g_ptr_array_free(self->labels, TRUE);
+@@ -337,7 +337,7 @@
+ newpixmap = make_pixmap(self, lbl->msg);
+
+ if (lbl->pixmap)
+- g_free(lbl->pixmap);
++ g_object_unref(lbl->pixmap);
+
+ lbl->pixmap = newpixmap;
+ }
diff --git a/xfce-extra/xfce4-weather/xfce4-weather-0.4.9-r2.ebuild b/xfce-extra/xfce4-weather/xfce4-weather-0.4.9-r2.ebuild
new file mode 100644
index 000000000000..f133858f6010
--- /dev/null
+++ b/xfce-extra/xfce4-weather/xfce4-weather-0.4.9-r2.ebuild
@@ -0,0 +1,16 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/xfce-extra/xfce4-weather/xfce4-weather-0.4.9-r2.ebuild,v 1.1 2006/12/12 03:42:10 nichoj Exp $
+
+inherit xfce42 eutils
+
+DESCRIPTION="Xfce panel weather monitor"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+
+goodies_plugin
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/scrollbox.c.patch
+}