summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2011-01-29 15:14:35 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2011-01-29 15:14:35 +0000
commit17a87c60469d04c6c1c164db19cafe5ef1398bd9 (patch)
treeb6ffadef1c5c23f1336885a8794f906953e27828 /xfce-extra/xfce4-sensors-plugin
parentpunt old, we don't want old aqbanking support anymore, it needs libchipcard t... (diff)
downloadgentoo-2-17a87c60469d04c6c1c164db19cafe5ef1398bd9.tar.gz
gentoo-2-17a87c60469d04c6c1c164db19cafe5ef1398bd9.tar.bz2
gentoo-2-17a87c60469d04c6c1c164db19cafe5ef1398bd9.zip
Fix building with x11-libs/libnotify >= 0.7.
(Portage version: 2.2.0_alpha19/cvs/Linux x86_64)
Diffstat (limited to 'xfce-extra/xfce4-sensors-plugin')
-rw-r--r--xfce-extra/xfce4-sensors-plugin/ChangeLog9
-rw-r--r--xfce-extra/xfce4-sensors-plugin/files/xfce4-sensors-plugin-1.0.0-libnotify-0.7.patch34
-rw-r--r--xfce-extra/xfce4-sensors-plugin/xfce4-sensors-plugin-1.0.0-r1.ebuild9
3 files changed, 47 insertions, 5 deletions
diff --git a/xfce-extra/xfce4-sensors-plugin/ChangeLog b/xfce-extra/xfce4-sensors-plugin/ChangeLog
index 7c177c00b373..1205cc6d81f2 100644
--- a/xfce-extra/xfce4-sensors-plugin/ChangeLog
+++ b/xfce-extra/xfce4-sensors-plugin/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for xfce-extra/xfce4-sensors-plugin
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/xfce-extra/xfce4-sensors-plugin/ChangeLog,v 1.13 2010/12/18 18:23:39 ssuominen Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/xfce-extra/xfce4-sensors-plugin/ChangeLog,v 1.14 2011/01/29 15:14:35 ssuominen Exp $
+
+ 29 Jan 2011; Samuli Suominen <ssuominen@gentoo.org>
+ xfce4-sensors-plugin-1.0.0-r1.ebuild,
+ +files/xfce4-sensors-plugin-1.0.0-libnotify-0.7.patch:
+ Fix building with x11-libs/libnotify >= 0.7.
*xfce4-sensors-plugin-1.0.0-r1 (18 Dec 2010)
diff --git a/xfce-extra/xfce4-sensors-plugin/files/xfce4-sensors-plugin-1.0.0-libnotify-0.7.patch b/xfce-extra/xfce4-sensors-plugin/files/xfce4-sensors-plugin-1.0.0-libnotify-0.7.patch
new file mode 100644
index 000000000000..46a2178e2673
--- /dev/null
+++ b/xfce-extra/xfce4-sensors-plugin/files/xfce4-sensors-plugin-1.0.0-libnotify-0.7.patch
@@ -0,0 +1,34 @@
+http://bugzilla.xfce.org/show_bug.cgi?id=6785
+
+--- lib/hddtemp.c
++++ lib/hddtemp.c
+@@ -102,7 +102,12 @@
+ if (!notify_is_initted())
+ notify_init(PACKAGE); /* NOTIFY_APPNAME */
+
+- nn = notify_notification_new (summary, body, icon, NULL);
++ nn = notify_notification_new (summary, body, icon
++ #ifdef HAVE_LIBNOTIFY_07
++ );
++ #else
++ , NULL);
++ #endif
+ /* FIXME: Use channels or propagate private object or use static global variable */
+ //notify_notification_add_action (nn,
+ //"confirmed",
+--- lib/sensors-interface.c
++++ lib/sensors-interface.c
+@@ -105,7 +105,12 @@
+ if (!notify_is_initted())
+ notify_init(PACKAGE); /* NOTIFY_APPNAME */
+
+- nn = notify_notification_new(summary, body, icon, NULL);
++ nn = notify_notification_new(summary, body, icon
++ #ifdef HAVE_LIBNOTIFY_07
++ );
++ #else
++ , NULL);
++ #endif
+ notify_notification_show(nn, &error);
+ #else
+ DBG("%s\n%s", summary, body);
diff --git a/xfce-extra/xfce4-sensors-plugin/xfce4-sensors-plugin-1.0.0-r1.ebuild b/xfce-extra/xfce4-sensors-plugin/xfce4-sensors-plugin-1.0.0-r1.ebuild
index c243d02ae55c..a22b3b02efcf 100644
--- a/xfce-extra/xfce4-sensors-plugin/xfce4-sensors-plugin-1.0.0-r1.ebuild
+++ b/xfce-extra/xfce4-sensors-plugin/xfce4-sensors-plugin-1.0.0-r1.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/xfce-extra/xfce4-sensors-plugin/xfce4-sensors-plugin-1.0.0-r1.ebuild,v 1.1 2010/12/18 18:23:39 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/xfce-extra/xfce4-sensors-plugin/xfce4-sensors-plugin-1.0.0-r1.ebuild,v 1.2 2011/01/29 15:14:35 ssuominen Exp $
EAPI=3
EAUTORECONF=yes
-inherit xfconf
+inherit flag-o-matic xfconf
DESCRIPTION="acpi, lm_sensors and hddtemp panel plugin"
HOMEPAGE="http://www.xfce.org/"
@@ -27,10 +27,13 @@ DEPEND="${RDEPEND}
dev-util/pkgconfig"
pkg_setup() {
+ has_version ">=x11-libs/libnotify-0.7" && append-cppflags -DHAVE_LIBNOTIFY_07
+
PATCHES=(
"${FILESDIR}"/${P}-missing_includedir.patch
"${FILESDIR}"/${P}-without_libnotify.patch
"${FILESDIR}"/${P}-segfault_workaround.patch
+ "${FILESDIR}"/${P}-libnotify-0.7.patch
)
XFCONF=(