summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Mende <angelos@gentoo.org>2008-12-05 16:20:27 +0000
committerChristoph Mende <angelos@gentoo.org>2008-12-05 16:20:27 +0000
commitdf197f3bb35b509f37b4650219727e03c156d07c (patch)
tree4a05fe06894d2b4c5c776f801c2471c0a2af56e3 /xfce-extra/xfce4-dict
parentRemove expat and zlib USE flags, bug #249459 (diff)
downloadgentoo-2-df197f3bb35b509f37b4650219727e03c156d07c.tar.gz
gentoo-2-df197f3bb35b509f37b4650219727e03c156d07c.tar.bz2
gentoo-2-df197f3bb35b509f37b4650219727e03c156d07c.zip
Added an elog to let the user know we need aspell/ispell/enchant for spell checking
(Portage version: 2.2_rc16/cvs/Linux 2.6.28-rc7 x86_64)
Diffstat (limited to 'xfce-extra/xfce4-dict')
-rw-r--r--xfce-extra/xfce4-dict/ChangeLog8
-rw-r--r--xfce-extra/xfce4-dict/xfce4-dict-0.3.0.ebuild15
-rw-r--r--xfce-extra/xfce4-dict/xfce4-dict-0.4.1.ebuild11
-rw-r--r--xfce-extra/xfce4-dict/xfce4-dict-0.5.0.ebuild11
-rw-r--r--xfce-extra/xfce4-dict/xfce4-dict-0.5.1.ebuild11
-rw-r--r--xfce-extra/xfce4-dict/xfce4-dict-0.5.2.ebuild11
6 files changed, 61 insertions, 6 deletions
diff --git a/xfce-extra/xfce4-dict/ChangeLog b/xfce-extra/xfce4-dict/ChangeLog
index 46d5c3f0ff4a..1f88beedc2c1 100644
--- a/xfce-extra/xfce4-dict/ChangeLog
+++ b/xfce-extra/xfce4-dict/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for xfce-extra/xfce4-dict
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/xfce-extra/xfce4-dict/ChangeLog,v 1.24 2008/12/05 15:57:26 angelos Exp $
+# $Header: /var/cvsroot/gentoo-x86/xfce-extra/xfce4-dict/ChangeLog,v 1.25 2008/12/05 16:20:27 angelos Exp $
+
+ 05 Dec 2008; Christoph Mende <angelos@gentoo.org> xfce4-dict-0.3.0.ebuild,
+ xfce4-dict-0.4.1.ebuild, xfce4-dict-0.5.0.ebuild, xfce4-dict-0.5.1.ebuild,
+ xfce4-dict-0.5.2.ebuild:
+ Added an elog to let the user know we need aspell/ispell/enchant for spell
+ checking
*xfce4-dict-0.5.2 (05 Dec 2008)
diff --git a/xfce-extra/xfce4-dict/xfce4-dict-0.3.0.ebuild b/xfce-extra/xfce4-dict/xfce4-dict-0.3.0.ebuild
index cae3d12c8733..2cc538ba2bed 100644
--- a/xfce-extra/xfce4-dict/xfce4-dict-0.3.0.ebuild
+++ b/xfce-extra/xfce4-dict/xfce4-dict-0.3.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/xfce-extra/xfce4-dict/xfce4-dict-0.3.0.ebuild,v 1.9 2008/09/26 13:32:03 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/xfce-extra/xfce4-dict/xfce4-dict-0.3.0.ebuild,v 1.10 2008/12/05 16:20:27 angelos Exp $
inherit xfce44
@@ -20,4 +20,17 @@ src_unpack() {
echo panel-plugin/aspell.c >> "${S}"/po/POTFILES.skip
}
+pkg_postinst() {
+ xfce44_pkg_postinst
+
+ if ! has_version app-text/aspell && ! has_version app-text/ispell \
+ && ! has_version app-text/enchant; then
+ echo
+ elog "You need a spell check program for spell checking."
+ elog "xfce4-dict works with enchant, aspell, ispell or any other spell"
+ elog "check program which is compatible with the ispell command"
+ elog "The dictionary function will still work without those"
+ fi
+}
+
xfce44_goodies_panel_plugin
diff --git a/xfce-extra/xfce4-dict/xfce4-dict-0.4.1.ebuild b/xfce-extra/xfce4-dict/xfce4-dict-0.4.1.ebuild
index 774722f249b8..b072a52e1ab5 100644
--- a/xfce-extra/xfce4-dict/xfce4-dict-0.4.1.ebuild
+++ b/xfce-extra/xfce4-dict/xfce4-dict-0.4.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/xfce-extra/xfce4-dict/xfce4-dict-0.4.1.ebuild,v 1.1 2008/11/06 20:21:59 angelos Exp $
+# $Header: /var/cvsroot/gentoo-x86/xfce-extra/xfce4-dict/xfce4-dict-0.4.1.ebuild,v 1.2 2008/12/05 16:20:27 angelos Exp $
EAPI=1
@@ -36,6 +36,15 @@ pkg_postinst() {
fdo-mime_desktop_database_update
fdo-mime_mime_database_update
gnome2_icon_cache_update
+
+ if ! has_version app-text/aspell && ! has_version app-text/ispell \
+ && ! has_version app-text/enchant; then
+ echo
+ elog "You need a spell check program for spell checking."
+ elog "xfce4-dict works with enchant, aspell, ispell or any other spell"
+ elog "check program which is compatible with the ispell command"
+ elog "The dictionary function will still work without those"
+ fi
}
pkg_postrm() {
diff --git a/xfce-extra/xfce4-dict/xfce4-dict-0.5.0.ebuild b/xfce-extra/xfce4-dict/xfce4-dict-0.5.0.ebuild
index 80591c9f5e57..fc4b7a43e166 100644
--- a/xfce-extra/xfce4-dict/xfce4-dict-0.5.0.ebuild
+++ b/xfce-extra/xfce4-dict/xfce4-dict-0.5.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/xfce-extra/xfce4-dict/xfce4-dict-0.5.0.ebuild,v 1.1 2008/11/10 00:02:48 angelos Exp $
+# $Header: /var/cvsroot/gentoo-x86/xfce-extra/xfce4-dict/xfce4-dict-0.5.0.ebuild,v 1.2 2008/12/05 16:20:27 angelos Exp $
EAPI=1
@@ -36,6 +36,15 @@ pkg_postinst() {
fdo-mime_desktop_database_update
fdo-mime_mime_database_update
gnome2_icon_cache_update
+
+ if ! has_version app-text/aspell && ! has_version app-text/ispell \
+ && ! has_version app-text/enchant; then
+ echo
+ elog "You need a spell check program for spell checking."
+ elog "xfce4-dict works with enchant, aspell, ispell or any other spell"
+ elog "check program which is compatible with the ispell command"
+ elog "The dictionary function will still work without those"
+ fi
}
pkg_postrm() {
diff --git a/xfce-extra/xfce4-dict/xfce4-dict-0.5.1.ebuild b/xfce-extra/xfce4-dict/xfce4-dict-0.5.1.ebuild
index 493ea7c88dc2..98de776323a8 100644
--- a/xfce-extra/xfce4-dict/xfce4-dict-0.5.1.ebuild
+++ b/xfce-extra/xfce4-dict/xfce4-dict-0.5.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/xfce-extra/xfce4-dict/xfce4-dict-0.5.1.ebuild,v 1.1 2008/11/23 14:23:31 angelos Exp $
+# $Header: /var/cvsroot/gentoo-x86/xfce-extra/xfce4-dict/xfce4-dict-0.5.1.ebuild,v 1.2 2008/12/05 16:20:27 angelos Exp $
EAPI=1
@@ -36,6 +36,15 @@ pkg_postinst() {
fdo-mime_desktop_database_update
fdo-mime_mime_database_update
gnome2_icon_cache_update
+
+ if ! has_version app-text/aspell && ! has_version app-text/ispell \
+ && ! has_version app-text/enchant; then
+ echo
+ elog "You need a spell check program for spell checking."
+ elog "xfce4-dict works with enchant, aspell, ispell or any other spell"
+ elog "check program which is compatible with the ispell command"
+ elog "The dictionary function will still work without those"
+ fi
}
pkg_postrm() {
diff --git a/xfce-extra/xfce4-dict/xfce4-dict-0.5.2.ebuild b/xfce-extra/xfce4-dict/xfce4-dict-0.5.2.ebuild
index fd9f95157a38..8e03cedcb7f3 100644
--- a/xfce-extra/xfce4-dict/xfce4-dict-0.5.2.ebuild
+++ b/xfce-extra/xfce4-dict/xfce4-dict-0.5.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/xfce-extra/xfce4-dict/xfce4-dict-0.5.2.ebuild,v 1.1 2008/12/05 15:57:26 angelos Exp $
+# $Header: /var/cvsroot/gentoo-x86/xfce-extra/xfce4-dict/xfce4-dict-0.5.2.ebuild,v 1.2 2008/12/05 16:20:27 angelos Exp $
EAPI=1
@@ -36,6 +36,15 @@ pkg_postinst() {
fdo-mime_desktop_database_update
fdo-mime_mime_database_update
gnome2_icon_cache_update
+
+ if ! has_version app-text/aspell && ! has_version app-text/ispell \
+ && ! has_version app-text/enchant; then
+ echo
+ elog "You need a spell check program for spell checking."
+ elog "xfce4-dict works with enchant, aspell, ispell or any other spell"
+ elog "check program which is compatible with the ispell command"
+ elog "The dictionary function will still work without those"
+ fi
}
pkg_postrm() {