summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Mende <angelos@gentoo.org>2008-12-01 19:36:08 +0000
committerChristoph Mende <angelos@gentoo.org>2008-12-01 19:36:08 +0000
commit43056e30ee00d616fcaf867e9595538a5532da52 (patch)
tree8e0e349bdaddc0f463776f0057970208455cf293 /xfce-extra/exo
parentInstall all docs. Remove old. (diff)
downloadgentoo-2-43056e30ee00d616fcaf867e9595538a5532da52.tar.gz
gentoo-2-43056e30ee00d616fcaf867e9595538a5532da52.tar.bz2
gentoo-2-43056e30ee00d616fcaf867e9595538a5532da52.zip
Don't declare exo_atomic_{inc,dec} when the functions are not available
(Portage version: 2.2_rc16/cvs/Linux 2.6.28-rc6-00184-gd9d060a x86_64)
Diffstat (limited to 'xfce-extra/exo')
-rw-r--r--xfce-extra/exo/ChangeLog8
-rw-r--r--xfce-extra/exo/exo-0.3.4-r2.ebuild69
-rw-r--r--xfce-extra/exo/files/exo-0.3.4-inline-functions.patch20
3 files changed, 96 insertions, 1 deletions
diff --git a/xfce-extra/exo/ChangeLog b/xfce-extra/exo/ChangeLog
index 8bfab2791327..8276a0894439 100644
--- a/xfce-extra/exo/ChangeLog
+++ b/xfce-extra/exo/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for xfce-extra/exo
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/xfce-extra/exo/ChangeLog,v 1.70 2008/11/20 16:52:33 angelos Exp $
+# $Header: /var/cvsroot/gentoo-x86/xfce-extra/exo/ChangeLog,v 1.71 2008/12/01 19:36:08 angelos Exp $
+
+*exo-0.3.4-r2 (01 Dec 2008)
+
+ 01 Dec 2008; Christoph Mende <angelos@gentoo.org>
+ +files/exo-0.3.4-inline-functions.patch, +exo-0.3.4-r2.ebuild:
+ Don't declare exo_atomic_{inc,dec} when the functions are not available
20 Nov 2008; Christoph Mende <angelos@gentoo.org> -exo-0.3.4.ebuild:
Removed old
diff --git a/xfce-extra/exo/exo-0.3.4-r2.ebuild b/xfce-extra/exo/exo-0.3.4-r2.ebuild
new file mode 100644
index 000000000000..d7812f4d3e96
--- /dev/null
+++ b/xfce-extra/exo/exo-0.3.4-r2.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/xfce-extra/exo/exo-0.3.4-r2.ebuild,v 1.1 2008/12/01 19:36:08 angelos Exp $
+
+inherit eutils xfce44 python multilib autotools
+
+XFCE_VERSION=4.4.2
+xfce44
+xfce44_core_package
+
+DESCRIPTION="Extensions, widgets and framework library with session management support"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="debug doc hal libnotify python"
+
+RDEPEND=">=dev-lang/perl-5.6
+ dev-perl/URI
+ >=dev-libs/glib-2.6
+ >=x11-libs/gtk+-2.6
+ >=xfce-base/libxfce4util-${XFCE_MASTER_VERSION}
+ >=xfce-base/xfce-mcs-manager-${XFCE_MASTER_VERSION}
+ >=xfce-base/xfce-mcs-plugins-${XFCE_MASTER_VERSION}
+ libnotify? ( x11-libs/libnotify )
+ hal? ( >=sys-apps/hal-0.5.7.1 )
+ python? ( dev-python/pygtk )"
+DEPEND="${RDEPEND}
+ dev-util/gtk-doc-am
+ dev-util/pkgconfig
+ dev-util/xfce4-dev-tools
+ doc? ( dev-util/gtk-doc )
+ dev-util/intltool"
+
+DOCS="AUTHORS ChangeLog HACKING NEWS README THANKS TODO"
+
+pkg_setup() {
+ XFCE_CONFIG="${XFCE_CONFIG} $(use_enable python)
+ $(use_enable libnotify notifications)
+ $(use_enable hal) --enable-mcs-plugin"
+}
+
+# See bug 166568 for reference
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ sed -i -e 's:-Werror::g' "${S}"/configure.in || die "sed failed"
+ epatch "${FILESDIR}"/${P}-eject.patch \
+ "${FILESDIR}"/${P}-remove-libmd5.patch \
+ "${FILESDIR}"/${P}-inline-functions.patch
+ intltoolize --force --copy --automake || die "intltoolize failed."
+ AT_M4DIR=/usr/share/xfce4/dev-tools/m4macros eautoreconf
+}
+
+# See bug 164780 for reference
+src_install() {
+ xfce44_src_install
+ rm -f "${D}"/usr/lib*/python*/site-packages/pyexo.py[co]
+ rm -f "${D}"/usr/lib*/python*/site-packages/${PN}-0.3/${PN}/__init__.py[co]
+}
+
+pkg_postinst() {
+ xfce44_pkg_postinst
+ python_version
+ python_mod_optimize /usr/$(get_libdir)/python${PYVER}/site-packages
+}
+
+pkg_postrm() {
+ xfce44_pkg_postrm
+ python_mod_cleanup
+}
diff --git a/xfce-extra/exo/files/exo-0.3.4-inline-functions.patch b/xfce-extra/exo/files/exo-0.3.4-inline-functions.patch
new file mode 100644
index 000000000000..80687b1549e0
--- /dev/null
+++ b/xfce-extra/exo/files/exo-0.3.4-inline-functions.patch
@@ -0,0 +1,20 @@
+Index: exo/exo-utils.h
+===================================================================
+--- exo/exo-utils.h (revision 28047)
++++ exo/exo-utils.h (revision 28048)
+@@ -35,12 +35,13 @@
+ gpointer exo_noop_null (void) G_GNUC_PURE;
+ gboolean exo_noop_true (void) G_GNUC_PURE;
+ gboolean exo_noop_false (void) G_GNUC_PURE;
+-G_INLINE_FUNC void exo_atomic_inc (gint *value);
+-G_INLINE_FUNC gboolean exo_atomic_dec (gint *value);
+
+ /* inline function implementations */
+ #if (defined(G_CAN_INLINE) && defined(__GNUC__) && defined(__i386__) && defined(__OPTIMIZE__)) || defined(__EXO_UTILS_C__)
+
++G_INLINE_FUNC void exo_atomic_inc (gint *value);
++G_INLINE_FUNC gboolean exo_atomic_dec (gint *value);
++
+ G_INLINE_FUNC void
+ exo_atomic_inc (gint *value)
+ {