summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Mende <angelos@gentoo.org>2011-06-18 09:33:53 +0000
committerChristoph Mende <angelos@gentoo.org>2011-06-18 09:33:53 +0000
commitc637602f14d97e3dfac4ac131e8ac93c1efe8ea0 (patch)
tree8ba380645321f6e04e7b6c781799b7acc38a0d72 /xfce-base
parentStable on amd64 wrt bug #370707 (diff)
downloadgentoo-2-c637602f14d97e3dfac4ac131e8ac93c1efe8ea0.tar.gz
gentoo-2-c637602f14d97e3dfac4ac131e8ac93c1efe8ea0.tar.bz2
gentoo-2-c637602f14d97e3dfac4ac131e8ac93c1efe8ea0.zip
Version bump
(Portage version: 2.2.0_alpha41/cvs/Linux x86_64)
Diffstat (limited to 'xfce-base')
-rw-r--r--xfce-base/xfce-utils/ChangeLog7
-rw-r--r--xfce-base/xfce-utils/xfce-utils-4.8.2.ebuild56
2 files changed, 62 insertions, 1 deletions
diff --git a/xfce-base/xfce-utils/ChangeLog b/xfce-base/xfce-utils/ChangeLog
index 0b330b2a09e0..4552c54426d0 100644
--- a/xfce-base/xfce-utils/ChangeLog
+++ b/xfce-base/xfce-utils/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for xfce-base/xfce-utils
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/xfce-base/xfce-utils/ChangeLog,v 1.182 2011/04/23 17:18:15 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/xfce-base/xfce-utils/ChangeLog,v 1.183 2011/06/18 09:33:53 angelos Exp $
+
+*xfce-utils-4.8.2 (18 Jun 2011)
+
+ 18 Jun 2011; Christoph Mende <angelos@gentoo.org> +xfce-utils-4.8.2.ebuild:
+ Version bump
23 Apr 2011; Samuli Suominen <ssuominen@gentoo.org> xfce-utils-4.8.1.ebuild:
alpha/ia64/sparc stable wrt #358407
diff --git a/xfce-base/xfce-utils/xfce-utils-4.8.2.ebuild b/xfce-base/xfce-utils/xfce-utils-4.8.2.ebuild
new file mode 100644
index 000000000000..d09530f23941
--- /dev/null
+++ b/xfce-base/xfce-utils/xfce-utils-4.8.2.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/xfce-base/xfce-utils/xfce-utils-4.8.2.ebuild,v 1.1 2011/06/18 09:33:53 angelos Exp $
+
+EAPI=4
+inherit xfconf
+
+DESCRIPTION="Utilities for the Xfce desktop environment"
+HOMEPAGE="http://www.xfce.org/projects/xfce-utils/"
+SRC_URI="mirror://xfce/src/xfce/${PN}/4.8/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~x86-solaris"
+IUSE="dbus debug +lock"
+
+COMMON_DEPEND="x11-libs/libX11
+ >=x11-libs/gtk+-2.10:2
+ >=xfce-base/libxfce4util-4.8
+ >=xfce-base/libxfce4ui-4.8
+ >=xfce-base/xfconf-4.8
+ dbus? ( >=dev-libs/dbus-glib-0.88 )"
+RDEPEND="${COMMON_DEPEND}
+ x11-apps/xrdb
+ x11-misc/xdg-user-dirs
+ lock? ( || ( x11-misc/xscreensaver
+ gnome-extra/gnome-screensaver
+ x11-misc/xlockmore
+ x11-misc/slock ) )"
+DEPEND="${COMMON_DEPEND}
+ dev-util/intltool
+ dev-util/pkgconfig
+ sys-devel/gettext"
+
+pkg_setup() {
+ XFCONF=(
+ --docdir="${EPREFIX}"/usr/share/doc/${PF}
+ --disable-xfconf-migration
+ $(use_enable dbus)
+ $(xfconf_use_debug)
+ --with-vendor-info=Gentoo
+ --with-xsession-prefix="${EPREFIX}"/usr
+ )
+
+ DOCS=( AUTHORS ChangeLog NEWS )
+}
+
+src_install() {
+ xfconf_src_install
+
+ rm -f "${ED}"/usr/share/applications/xfhelp4.desktop
+
+ echo startxfce4 > "${T}"/Xfce4
+ exeinto /etc/X11/Sessions
+ doexe "${T}"/Xfce4
+}