summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Mende <angelos@gentoo.org>2011-05-19 18:33:39 +0000
committerChristoph Mende <angelos@gentoo.org>2011-05-19 18:33:39 +0000
commit8352319bc86660ec710ff721f5ec838c8f01759b (patch)
treed5eb3714f7bb36e4d350d396f5572b23e4e4d785 /xfce-base
parentversion bump (diff)
downloadgentoo-2-8352319bc86660ec710ff721f5ec838c8f01759b.tar.gz
gentoo-2-8352319bc86660ec710ff721f5ec838c8f01759b.tar.bz2
gentoo-2-8352319bc86660ec710ff721f5ec838c8f01759b.zip
Version bump
(Portage version: 2.2.0_alpha34/cvs/Linux x86_64)
Diffstat (limited to 'xfce-base')
-rw-r--r--xfce-base/xfce4-settings/ChangeLog8
-rw-r--r--xfce-base/xfce4-settings/xfce4-settings-4.8.2.ebuild55
2 files changed, 62 insertions, 1 deletions
diff --git a/xfce-base/xfce4-settings/ChangeLog b/xfce-base/xfce4-settings/ChangeLog
index 95bbad474fca..e917afd0da73 100644
--- a/xfce-base/xfce4-settings/ChangeLog
+++ b/xfce-base/xfce4-settings/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for xfce-base/xfce4-settings
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/xfce-base/xfce4-settings/ChangeLog,v 1.77 2011/04/23 17:14:04 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/xfce-base/xfce4-settings/ChangeLog,v 1.78 2011/05/19 18:33:39 angelos Exp $
+
+*xfce4-settings-4.8.2 (19 May 2011)
+
+ 19 May 2011; Christoph Mende <angelos@gentoo.org>
+ +xfce4-settings-4.8.2.ebuild:
+ Version bump
23 Apr 2011; Samuli Suominen <ssuominen@gentoo.org>
xfce4-settings-4.8.1.ebuild:
diff --git a/xfce-base/xfce4-settings/xfce4-settings-4.8.2.ebuild b/xfce-base/xfce4-settings/xfce4-settings-4.8.2.ebuild
new file mode 100644
index 000000000000..0a2f7de9d28e
--- /dev/null
+++ b/xfce-base/xfce4-settings/xfce4-settings-4.8.2.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/xfce-base/xfce4-settings/xfce4-settings-4.8.2.ebuild,v 1.1 2011/05/19 18:33:39 angelos Exp $
+
+EAPI=3
+inherit xfconf
+
+DESCRIPTION="Configuration system for the Xfce desktop environment"
+HOMEPAGE="http://www.xfce.org/projects/xfce4-settings/"
+SRC_URI="mirror://xfce/src/xfce/${PN}/4.8/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~ia64-linux ~x86-linux"
+IUSE="debug libcanberra libnotify +xklavier"
+
+RDEPEND=">=dev-libs/glib-2.16:2
+ >=dev-libs/dbus-glib-0.88
+ >=gnome-base/libglade-2
+ >=x11-libs/gtk+-2.14:2
+ >=x11-libs/libX11-1
+ >=x11-libs/libXcursor-1.1
+ >=x11-libs/libXi-1.3
+ >=x11-libs/libXrandr-1.2
+ >=xfce-base/libxfce4util-4.8
+ >=xfce-base/libxfce4ui-4.8
+ >=xfce-base/xfconf-4.8
+ >=xfce-base/exo-0.6
+ libcanberra? ( >=media-libs/libcanberra-0.25[sound] )
+ libnotify? ( >=x11-libs/libnotify-0.1.3 )
+ xklavier? ( >=x11-libs/libxklavier-0.3 )"
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ dev-util/pkgconfig
+ sys-devel/gettext
+ >=x11-proto/inputproto-1.4
+ x11-proto/xproto"
+
+pkg_setup() {
+ XFCONF=(
+ --disable-dependency-tracking
+ --disable-static
+ $(use_enable libnotify)
+ $(use_enable xklavier libxklavier)
+ $(use_enable libcanberra sound-settings)
+ $(xfconf_use_debug)
+ )
+
+ DOCS="AUTHORS ChangeLog NEWS TODO"
+}
+
+src_prepare() {
+ sed -i -e '/IconThemeName/s:Rodent:Tango:' xfsettingsd/xsettings.xml || die
+ xfconf_src_prepare
+}