summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeremy Olexa <darkside@gentoo.org>2009-04-28 01:16:55 +0000
committerJeremy Olexa <darkside@gentoo.org>2009-04-28 01:16:55 +0000
commit28725b9f08b63cba6223c632f5a6ad1b92e7c751 (patch)
treea2bb9ca78062f1fc911082258c5cc2ea4e747d39 /xfce-base
parentInitial commit (bug #231864) (diff)
downloadgentoo-2-28725b9f08b63cba6223c632f5a6ad1b92e7c751.tar.gz
gentoo-2-28725b9f08b63cba6223c632f5a6ad1b92e7c751.tar.bz2
gentoo-2-28725b9f08b63cba6223c632f5a6ad1b92e7c751.zip
Move use_enable out of global scope into pkg_setup()
(Portage version: 2.1.6.11/cvs/Linux x86_64)
Diffstat (limited to 'xfce-base')
-rw-r--r--xfce-base/xfce4-settings/xfce4-settings-4.6.1.ebuild6
1 files changed, 4 insertions, 2 deletions
diff --git a/xfce-base/xfce4-settings/xfce4-settings-4.6.1.ebuild b/xfce-base/xfce4-settings/xfce4-settings-4.6.1.ebuild
index 760b50c1ea18..df0aa1297bb0 100644
--- a/xfce-base/xfce4-settings/xfce4-settings-4.6.1.ebuild
+++ b/xfce-base/xfce4-settings/xfce4-settings-4.6.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/xfce-base/xfce4-settings/xfce4-settings-4.6.1.ebuild,v 1.1 2009/04/21 04:26:48 darkside Exp $
+# $Header: /var/cvsroot/gentoo-x86/xfce-base/xfce4-settings/xfce4-settings-4.6.1.ebuild,v 1.2 2009/04/28 01:16:55 darkside Exp $
EAPI="1"
@@ -36,7 +36,9 @@ DEPEND="${RDEPEND}
x11-proto/inputproto
x11-proto/xf86vidmodeproto"
-XFCE_CONFIG+=" $(use_enable libnotify) $(use_enable keyboard libxklavier)
+pkg_setup() {
+ XFCE_CONFIG+=" $(use_enable libnotify) $(use_enable keyboard libxklavier)
$(use_enable sound sound-settings) --enable-xcursor"
+}
DOCS="AUTHORS ChangeLog NEWS README TODO"