summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2010-01-15 03:34:27 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2010-01-15 03:34:27 +0000
commit0037bd98a2d7f6b2f7e80b540254ae87a399ae22 (patch)
tree60f8d28f36ee7ed69159cc2a52904a9f6389c5d0 /xfce-base/xfconf
parentUse funcs from eautotools #300323 by Pacho Ramos. (diff)
downloadgentoo-2-0037bd98a2d7f6b2f7e80b540254ae87a399ae22.tar.gz
gentoo-2-0037bd98a2d7f6b2f7e80b540254ae87a399ae22.tar.bz2
gentoo-2-0037bd98a2d7f6b2f7e80b540254ae87a399ae22.zip
Version bump.
(Portage version: 2.2_rc61/cvs/Linux x86_64)
Diffstat (limited to 'xfce-base/xfconf')
-rw-r--r--xfce-base/xfconf/ChangeLog7
-rw-r--r--xfce-base/xfconf/xfconf-4.7.0.ebuild60
2 files changed, 66 insertions, 1 deletions
diff --git a/xfce-base/xfconf/ChangeLog b/xfce-base/xfconf/ChangeLog
index 9fe964fd764d..91a0dc5c820e 100644
--- a/xfce-base/xfconf/ChangeLog
+++ b/xfce-base/xfconf/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for xfce-base/xfconf
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/xfce-base/xfconf/ChangeLog,v 1.19 2010/01/11 04:19:45 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/xfce-base/xfconf/ChangeLog,v 1.20 2010/01/15 03:34:27 ssuominen Exp $
+
+*xfconf-4.7.0 (15 Jan 2010)
+
+ 15 Jan 2010; Samuli Suominen <ssuominen@gentoo.org> +xfconf-4.7.0.ebuild:
+ Version bump.
11 Jan 2010; Mike Frysinger <vapier@gentoo.org> xfconf-4.6.1.ebuild,
xfconf-4.6.1-r1.ebuild:
diff --git a/xfce-base/xfconf/xfconf-4.7.0.ebuild b/xfce-base/xfconf/xfconf-4.7.0.ebuild
new file mode 100644
index 000000000000..721d3f0f80a6
--- /dev/null
+++ b/xfce-base/xfconf/xfconf-4.7.0.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/xfce-base/xfconf/xfconf-4.7.0.ebuild,v 1.1 2010/01/15 03:34:27 ssuominen Exp $
+
+EAPI=2
+inherit xfconf
+
+DESCRIPTION="Xfce configuration daemon and utilities"
+HOMEPAGE="http://www.xfce.org/"
+SRC_URI="mirror://xfce/src/xfce/xfconf/4.7/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~ia64-linux ~x86-linux"
+IUSE="debug -perl profile"
+
+RDEPEND=">=dev-libs/dbus-glib-0.72
+ >=dev-libs/glib-2.12:2
+ >=xfce-base/libxfce4util-4.6
+ perl? ( dev-perl/glib-perl )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ dev-util/intltool
+ sys-devel/gettext
+ perl? ( dev-perl/extutils-depends
+ dev-perl/extutils-pkgconfig )"
+
+RESTRICT="test"
+
+pkg_setup() {
+ XFCONF="--disable-dependency-tracking
+ --disable-static
+ --with-perl-options=INSTALLDIRS=vendor
+ $(use_enable perl perl-bindings)
+ --disable-gtk-doc
+ --disable-gtk-doc-html
+ --disable-gtk-doc-pdf
+ $(use_enable debug)
+ $(use_enable debug checks)
+ --with-html-dir=/usr/share/doc/${PF}/html"
+
+ use profile && XFCONF="${XFCONF} --enable-profiling"
+
+ DOCS="AUTHORS ChangeLog NEWS TODO"
+}
+
+src_compile() {
+ emake OTHERLDFLAGS="${LDFLAGS}" || die
+}
+
+src_install() {
+ xfconf_src_install
+
+ if use perl; then
+ # Prefix compat. In Gentoo Linux, defaults to ${D}
+ [[ -z ${ED} ]] && local ED=${D}
+ find "${ED}" -type f -name perllocal.pod -delete
+ find "${ED}" -depth -mindepth 1 -type d -empty -delete
+ fi
+}