summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2015-03-08 15:06:40 +0000
committerMichał Górny <mgorny@gentoo.org>2015-03-08 15:06:40 +0000
commit1ad6493fd27d761be642f337767ae1bbc8a949d9 (patch)
tree45cc2bc6bfdef11d3c9e08b0aa6a7a0f36373049 /xfce-base/xfce4-session
parentCleanup. (diff)
downloadgentoo-2-1ad6493fd27d761be642f337767ae1bbc8a949d9.tar.gz
gentoo-2-1ad6493fd27d761be642f337767ae1bbc8a949d9.tar.bz2
gentoo-2-1ad6493fd27d761be642f337767ae1bbc8a949d9.zip
Xfce 4.12 version bump, bug #541962. https://github.com/gentoo/gentoo-portage-rsync-mirror/pull/63 by me and damex.
(Portage version: 2.2.17/cvs/Linux x86_64, signed Manifest commit with key EFB4464E!)
Diffstat (limited to 'xfce-base/xfce4-session')
-rw-r--r--xfce-base/xfce4-session/ChangeLog9
-rw-r--r--xfce-base/xfce4-session/xfce4-session-4.12.0.ebuild70
2 files changed, 78 insertions, 1 deletions
diff --git a/xfce-base/xfce4-session/ChangeLog b/xfce-base/xfce4-session/ChangeLog
index 2bfe93c1cfd3..426278b3e0f8 100644
--- a/xfce-base/xfce4-session/ChangeLog
+++ b/xfce-base/xfce4-session/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for xfce-base/xfce4-session
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/xfce-base/xfce4-session/ChangeLog,v 1.226 2015/03/03 13:10:17 dlan Exp $
+# $Header: /var/cvsroot/gentoo-x86/xfce-base/xfce4-session/ChangeLog,v 1.227 2015/03/08 15:06:39 mgorny Exp $
+
+*xfce4-session-4.12.0 (08 Mar 2015)
+
+ 08 Mar 2015; Michał Górny <mgorny@gentoo.org> +xfce4-session-4.12.0.ebuild,
+ metadata.xml:
+ Xfce 4.12 version bump, bug #541962. https://github.com/gentoo/gentoo-portage-
+ rsync-mirror/pull/63 by me and damex.
03 Mar 2015; Yixun Lan <dlan@gentoo.org> xfce4-session-4.11.0-r2.ebuild:
add arm64 support, tested on A53 board
diff --git a/xfce-base/xfce4-session/xfce4-session-4.12.0.ebuild b/xfce-base/xfce4-session/xfce4-session-4.12.0.ebuild
new file mode 100644
index 000000000000..9b416ad1eda2
--- /dev/null
+++ b/xfce-base/xfce4-session/xfce4-session-4.12.0.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/xfce-base/xfce4-session/xfce4-session-4.12.0.ebuild,v 1.1 2015/03/08 15:06:39 mgorny Exp $
+
+EAPI=5
+EAUTORECONF=1
+inherit xfconf
+
+DESCRIPTION="A session manager for the Xfce desktop environment"
+HOMEPAGE="http://docs.xfce.org/xfce/xfce4-session/start"
+SRC_URI="mirror://xfce/src/xfce/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~x86-solaris"
+IUSE="debug nls policykit systemd upower +xscreensaver"
+
+COMMON_DEPEND=">=dev-libs/dbus-glib-0.100
+ x11-apps/iceauth
+ x11-libs/libSM
+ >=x11-libs/libwnck-2.30:1
+ x11-libs/libX11
+ >=xfce-base/libxfce4util-4.11
+ >=xfce-base/libxfce4ui-4.11
+ >=xfce-base/xfconf-4.10
+ !xfce-base/xfce-utils
+ policykit? ( >=sys-auth/polkit-0.102 )
+ upower? ( || ( >=sys-power/upower-0.9.23 sys-power/upower-pm-utils ) )"
+RDEPEND="${COMMON_DEPEND}
+ x11-apps/xrdb
+ nls? ( x11-misc/xdg-user-dirs )
+ !systemd? ( upower? ( sys-power/pm-utils ) )
+ xscreensaver? ( || (
+ >=x11-misc/xscreensaver-5.26
+ gnome-extra/gnome-screensaver
+ >=x11-misc/xlockmore-5.43
+ x11-misc/slock
+ x11-misc/alock[pam]
+ ) )"
+DEPEND="${COMMON_DEPEND}
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+REQUIRED_USE="systemd? ( policykit )"
+
+pkg_setup() {
+ PATCHES=( "${FILESDIR}"/${PN}-4.10.1-alock_support_to_xflock4.patch )
+
+ XFCONF=(
+ --docdir="${EPREFIX}"/usr/share/doc/${PF}
+ $(use_enable policykit polkit)
+ --with-xsession-prefix="${EPREFIX}"/usr
+ $(xfconf_use_debug)
+ )
+
+ use upower && XFCONF+=( --enable-upower )
+
+ DOCS=( AUTHORS BUGS ChangeLog NEWS README TODO )
+}
+
+src_install() {
+ xfconf_src_install
+
+ local sessiondir=/etc/X11/Sessions
+ echo startxfce4 > "${T}"/Xfce4
+ exeinto ${sessiondir}
+ doexe "${T}"/Xfce4
+ dosym Xfce4 ${sessiondir}/Xfce
+}