summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2010-09-05 21:14:32 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2010-09-05 21:14:32 +0000
commitf31bf2927acc0a672eb021f61f3cd418f474ecc4 (patch)
tree486ee6bc5ade158deca284778641b13ad8518785 /xfce-base/xfce-utils
parentx86 stable wrt bug #335565 (diff)
downloadgentoo-2-f31bf2927acc0a672eb021f61f3cd418f474ecc4.tar.gz
gentoo-2-f31bf2927acc0a672eb021f61f3cd418f474ecc4.tar.bz2
gentoo-2-f31bf2927acc0a672eb021f61f3cd418f474ecc4.zip
Version bump.
(Portage version: 2.2_rc75/cvs/Linux x86_64)
Diffstat (limited to 'xfce-base/xfce-utils')
-rw-r--r--xfce-base/xfce-utils/ChangeLog8
-rw-r--r--xfce-base/xfce-utils/xfce-utils-4.7.0.ebuild53
2 files changed, 60 insertions, 1 deletions
diff --git a/xfce-base/xfce-utils/ChangeLog b/xfce-base/xfce-utils/ChangeLog
index 521a19f9c058..484c5cf7bc2c 100644
--- a/xfce-base/xfce-utils/ChangeLog
+++ b/xfce-base/xfce-utils/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for xfce-base/xfce-utils
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/xfce-base/xfce-utils/ChangeLog,v 1.157 2010/08/29 17:49:26 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/xfce-base/xfce-utils/ChangeLog,v 1.158 2010/09/05 21:14:32 ssuominen Exp $
+
+*xfce-utils-4.7.0 (05 Sep 2010)
+
+ 05 Sep 2010; Samuli Suominen <ssuominen@gentoo.org>
+ +xfce-utils-4.7.0.ebuild:
+ Version bump.
29 Aug 2010; Raúl Porcel <armin76@gentoo.org> xfce-utils-4.6.2.ebuild:
alpha/ia64/sparc stable wrt #323729
diff --git a/xfce-base/xfce-utils/xfce-utils-4.7.0.ebuild b/xfce-base/xfce-utils/xfce-utils-4.7.0.ebuild
new file mode 100644
index 000000000000..03bcdcfa1f03
--- /dev/null
+++ b/xfce-base/xfce-utils/xfce-utils-4.7.0.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/xfce-base/xfce-utils/xfce-utils-4.7.0.ebuild,v 1.1 2010/09/05 21:14:32 ssuominen Exp $
+
+EAPI=2
+inherit xfconf
+
+DESCRIPTION="Collection of utils for Xfce4"
+HOMEPAGE="http://www.xfce.org/projects/xfce-utils/"
+SRC_URI="mirror://xfce/src/xfce/${PN}/4.7/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~x86-solaris"
+IUSE="dbus debug +lock"
+
+# XML-Parser is really a runtime dependency for xfconf-migration-4.6.pl script
+RDEPEND="dev-perl/XML-Parser
+ x11-apps/xrdb
+ x11-libs/libX11
+ >=x11-libs/gtk+-2.10:2
+ >=xfce-base/libxfce4util-4.6
+ >=xfce-base/libxfce4ui-4.7
+ >=xfce-base/xfconf-4.6
+ dbus? ( >=dev-libs/dbus-glib-0.70 )
+ lock? ( || ( x11-misc/xscreensaver
+ gnome-extra/gnome-screensaver
+ x11-misc/xlockmore
+ x11-misc/slock ) )"
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ dev-util/pkgconfig
+ sys-devel/gettext"
+
+pkg_setup() {
+ XFCONF="--disable-dependency-tracking
+ $(use_enable dbus)
+ $(xfconf_use_debug)
+ --with-vendor-info=Gentoo
+ --with-xsession-prefix=${EPREFIX}/usr"
+ DOCS="AUTHORS ChangeLog NEWS README"
+}
+
+src_install() {
+ xfconf_src_install
+
+ insinto /usr/share/xfce4
+ doins "${FILESDIR}"/Gentoo || die
+
+ echo startxfce4 > "${T}"/Xfce4
+ exeinto /etc/X11/Sessions
+ doexe "${T}"/Xfce4 || die
+}