summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Mende <angelos@gentoo.org>2008-11-10 22:03:41 +0000
committerChristoph Mende <angelos@gentoo.org>2008-11-10 22:03:41 +0000
commitaca7cec5dfe066c16944fa26031cd6575737d815 (patch)
tree5cbc2f8e4ae4ef11de056eba3232840153e1c83b /xfce-base/thunar
parentRestrict tests for now, re-add dropped keywords. As per discussion on irc wit... (diff)
downloadgentoo-2-aca7cec5dfe066c16944fa26031cd6575737d815.tar.gz
gentoo-2-aca7cec5dfe066c16944fa26031cd6575737d815.tar.bz2
gentoo-2-aca7cec5dfe066c16944fa26031cd6575737d815.zip
Version bump
(Portage version: 2.2_rc13/cvs/Linux 2.6.28-rc4 x86_64)
Diffstat (limited to 'xfce-base/thunar')
-rw-r--r--xfce-base/thunar/ChangeLog7
-rw-r--r--xfce-base/thunar/thunar-0.9.3.ebuild82
2 files changed, 88 insertions, 1 deletions
diff --git a/xfce-base/thunar/ChangeLog b/xfce-base/thunar/ChangeLog
index bcd553840613..e2ec634d5dd1 100644
--- a/xfce-base/thunar/ChangeLog
+++ b/xfce-base/thunar/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for xfce-base/thunar
# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/xfce-base/thunar/ChangeLog,v 1.57 2008/11/09 08:53:12 angelos Exp $
+# $Header: /var/cvsroot/gentoo-x86/xfce-base/thunar/ChangeLog,v 1.58 2008/11/10 22:03:41 angelos Exp $
+
+*thunar-0.9.3 (10 Nov 2008)
+
+ 10 Nov 2008; Christoph Mende <angelos@gentoo.org> +thunar-0.9.3.ebuild:
+ Version bump
09 Nov 2008; Christoph Mende <angelos@gentoo.org> -thunar-0.8.0-r3.ebuild:
Removed old
diff --git a/xfce-base/thunar/thunar-0.9.3.ebuild b/xfce-base/thunar/thunar-0.9.3.ebuild
new file mode 100644
index 000000000000..bff172080eb7
--- /dev/null
+++ b/xfce-base/thunar/thunar-0.9.3.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/xfce-base/thunar/thunar-0.9.3.ebuild,v 1.1 2008/11/10 22:03:41 angelos Exp $
+
+EAPI=1
+
+inherit eutils virtualx xfce44
+
+MY_P=${P/t/T}
+S=${WORKDIR}/${MY_P}
+
+XFCE_VERSION=4.4.3
+xfce44
+
+DESCRIPTION="File manager"
+HOMEPAGE="http://thunar.xfce.org"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="doc dbus debug exif gnome hal pcre startup-notification +trash-plugin"
+
+RDEPEND=">=dev-lang/perl-5.6
+ x11-libs/libSM
+ >=x11-libs/gtk+-2.6
+ >=dev-libs/glib-2.6
+ >=xfce-extra/exo-0.3.4
+ >=x11-misc/shared-mime-info-0.20
+ >=dev-util/desktop-file-utils-0.14
+ >=xfce-base/libxfce4util-${XFCE_MASTER_VERSION}
+ virtual/fam
+ dbus? ( dev-libs/dbus-glib )
+ hal? ( dev-libs/dbus-glib
+ sys-apps/hal )
+ >=media-libs/freetype-2
+ gnome? ( gnome-base/gconf )
+ exif? ( >=media-libs/libexif-0.6 )
+ >=media-libs/jpeg-6b
+ startup-notification? ( x11-libs/startup-notification )
+ pcre? ( >=dev-libs/libpcre-6 )
+ trash-plugin? ( dev-libs/dbus-glib
+ >=xfce-base/xfce4-panel-${XFCE_MASTER_VERSION} )
+ gnome-base/librsvg"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ dev-util/intltool
+ doc? ( dev-util/gtk-doc )"
+
+DOCS="AUTHORS ChangeLog HACKING FAQ THANKS TODO README NEWS"
+
+pkg_setup() {
+ XFCE_CONFIG+=" $(use_enable exif) $(use_enable gnome gnome-thumbnailers)
+ $(use_enable dbus) $(use_enable pcre)"
+
+ if use hal; then
+ XFCE_CONFIG+=" --enable-dbus --with-volume-manager=hal"
+ else
+ XFCE_CONFIG+=" --with-volume-manager=none"
+ fi
+
+ if use trash-plugin; then
+ XFCE_CONFIG+=" --enable-dbus"
+ else
+ XFCE_CONFIG+=" --disable-tpa-plugin"
+ fi
+
+ local fail="Re-emerge xfce-extra/exo with USE hal."
+ if use hal && ! built_with_use xfce-extra/exo hal; then
+ eerror "${fail}"
+ die "${fail}"
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-missing-audio-cds-for-volman.patch \
+ "${FILESDIR}"/${P}-fix-defuncts.patch
+}
+
+src_test() {
+ Xemake check || die "emake check failed."
+}
+
+xfce44_extra_package