summaryrefslogtreecommitdiff
path: root/x11-wm
diff options
context:
space:
mode:
authorCédric Krier <cedk@gentoo.org>2007-01-16 19:29:28 +0000
committerCédric Krier <cedk@gentoo.org>2007-01-16 19:29:28 +0000
commitf9dd6b3661bd3389f9ba6ed131650f736379c369 (patch)
tree06673954a06e68b0914be295fa4d0744c4ed94af /x11-wm
parentBump to 3.5.6 (prerelease). (diff)
downloadgentoo-2-f9dd6b3661bd3389f9ba6ed131650f736379c369.tar.gz
gentoo-2-f9dd6b3661bd3389f9ba6ed131650f736379c369.tar.bz2
gentoo-2-f9dd6b3661bd3389f9ba6ed131650f736379c369.zip
Version bump
(Portage version: 2.1.1-r2)
Diffstat (limited to 'x11-wm')
-rw-r--r--x11-wm/dwm/ChangeLog7
-rw-r--r--x11-wm/dwm/dwm-3.1.ebuild93
-rw-r--r--x11-wm/dwm/files/digest-dwm-3.13
3 files changed, 102 insertions, 1 deletions
diff --git a/x11-wm/dwm/ChangeLog b/x11-wm/dwm/ChangeLog
index bc137f859f72..04e2cf68c6da 100644
--- a/x11-wm/dwm/ChangeLog
+++ b/x11-wm/dwm/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-wm/dwm
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/dwm/ChangeLog,v 1.4 2007/01/13 14:01:48 cedk Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/dwm/ChangeLog,v 1.5 2007/01/16 19:29:28 cedk Exp $
+
+*dwm-3.1 (16 Jan 2007)
+
+ 16 Jan 2007; Cedric Krier <cedk@gentoo.org> +dwm-3.1.ebuild:
+ Version bump
*dwm-3.0 (13 Jan 2007)
diff --git a/x11-wm/dwm/dwm-3.1.ebuild b/x11-wm/dwm/dwm-3.1.ebuild
new file mode 100644
index 000000000000..fc1c8d632300
--- /dev/null
+++ b/x11-wm/dwm/dwm-3.1.ebuild
@@ -0,0 +1,93 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/dwm/dwm-3.1.ebuild,v 1.1 2007/01/16 19:29:28 cedk Exp $
+
+inherit toolchain-funcs
+
+DESCRIPTION="a dynamic window manager for X11"
+HOMEPAGE="http://suckless.org/view/dynamic+window+manager"
+SRC_URI="http://suckless.org/download/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="savedconfig"
+
+DEPEND="x11-libs/libX11"
+RDEPEND=${DEPEND}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ sed -i \
+ -e "s/.*strip.*//" \
+ Makefile || die "sed failed"
+
+ sed -i \
+ -e "s/CFLAGS = -Os/CFLAGS +=/" \
+ -e "s/LDFLAGS =/LDFLAGS +=/" \
+ config.mk || die "sed failed"
+
+ if use savedconfig; then
+ local conf root
+ [[ -r config.h ]] && rm config.h
+ for conf in ${PF} ${P} ${PN}; do
+ for root in "${PORTAGE_CONFIGROOT}" "${ROOT}" /; do
+ configfile=${root}etc/portage/savedconfig/${conf}.config.h
+ if [[ -r ${configfile} ]]; then
+ elog "Found your ${configfile} and using it."
+ cp ${configfile} "${S}"/config.h
+ return 0
+ fi
+ done
+ done
+ ewarn "Could not locate user configfile, so we will save a default one."
+ fi
+}
+
+src_compile() {
+ local msg
+ use savedconfig && msg=", please check the configfile"
+ emake CC=$(tc-getCC) || die "emake failed${msg}"
+}
+
+src_install() {
+ emake DESTDIR="${D}" PREFIX="/usr" install || die "emake install failed"
+
+ insinto /usr/share/${PN}
+ newins config.h ${PF}.config.h
+
+ exeinto /etc/X11/Sessions
+ newexe "${FILESDIR}"/dwm-session dwm
+
+ insinto /usr/share/xsessions
+ doins "${FILESDIR}"/dwm.desktop
+
+ dodoc README
+}
+
+pkg_preinst() {
+ if use savedconfig; then
+ mv "${D}"/usr/share/${PN}/${PF}.config.h "${T}"/ || die
+ fi
+}
+
+pkg_postinst() {
+ if use savedconfig; then
+ local config_dir="${PORTAGE_CONFIGROOT:-${ROOT}}/etc/portage/savedconfig"
+ elog "Saving this build config to ${config_dir}/${PF}.config.h"
+ einfo "Read this ebuild for more info on how to take advantage of this option."
+ mkdir -p "${config_dir}"
+ cp "${T}"/${PF}.config.h "${config_dir}"/${PF}.config.h
+ fi
+ einfo "This ebuild has support for user defined configs"
+ einfo "Please read this ebuild for more details and re-emerge as needed"
+ einfo "if you want to add or remove functionality for ${PN}"
+ if ! has_version x11-misc/dmenu; then
+ elog "Installing ${PN} without x11-misc/dmenu"
+ einfo "To have a menu you can install x11-misc/dmenu"
+ fi
+ einfo "You can custom status bar with a script in HOME/.dwm/dwmrc"
+ einfo "the ouput is redirected to the standard input of dwm"
+}
diff --git a/x11-wm/dwm/files/digest-dwm-3.1 b/x11-wm/dwm/files/digest-dwm-3.1
new file mode 100644
index 000000000000..a085a8c0ef6e
--- /dev/null
+++ b/x11-wm/dwm/files/digest-dwm-3.1
@@ -0,0 +1,3 @@
+MD5 da36256461f98bfa9d4ae0a4b9bf988f dwm-3.1.tar.gz 17492
+RMD160 9ebe31e761617b113e3ab89b8aafa5adecc5d09e dwm-3.1.tar.gz 17492
+SHA256 8000b7f1f171672c9a1163b1839aa5e321d76628b5ff0a2ca5d889713ef295ad dwm-3.1.tar.gz 17492