summaryrefslogtreecommitdiff
path: root/x11-wm
diff options
context:
space:
mode:
authorYuri Vasilevski <yvasilev@gentoo.org>2006-06-14 21:50:45 +0000
committerYuri Vasilevski <yvasilev@gentoo.org>2006-06-14 21:50:45 +0000
commite2bc3d44b9c0b70ae71284c943e221fd0410c116 (patch)
tree899380ba76be65a1bf173e55fc811dda7af56d80 /x11-wm
parentbetter einfo, remove comment (diff)
downloadgentoo-2-e2bc3d44b9c0b70ae71284c943e221fd0410c116.tar.gz
gentoo-2-e2bc3d44b9c0b70ae71284c943e221fd0410c116.tar.bz2
gentoo-2-e2bc3d44b9c0b70ae71284c943e221fd0410c116.zip
Allows to build with USE=-png
(Portage version: 2.1)
Diffstat (limited to 'x11-wm')
-rw-r--r--x11-wm/matchbox-window-manager/ChangeLog7
-rw-r--r--x11-wm/matchbox-window-manager/files/matchbox-window-manager-1.0-use-nopng.patch27
-rw-r--r--x11-wm/matchbox-window-manager/matchbox-window-manager-1.0.ebuild12
3 files changed, 43 insertions, 3 deletions
diff --git a/x11-wm/matchbox-window-manager/ChangeLog b/x11-wm/matchbox-window-manager/ChangeLog
index 18cd1ac0ac35..74099fc6097a 100644
--- a/x11-wm/matchbox-window-manager/ChangeLog
+++ b/x11-wm/matchbox-window-manager/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-wm/matchbox-window-manager
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/matchbox-window-manager/ChangeLog,v 1.3 2006/06/04 21:47:11 yvasilev Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/matchbox-window-manager/ChangeLog,v 1.4 2006/06/14 21:50:45 yvasilev Exp $
+
+ 14 Jun 2006; <yvasilev@gentoo.org>
+ +files/matchbox-window-manager-1.0-use-nopng.patch,
+ matchbox-window-manager-1.0.ebuild:
+ Allows to build with USE=-png
*matchbox-window-manager-1.0 (04 Jun 2006)
diff --git a/x11-wm/matchbox-window-manager/files/matchbox-window-manager-1.0-use-nopng.patch b/x11-wm/matchbox-window-manager/files/matchbox-window-manager-1.0-use-nopng.patch
new file mode 100644
index 000000000000..881567d9b96d
--- /dev/null
+++ b/x11-wm/matchbox-window-manager/files/matchbox-window-manager-1.0-use-nopng.patch
@@ -0,0 +1,27 @@
+diff -Naurp matchbox-window-manager-1.0.orig/src/structs.h matchbox-window-manager-1.0/src/structs.h
+--- matchbox-window-manager-1.0.orig/src/structs.h 2006-02-19 16:00:52.000000000 -0500
++++ matchbox-window-manager-1.0/src/structs.h 2006-06-12 18:52:53.000000000 -0400
+@@ -81,23 +81,12 @@
+
+ #define GENERIC_ICON PKGDATADIR "/mbnoapp.xpm"
+
+-#ifdef MB_HAVE_PNG
+-
+ #define DEFAULT_THEME DATADIR "/themes/Default/matchbox/theme.xml"
+-
+ #define DEFAULTTHEME DATADIR "/themes/Default/matchbox/theme.xml"
+
+ #define DEFAULT_THEMENAME "Default"
+-
+ #define DEFAULTTHEMENAME "Default"
+
+-#else
+-
+-#define DEFAULT_THEME DATADIR "/themes/Default/matchbox/theme.xml"
+-#define DEFAULT_THEME_NAME "Default"
+-
+-#endif
+-
+ #define CONFDEFAULTS PKGDATADIR "/defaults"
+
+ /* Simple Macros */
diff --git a/x11-wm/matchbox-window-manager/matchbox-window-manager-1.0.ebuild b/x11-wm/matchbox-window-manager/matchbox-window-manager-1.0.ebuild
index 6c3917f599bd..2c02ba1c7de2 100644
--- a/x11-wm/matchbox-window-manager/matchbox-window-manager-1.0.ebuild
+++ b/x11-wm/matchbox-window-manager/matchbox-window-manager-1.0.ebuild
@@ -1,8 +1,8 @@
# Copyright 2006-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/matchbox-window-manager/matchbox-window-manager-1.0.ebuild,v 1.1 2006/06/04 21:47:11 yvasilev Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/matchbox-window-manager/matchbox-window-manager-1.0.ebuild,v 1.2 2006/06/14 21:50:45 yvasilev Exp $
-inherit versionator
+inherit eutils versionator
DESCRIPTION="Light weight WM designed for use on PDA computers"
HOMEPAGE="http://projects.o-hand.com/matchbox/"
@@ -23,6 +23,14 @@ DEPEND=">=x11-libs/libmatchbox-1.5
x11-libs/libXdamage )
virtual/x11 ) )"
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ # Allows to build with USE=-png
+ epatch "${FILESDIR}/${P}-use-nopng.patch"
+}
+
src_compile() {
econf --enable-keyboard \
--enable-ping-protocol \