summaryrefslogtreecommitdiff
path: root/x11-wm
diff options
context:
space:
mode:
authorAaron Walker <ka0ttic@gentoo.org>2005-10-27 21:50:32 +0000
committerAaron Walker <ka0ttic@gentoo.org>2005-10-27 21:50:32 +0000
commite097b8199d30ca33909fa86167c8b1e597a281d8 (patch)
treeec5588e7e0ed10f1ed0818daeda99da318a5e42e /x11-wm
parentAdded patch to compile on FreeBSD as per bug #109519. (diff)
downloadgentoo-2-e097b8199d30ca33909fa86167c8b1e597a281d8.tar.gz
gentoo-2-e097b8199d30ca33909fa86167c8b1e597a281d8.tar.bz2
gentoo-2-e097b8199d30ca33909fa86167c8b1e597a281d8.zip
Marked 2.1.2 stable on x86; tidy old ebuilds.
(Portage version: 2.0.53_rc6)
Diffstat (limited to 'x11-wm')
-rw-r--r--x11-wm/afterstep/ChangeLog7
-rw-r--r--x11-wm/afterstep/afterstep-2.00.04.ebuild114
-rw-r--r--x11-wm/afterstep/afterstep-2.1.1.ebuild114
-rw-r--r--x11-wm/afterstep/afterstep-2.1.2.ebuild4
-rw-r--r--x11-wm/afterstep/files/digest-afterstep-2.00.041
-rw-r--r--x11-wm/afterstep/files/digest-afterstep-2.1.11
-rw-r--r--x11-wm/afterstep/metadata.xml5
7 files changed, 9 insertions, 237 deletions
diff --git a/x11-wm/afterstep/ChangeLog b/x11-wm/afterstep/ChangeLog
index 14dab23763b8..e44364cfc095 100644
--- a/x11-wm/afterstep/ChangeLog
+++ b/x11-wm/afterstep/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-wm/afterstep
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/afterstep/ChangeLog,v 1.45 2005/08/23 18:55:31 ka0ttic Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/afterstep/ChangeLog,v 1.46 2005/10/27 21:50:32 ka0ttic Exp $
+
+ 27 Oct 2005; Aaron Walker <ka0ttic@gentoo.org> metadata.xml,
+ -afterstep-2.00.04.ebuild, -afterstep-2.1.1.ebuild,
+ afterstep-2.1.2.ebuild:
+ Marked 2.1.2 stable on x86; tidy old ebuilds.
23 Aug 2005; Aaron Walker <ka0ttic@gentoo.org> afterstep-1.8.11-r2.ebuild,
afterstep-2.00.04.ebuild, afterstep-2.00.05.ebuild,
diff --git a/x11-wm/afterstep/afterstep-2.00.04.ebuild b/x11-wm/afterstep/afterstep-2.00.04.ebuild
deleted file mode 100644
index dc0490e08a3a..000000000000
--- a/x11-wm/afterstep/afterstep-2.00.04.ebuild
+++ /dev/null
@@ -1,114 +0,0 @@
-# Copyright 1999-2005 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/afterstep/afterstep-2.00.04.ebuild,v 1.7 2005/08/23 18:55:31 ka0ttic Exp $
-
-inherit flag-o-matic
-
-DESCRIPTION="AfterStep is a feature rich NeXTish window manager"
-HOMEPAGE="http://www.afterstep.org"
-SRC_URI="ftp://ftp.afterstep.org/stable/AfterStep-${PV}.tar.bz2"
-
-LICENSE="AFTERSTEP"
-SLOT="0"
-KEYWORDS="x86 ~ppc sparc"
-IUSE="debug gif jpeg mmx nls png tiff xinerama"
-
-DEPEND="virtual/libc
- virtual/x11
- media-libs/freetype
- debug? ( !ppc? ( dev-util/efence ) )
- png? ( >=media-libs/libpng-1.2.5 )
- jpeg? ( >=media-libs/jpeg-6b )
- gif? ( >=media-libs/giflib-4.1.0 )
- tiff? ( >=media-libs/tiff-3.5.7 )"
-
-S="${WORKDIR}/AfterStep-${PV}"
-
-src_compile() {
- local myconf
-
- use debug && myconf="--enable-gdb --enable-warn --enable-gprof
- --enable-audit --enable-trace --enable-trace-x"
-
- if ! use ppc && use debug ; then
- myconf="${myconf} --with-libefence"
- fi
-
- #implied intent of debug means you need the frame pointers.
- use debug && filter-flags -fomit-frame-pointer
-
- # Explanation of configure options
- # ================================
- # --with-helpcommand="xterm -e man" - Avoid installing xiterm
- # --with-xpm - Contained in xfree
- # --with-ungif=no - Use giflib instead of libungif
- # --disable-availability - So we can use complete paths for menuitems
- # --enable-ascp - The AfterStep ControlPanel is abandoned
-
- econf \
- $(use_enable nls i18n) \
- $(use_enable mmx mmx-optimization) \
- $(use_enable xinerama) \
- $(use_with png) \
- $(use_with jpeg) \
- $(use_with gif) \
- $(use_with tiff) \
- --with-helpcommand="xterm -e man" \
- --with-ungif=no \
- --disable-availability \
- --disable-staticlibs \
- --enable-ascp=no \
- ${myconf} || die "configure failed"
-
- emake || die "emake failed"
-}
-
-src_install() {
- # see bug #31541
- dodir /usr/share/gnome/wm-properties
-
- # afterstep tries to detect the current resolution
- # for documentation generation, causing access violations
- # for the video device. bug #87356
- unset DISPLAY
-
- make DESTDIR=${D} install || die "make install failed"
-
- # This fixes a bug with shared libraries
- rm ${D}/usr/lib/{libAfterImage.a,libAfterBase.a}
- cp -pPR ${S}/libAfterImage/libAfterImage.so* ${D}/usr/lib
- cp -pPR ${S}/libAfterBase/libAfterBase.so* ${D}/usr/lib
- cp -pPR ${S}/libAfterConf/libAfterConf.so* ${D}/usr/lib
- cp -pPR ${S}/libAfterStep/libAfterStep.so* ${D}/usr/lib
-
- # Create a symlink from MonitorWharf to Wharf
- rm ${D}/usr/bin/MonitorWharf
- dosym /usr/bin/Wharf /usr/bin/MonitorWharf
-
- # Handle the documentation
- dodoc COPYRIGHT ChangeLog INSTALL NEW* README* TEAM UPGRADE
- cp -pPR ${S}/TODO ${D}/usr/share/doc/${PF}/
- dodir /usr/share/doc/${PF}/html
- cp -pPR ${S}/doc/* ${D}/usr/share/doc/${PF}/html
- rm ${D}/usr/share/doc/${PF}/html/{Makefile*,afterstepdoc.in}
-
- dodir /usr/share/xsessions
- insinto /usr/share/xsessions
- newins ${S}/AfterStep.desktop.final AfterStep.desktop
-
- # For desktop managers like GDM or KDE
- exeinto /etc/X11/Sessions
- doexe ${FILESDIR}/afterstep
-}
-
-pkg_postinst() {
- echo
- einfo "To use AfterStep issue the following commands:"
- einfo "mv ~/.xinitrc ~/xinitrc.old"
- einfo "echo afterstep > ~/.xinitrc"
- echo
- einfo "If you like AfterStep please vote for it at"
- einfo "http://www.PLiG.org/xwinman/vote.html !"
- echo
-}
-
diff --git a/x11-wm/afterstep/afterstep-2.1.1.ebuild b/x11-wm/afterstep/afterstep-2.1.1.ebuild
deleted file mode 100644
index 1087b26d5a71..000000000000
--- a/x11-wm/afterstep/afterstep-2.1.1.ebuild
+++ /dev/null
@@ -1,114 +0,0 @@
-# Copyright 1999-2005 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/afterstep/afterstep-2.1.1.ebuild,v 1.5 2005/08/23 18:55:31 ka0ttic Exp $
-
-inherit flag-o-matic
-
-DESCRIPTION="AfterStep is a feature rich NeXTish window manager"
-HOMEPAGE="http://www.afterstep.org"
-SRC_URI="ftp://ftp.afterstep.org/stable/AfterStep-${PV}.tar.bz2"
-
-LICENSE="AFTERSTEP"
-SLOT="0"
-KEYWORDS="~mips ~ppc ~ppc64 ~sparc ~x86"
-IUSE="debug gif jpeg mmx nls png tiff xinerama"
-
-DEPEND="virtual/libc
- virtual/x11
- media-libs/freetype
- debug? ( !ppc? ( dev-util/efence ) )
- png? ( >=media-libs/libpng-1.2.5 )
- jpeg? ( >=media-libs/jpeg-6b )
- gif? ( >=media-libs/giflib-4.1.0 )
- tiff? ( >=media-libs/tiff-3.5.7 )"
-
-S="${WORKDIR}/AfterStep-${PV}"
-
-src_compile() {
- local myconf
-
- use debug && myconf="--enable-gdb --enable-warn --enable-gprof
- --enable-audit --enable-trace --enable-trace-x"
-
- if ! use ppc && use debug ; then
- myconf="${myconf} --with-libefence"
- fi
-
- #implied intent of debug means you need the frame pointers.
- use debug && filter-flags -fomit-frame-pointer
-
- # Explanation of configure options
- # ================================
- # --with-helpcommand="xterm -e man" - Avoid installing xiterm
- # --with-xpm - Contained in xfree
- # --with-ungif=no - Use giflib instead of libungif
- # --disable-availability - So we can use complete paths for menuitems
- # --enable-ascp - The AfterStep ControlPanel is abandoned
-
- econf \
- $(use_enable nls i18n) \
- $(use_enable mmx mmx-optimization) \
- $(use_enable xinerama) \
- $(use_with png) \
- $(use_with jpeg) \
- $(use_with gif) \
- $(use_with tiff) \
- --with-helpcommand="xterm -e man" \
- --with-ungif=no \
- --disable-availability \
- --disable-staticlibs \
- --enable-ascp=no \
- ${myconf} || die "configure failed"
-
- emake || die "emake failed"
-}
-
-src_install() {
- # see bug #31541
- dodir /usr/share/gnome/wm-properties
-
- # afterstep tries to detect the current resolution
- # for documentation generation, causing access violations
- # for the video device. bug #87356
- unset DISPLAY
-
- make DESTDIR=${D} install || die "make install failed"
-
- # This fixes a bug with shared libraries
- rm ${D}/usr/lib/{libAfterImage.a,libAfterBase.a}
- cp -pPR ${S}/libAfterImage/libAfterImage.so* ${D}/usr/lib
- cp -pPR ${S}/libAfterBase/libAfterBase.so* ${D}/usr/lib
- cp -pPR ${S}/libAfterConf/libAfterConf.so* ${D}/usr/lib
- cp -pPR ${S}/libAfterStep/libAfterStep.so* ${D}/usr/lib
-
- # Create a symlink from MonitorWharf to Wharf
- rm ${D}/usr/bin/MonitorWharf
- dosym /usr/bin/Wharf /usr/bin/MonitorWharf
-
- # Handle the documentation
- dodoc COPYRIGHT ChangeLog INSTALL NEW* README* TEAM UPGRADE
- cp -pPR ${S}/TODO ${D}/usr/share/doc/${PF}/
- dodir /usr/share/doc/${PF}/html
- cp -pPR ${S}/doc/* ${D}/usr/share/doc/${PF}/html
- rm ${D}/usr/share/doc/${PF}/html/{Makefile*,afterstepdoc.in}
-
- dodir /usr/share/xsessions
- insinto /usr/share/xsessions
- newins ${S}/AfterStep.desktop.final AfterStep.desktop
-
- # For desktop managers like GDM or KDE
- exeinto /etc/X11/Sessions
- doexe ${FILESDIR}/afterstep
-}
-
-pkg_postinst() {
- echo
- einfo "To use AfterStep issue the following commands:"
- einfo "mv ~/.xinitrc ~/xinitrc.old"
- einfo "echo afterstep > ~/.xinitrc"
- echo
- einfo "If you like AfterStep please vote for it at"
- einfo "http://www.PLiG.org/xwinman/vote.html !"
- echo
-}
-
diff --git a/x11-wm/afterstep/afterstep-2.1.2.ebuild b/x11-wm/afterstep/afterstep-2.1.2.ebuild
index ca59530fd431..7b3d25a1bd5b 100644
--- a/x11-wm/afterstep/afterstep-2.1.2.ebuild
+++ b/x11-wm/afterstep/afterstep-2.1.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/afterstep/afterstep-2.1.2.ebuild,v 1.3 2005/08/23 18:55:31 ka0ttic Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/afterstep/afterstep-2.1.2.ebuild,v 1.4 2005/10/27 21:50:32 ka0ttic Exp $
inherit flag-o-matic
@@ -10,7 +10,7 @@ SRC_URI="ftp://ftp.afterstep.org/stable/AfterStep-${PV}.tar.bz2"
LICENSE="AFTERSTEP"
SLOT="0"
-KEYWORDS="~amd64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+KEYWORDS="~amd64 ~mips ~ppc ~ppc64 ~sparc x86"
IUSE="debug gif jpeg mmx nls png tiff xinerama"
DEPEND="virtual/libc
diff --git a/x11-wm/afterstep/files/digest-afterstep-2.00.04 b/x11-wm/afterstep/files/digest-afterstep-2.00.04
deleted file mode 100644
index a69e39b644c8..000000000000
--- a/x11-wm/afterstep/files/digest-afterstep-2.00.04
+++ /dev/null
@@ -1 +0,0 @@
-MD5 5b1459a9c8f06100d0c1c0002aa3399c AfterStep-2.00.04.tar.bz2 4710344
diff --git a/x11-wm/afterstep/files/digest-afterstep-2.1.1 b/x11-wm/afterstep/files/digest-afterstep-2.1.1
deleted file mode 100644
index 1a368c649c10..000000000000
--- a/x11-wm/afterstep/files/digest-afterstep-2.1.1
+++ /dev/null
@@ -1 +0,0 @@
-MD5 5b02ebcab3be1227cd227e39ab169bd3 AfterStep-2.1.1.tar.bz2 5025858
diff --git a/x11-wm/afterstep/metadata.xml b/x11-wm/afterstep/metadata.xml
index 7b5bac145667..bb5dbc652bc7 100644
--- a/x11-wm/afterstep/metadata.xml
+++ b/x11-wm/afterstep/metadata.xml
@@ -3,11 +3,8 @@
<pkgmetadata>
<herd>afterstep</herd>
<maintainer>
- <email>ka0ttic@gentoo.org</email>
- <name>Aaron Walker</name>
- </maintainer>
- <maintainer>
<email>gentoo.org@vaevictus.net</email>
<name>Nathan Mahon</name>
+ <description>Upstream developer; afterstep herd maintains on his behalf</description>
</maintainer>
</pkgmetadata>