summaryrefslogtreecommitdiff
path: root/x11-wm
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2015-08-02 01:23:46 +0000
committerTim Harder <radhermit@gentoo.org>2015-08-02 01:23:46 +0000
commitc7c937cf131838e8b6f4245c98af8191d40357c3 (patch)
tree4519440981ef87fb968bbd972748c32c8a4eead5 /x11-wm
parentadd pypy support (diff)
downloadgentoo-2-c7c937cf131838e8b6f4245c98af8191d40357c3.tar.gz
gentoo-2-c7c937cf131838e8b6f4245c98af8191d40357c3.tar.bz2
gentoo-2-c7c937cf131838e8b6f4245c98af8191d40357c3.zip
Version bump.
(Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key 4AB3E85B4F064CA3)
Diffstat (limited to 'x11-wm')
-rw-r--r--x11-wm/qtile/ChangeLog7
-rw-r--r--x11-wm/qtile/qtile-0.10.1.ebuild56
2 files changed, 62 insertions, 1 deletions
diff --git a/x11-wm/qtile/ChangeLog b/x11-wm/qtile/ChangeLog
index fa11061c04e9..e7eaf15972b5 100644
--- a/x11-wm/qtile/ChangeLog
+++ b/x11-wm/qtile/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-wm/qtile
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/qtile/ChangeLog,v 1.18 2015/07/10 01:21:12 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/qtile/ChangeLog,v 1.19 2015/08/02 01:23:46 radhermit Exp $
+
+*qtile-0.10.1 (02 Aug 2015)
+
+ 02 Aug 2015; Tim Harder <radhermit@gentoo.org> +qtile-0.10.1.ebuild:
+ Version bump.
*qtile-0.10.0 (10 Jul 2015)
diff --git a/x11-wm/qtile/qtile-0.10.1.ebuild b/x11-wm/qtile/qtile-0.10.1.ebuild
new file mode 100644
index 000000000000..4d9e03058006
--- /dev/null
+++ b/x11-wm/qtile/qtile-0.10.1.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/qtile/qtile-0.10.1.ebuild,v 1.1 2015/08/02 01:23:46 radhermit Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_4} )
+
+inherit distutils-r1 virtualx
+
+if [[ ${PV} == 9999* ]] ; then
+ EGIT_REPO_URI="https://github.com/qtile/qtile.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/qtile/qtile/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="A full-featured, hackable tiling window manager written in Python"
+HOMEPAGE="http://qtile.org/"
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="test"
+# docs require sphinxcontrib-blockdiag and sphinxcontrib-seqdiag
+
+RDEPEND="x11-libs/pango
+ >=dev-python/cairocffi-0.7[${PYTHON_USEDEP}]
+ >=dev-python/cffi-1.1.0[${PYTHON_USEDEP}]
+ >=dev-python/six-1.4.1[${PYTHON_USEDEP}]
+ >=dev-python/xcffib-0.3.2[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep 'dev-python/trollius[${PYTHON_USEDEP}]' 'python2*')
+"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/nose[${PYTHON_USEDEP}]
+ x11-base/xorg-server[kdrive]
+ )
+"
+
+RESTRICT="test"
+
+python_test() {
+ VIRTUALX_COMMAND="nosetests" virtualmake
+}
+
+python_install_all() {
+ local DOCS=( CHANGELOG README.rst )
+ distutils-r1_python_install_all
+
+ insinto /usr/share/xsessions
+ doins resources/qtile.desktop
+
+ exeinto /etc/X11/Sessions
+ newexe "${FILESDIR}"/${PN}-session ${PN}
+}