summaryrefslogtreecommitdiff
path: root/x11-wm
diff options
context:
space:
mode:
authorJoshua Charles Campbell <warpzero@gentoo.org>2005-05-11 02:39:26 +0000
committerJoshua Charles Campbell <warpzero@gentoo.org>2005-05-11 02:39:26 +0000
commitc5eb48f6b591037425eac059c048806194b7f371 (patch)
tree1eca8c6ec89c26e28ff82b869db5fac8e0c4f241 /x11-wm
parentFix keywords. (diff)
downloadgentoo-2-c5eb48f6b591037425eac059c048806194b7f371.tar.gz
gentoo-2-c5eb48f6b591037425eac059c048806194b7f371.tar.bz2
gentoo-2-c5eb48f6b591037425eac059c048806194b7f371.zip
bump ion3
(Portage version: 2.0.51.19)
Diffstat (limited to 'x11-wm')
-rw-r--r--x11-wm/ion3/ChangeLog7
-rw-r--r--x11-wm/ion3/Manifest2
-rw-r--r--x11-wm/ion3/files/digest-ion3-200505021
-rw-r--r--x11-wm/ion3/ion3-20050502.ebuild68
4 files changed, 77 insertions, 1 deletions
diff --git a/x11-wm/ion3/ChangeLog b/x11-wm/ion3/ChangeLog
index 88089303bdab..aa196e5f0a5c 100644
--- a/x11-wm/ion3/ChangeLog
+++ b/x11-wm/ion3/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-wm/ion3
# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/ion3/ChangeLog,v 1.19 2005/04/21 22:39:34 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/ion3/ChangeLog,v 1.20 2005/05/11 02:39:26 warpzero Exp $
+
+*ion3-20050505 (10 May 2005)
+
+ 10 May 2005: Joshua Charles Campbell <warpzero@gentoo.org> ion3-20050505.ebuild,
+ Version bump.
21 Apr 2005; Aron Griffis <agriffis@gentoo.org> ion3-20050116.ebuild,
ion3-20050322.ebuild:
diff --git a/x11-wm/ion3/Manifest b/x11-wm/ion3/Manifest
index 9e69306cb424..8ca8385903c9 100644
--- a/x11-wm/ion3/Manifest
+++ b/x11-wm/ion3/Manifest
@@ -1,8 +1,10 @@
MD5 447a6bc277a9cb636d4ccc4b33f55bd5 ion3-20050322.ebuild 1595
MD5 81491d43cb97cde860ac2d6e291dee8e ion3-20050116.ebuild 1591
+MD5 447a6bc277a9cb636d4ccc4b33f55bd5 ion3-20050502.ebuild 1595
MD5 081c886bc8d0dcd84e3f7f9bdbe0d524 ChangeLog 2632
MD5 d992d28bec4a3bfd72b441145091a58e metadata.xml 244
MD5 e5e408ab1f83116c2138a26b20c86653 files/pwm3.desktop 170
MD5 00450ed1292b72e2be71b9860c4db6ee files/ion3.desktop 217
MD5 f5a4c637813405c5a7b6a5fa8c68c748 files/digest-ion3-20050116 68
MD5 4e5d9581a3b82804570c95a96bae9684 files/digest-ion3-20050322 68
+MD5 1e45cb80fb365e65fe31ddac6d6cc9cd files/digest-ion3-20050502 68
diff --git a/x11-wm/ion3/files/digest-ion3-20050502 b/x11-wm/ion3/files/digest-ion3-20050502
new file mode 100644
index 000000000000..02525dbf07de
--- /dev/null
+++ b/x11-wm/ion3/files/digest-ion3-20050502
@@ -0,0 +1 @@
+MD5 545cbb9894ee8fe47fc97e51c28227a5 ion-3ds-20050502.tar.gz 605830
diff --git a/x11-wm/ion3/ion3-20050502.ebuild b/x11-wm/ion3/ion3-20050502.ebuild
new file mode 100644
index 000000000000..d106c8102867
--- /dev/null
+++ b/x11-wm/ion3/ion3-20050502.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/ion3/ion3-20050502.ebuild,v 1.1 2005/05/11 02:39:26 warpzero Exp $
+
+inherit eutils
+
+MY_PV=${PV/_p/-}
+MY_PN=ion-3ds-${MY_PV}
+DESCRIPTION="A tiling tabbed window manager designed with keyboard users in mind"
+HOMEPAGE="http://www.iki.fi/tuomov/ion/"
+SRC_URI="http://modeemi.cs.tut.fi/~tuomov/ion/dl/${MY_PN}.tar.gz"
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~sparc ~x86"
+IUSE="xinerama"
+DEPEND="virtual/x11
+ app-misc/run-mailcap
+ >=dev-lang/lua-5.0.2"
+S=${WORKDIR}/${MY_PN}
+
+src_compile() {
+
+ autoreconf
+
+ local myconf=""
+
+ if has_version '>=x11-base/xfree-4.3.0'; then
+ myconf="${myconf} --disable-xfree86-textprop-bug-workaround"
+ fi
+
+ use hppa && myconf="${myconf} --disable-shared"
+
+ econf \
+ --sysconfdir=/etc/X11 \
+ `use_enable xinerama` \
+ ${myconf} || die
+
+ make \
+ DOCDIR=/usr/share/doc/${PF} || die
+
+}
+
+src_install() {
+
+ make \
+ prefix=${D}/usr \
+ ETCDIR=${D}/etc/X11/ion3 \
+ SHAREDIR=${D}/usr/share/ion3 \
+ MANDIR=${D}/usr/share/man \
+ DOCDIR=${D}/usr/share/doc/${PF} \
+ LOCALEDIR=${D}/usr/share/locale \
+ LIBDIR=${D}/usr/lib \
+ MODULEDIR=${D}/usr/lib/ion3/mod \
+ LCDIR=${D}/usr/lib/ion3/lc \
+ VARDIR=${D}/var/cache/ion3 \
+ install || die
+
+ prepalldocs
+
+ echo -e "#!/bin/sh\n/usr/bin/ion3" > ${T}/ion3
+ echo -e "#!/bin/sh\n/usr/bin/pwm3" > ${T}/pwm3
+ exeinto /etc/X11/Sessions
+ doexe ${T}/ion3 ${T}/pwm3
+
+ insinto /usr/share/xsessions
+ doins ${FILESDIR}/ion3.desktop ${FILESDIR}/pwm3.desktop
+
+}