summaryrefslogtreecommitdiff
path: root/x11-wm
diff options
context:
space:
mode:
authorCédric Krier <cedk@gentoo.org>2008-06-19 09:09:25 +0000
committerCédric Krier <cedk@gentoo.org>2008-06-19 09:09:25 +0000
commit896200ce1d4687130b6d360524ac8e9f59d3365a (patch)
tree84bde53cd0f3af0b7022f04ba4fec56566b5e21a /x11-wm
parentRevision bump so users get the changes, see the changelog to see whats new (diff)
downloadgentoo-2-896200ce1d4687130b6d360524ac8e9f59d3365a.tar.gz
gentoo-2-896200ce1d4687130b6d360524ac8e9f59d3365a.tar.bz2
gentoo-2-896200ce1d4687130b6d360524ac8e9f59d3365a.zip
Version bump
(Portage version: 2.1.4.4)
Diffstat (limited to 'x11-wm')
-rw-r--r--x11-wm/dwm/ChangeLog7
-rw-r--r--x11-wm/dwm/dwm-5.0.1.ebuild66
2 files changed, 72 insertions, 1 deletions
diff --git a/x11-wm/dwm/ChangeLog b/x11-wm/dwm/ChangeLog
index daaa9c7e7b8e..307b813d15f4 100644
--- a/x11-wm/dwm/ChangeLog
+++ b/x11-wm/dwm/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-wm/dwm
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/dwm/ChangeLog,v 1.34 2008/04/04 16:57:05 cedk Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/dwm/ChangeLog,v 1.35 2008/06/19 09:09:25 cedk Exp $
+
+*dwm-5.0.1 (19 Jun 2008)
+
+ 19 Jun 2008; Cédric Krier <cedk@gentoo.org> +dwm-5.0.1.ebuild:
+ Version bump
*dwm-4.9 (04 Apr 2008)
diff --git a/x11-wm/dwm/dwm-5.0.1.ebuild b/x11-wm/dwm/dwm-5.0.1.ebuild
new file mode 100644
index 000000000000..6524648e5669
--- /dev/null
+++ b/x11-wm/dwm/dwm-5.0.1.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/dwm/dwm-5.0.1.ebuild,v 1.1 2008/06/19 09:09:25 cedk Exp $
+
+inherit toolchain-funcs savedconfig
+
+DESCRIPTION="a dynamic window manager for X11"
+HOMEPAGE="http://dwm.suckless.org/"
+SRC_URI="http://suckless.org/download/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE=""
+
+DEPEND="x11-libs/libX11"
+RDEPEND=${DEPEND}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ sed -i \
+ -e "s/CFLAGS = -Os/CFLAGS += -g/" \
+ -e "s/LDFLAGS = -s/LDFLAGS += -g/" \
+ config.mk || die "sed failed"
+
+ if use savedconfig; then
+ restore_config config.h
+ fi
+}
+
+src_compile() {
+ local msg
+ use savedconfig && msg=", please check the configfile"
+ emake CC=$(tc-getCC) || die "emake failed${msg}"
+}
+
+src_install() {
+ emake DESTDIR="${D}" PREFIX="/usr" install || die "emake install failed"
+
+ insinto /usr/share/${PN}
+ newins config.h ${PF}.config.h
+
+ exeinto /etc/X11/Sessions
+ newexe "${FILESDIR}"/dwm-session dwm
+
+ insinto /usr/share/xsessions
+ doins "${FILESDIR}"/dwm.desktop
+
+ dodoc README
+
+ save_config config.h
+}
+
+pkg_postinst() {
+ einfo "This ebuild has support for user defined configs"
+ einfo "Please read this ebuild for more details and re-emerge as needed"
+ einfo "if you want to add or remove functionality for ${PN}"
+ if ! has_version x11-misc/dmenu; then
+ elog "Installing ${PN} without x11-misc/dmenu"
+ einfo "To have a menu you can install x11-misc/dmenu"
+ fi
+ einfo "You can custom status bar with a script in HOME/.dwm/dwmrc"
+ einfo "the ouput is redirected to the standard input of dwm"
+}