summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTorsten Veller <tove@gentoo.org>2005-08-12 15:36:22 +0000
committerTorsten Veller <tove@gentoo.org>2005-08-12 15:36:22 +0000
commit88ebb32b264bf8143ad18f9ad87b044def87cce6 (patch)
tree938c1552004db13d31337a3cc8c9d14244fdfff1 /x11-wm/wmii/wmii-2.ebuild
parentStable on sparc (diff)
downloadgentoo-2-88ebb32b264bf8143ad18f9ad87b044def87cce6.tar.gz
gentoo-2-88ebb32b264bf8143ad18f9ad87b044def87cce6.tar.bz2
gentoo-2-88ebb32b264bf8143ad18f9ad87b044def87cce6.zip
Version bump.
(Portage version: 2.0.51.22-r2)
Diffstat (limited to 'x11-wm/wmii/wmii-2.ebuild')
-rw-r--r--x11-wm/wmii/wmii-2.ebuild67
1 files changed, 67 insertions, 0 deletions
diff --git a/x11-wm/wmii/wmii-2.ebuild b/x11-wm/wmii/wmii-2.ebuild
new file mode 100644
index 000000000000..626dcc4f0fa5
--- /dev/null
+++ b/x11-wm/wmii/wmii-2.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/wmii/wmii-2.ebuild,v 1.1 2005/08/12 15:36:22 tove Exp $
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="window manager improved 2 -- the next generation of the WMI project."
+HOMEPAGE="http://www.wmii.net"
+SRC_URI="http://wmi.modprobe.de/download/${P}.tar.bz2"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~x86"
+IUSE="python"
+
+DEPEND="virtual/x11
+ python? ( dev-python/pyrex )"
+
+src_unpack() {
+ unpack "${A}"
+ cd ${S}
+
+ epatch "${FILESDIR}/${P}_050802.patch"
+
+ sed -i \
+ -e "/^PREFIX/s/=.*/= \/usr/" \
+ -e "/^CONFPREFIX/s/=.*/= \/etc/" \
+ -e "/^CC/s/=.*/= $(tc-getCC)/" \
+ -e "/^AR/s/=.*/= $(tc-getAR) cr/" \
+ -e "/^RANLIB/s/=.*/= $(tc-getRANLIB)/" \
+ -e "/^CFLAGS/s/-O0/${CFLAGS}/" \
+ -e "/^LDFLAGS/s/-g /-g ${LDFLAGS} /" \
+ "${S}/config.mk" || die "sed failed."
+}
+
+src_compile() {
+ emake || die "emake failed"
+
+ if useq python ; then
+ cd "${S}"/libixp/python
+ python setup.py build || die "python build failed."
+ fi
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "make install failed."
+
+ dodoc ANNOUNCE || die "ANNOUNCE failed." # only in releases
+ dodoc CHANGES README LICENSE doc/welcome.txt || die "dodoc failed."
+
+ if useq python ; then
+ cd "${S}"/libixp/python
+ python setup.py install --root="${D}" || die "python install failed."
+ fi
+
+# insinto /usr/share/"${PN}"/contrib
+# doins "${S}"/contrib/README || die "contrib README failed."
+# exeinto /usr/share/"${PN}"/contrib
+# doexe "${S}"/contrib/*.py || die "contrib failed."
+
+ echo -e "#!/bin/sh\n/usr/bin/wmii" > "${T}/${PN}"
+ exeinto /etc/X11/Sessions
+ doexe "${T}/${PN}" || die "/etc/X11/Sessions failed."
+
+ insinto /usr/share/xsessions
+ doins "${FILESDIR}/${PN}.desktop" || die "${PN}.desktop failed."
+}