summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPetteri Räty <betelgeuse@gentoo.org>2009-09-07 20:36:20 +0000
committerPetteri Räty <betelgeuse@gentoo.org>2009-09-07 20:36:20 +0000
commitfa93a956849b592507f4d3470a87ae4ae0c79fc0 (patch)
tree82019ae3064b813f58a86667858ffe82ec78c3b7 /x11-wm/stumpwm
parentBump (diff)
downloadgentoo-2-fa93a956849b592507f4d3470a87ae4ae0c79fc0.tar.gz
gentoo-2-fa93a956849b592507f4d3470a87ae4ae0c79fc0.tar.bz2
gentoo-2-fa93a956849b592507f4d3470a87ae4ae0c79fc0.zip
Migrate to EAPI 2 in order to get rid of built_with_use.
(Portage version: 2.2_rc40/cvs/Linux i686)
Diffstat (limited to 'x11-wm/stumpwm')
-rw-r--r--x11-wm/stumpwm/ChangeLog5
-rw-r--r--x11-wm/stumpwm/stumpwm-0.9.2.ebuild27
2 files changed, 12 insertions, 20 deletions
diff --git a/x11-wm/stumpwm/ChangeLog b/x11-wm/stumpwm/ChangeLog
index 32806b833a29..e9dd69264324 100644
--- a/x11-wm/stumpwm/ChangeLog
+++ b/x11-wm/stumpwm/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for x11-wm/stumpwm
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/stumpwm/ChangeLog,v 1.3 2009/07/26 19:17:55 bangert Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/stumpwm/ChangeLog,v 1.4 2009/09/07 20:36:20 betelgeuse Exp $
+
+ 07 Sep 2009; Petteri Räty <betelgeuse@gentoo.org> stumpwm-0.9.2.ebuild:
+ Migrate to EAPI 2 in order to get rid of built_with_use.
26 Jul 2009; Thilo Bangert <bangert@gentoo.org> metadata.xml:
add <herd> tag
diff --git a/x11-wm/stumpwm/stumpwm-0.9.2.ebuild b/x11-wm/stumpwm/stumpwm-0.9.2.ebuild
index 453d3101de5a..404696d36fef 100644
--- a/x11-wm/stumpwm/stumpwm-0.9.2.ebuild
+++ b/x11-wm/stumpwm/stumpwm-0.9.2.ebuild
@@ -1,6 +1,8 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/stumpwm/stumpwm-0.9.2.ebuild,v 1.1 2008/05/04 01:32:30 jmglov Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/stumpwm/stumpwm-0.9.2.ebuild,v 1.2 2009/09/07 20:36:20 betelgeuse Exp $
+
+EAPI="2"
inherit common-lisp eutils
@@ -24,34 +26,21 @@ DEPEND="dev-lisp/common-lisp-controller
RDEPEND="${DEPEND}
emacs? ( app-emacs/slime )
!clisp? ( !sbcl? ( !amd64? ( dev-lisp/cmucl ) ) )
- clisp? ( >=dev-lisp/clisp-2.38-r2 )
+ clisp? ( >=dev-lisp/clisp-2.38-r2[X,-new-clx] )
sbcl? ( dev-lisp/sbcl dev-lisp/cl-clx )"
-pkg_setup() {
- if use clisp; then
- if built_with_use dev-lisp/clisp X; then
- if built_with_use dev-lisp/clisp new-clx; then
- while read line; do ewarn "$line"; done <<'EOF'
-CLISP needs MIT-CLX support built-in to work with StumpWM. Your CLISP
-has been built with support for NEW-CLX which may not work properly
-with StumpWM. Emerge dev-lisp/clisp with "X -new-clx" in USE.
-EOF
- fi
- else
- die "You need to build dev-lisp/clisp with USE='X -new-clx'"
- fi
- fi
+src_configure() {
+ sed "s,@PACKAGE_VERSION@,$PV,g" version.lisp.in > version.lisp
}
src_compile() {
- sed "s,@PACKAGE_VERSION@,$PV,g" version.lisp.in > version.lisp
use doc && makeinfo stumpwm.texi
}
src_install() {
common-lisp-install *.lisp stumpwm.asd
common-lisp-system-symlink
- dodoc README NEWS ChangeLog "${FILESDIR}/README.Gentoo"
+ dodoc README NEWS ChangeLog "${FILESDIR}/README.Gentoo" || die
use doc && doinfo stumpwm.info
}