summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Robbins <drobbins@gentoo.org>2001-12-18 00:45:55 +0000
committerDaniel Robbins <drobbins@gentoo.org>2001-12-18 00:45:55 +0000
commite57ec8b5a30daac46f271399ee7cbd137766dab4 (patch)
tree1efd90bc3c58c1eda888acea4702b2ad61369605 /x11-wm/pwm
parentfix if ssl not in USE (diff)
downloadgentoo-2-e57ec8b5a30daac46f271399ee7cbd137766dab4.tar.gz
gentoo-2-e57ec8b5a30daac46f271399ee7cbd137766dab4.tar.bz2
gentoo-2-e57ec8b5a30daac46f271399ee7cbd137766dab4.zip
New version of the incredible pwm
Diffstat (limited to 'x11-wm/pwm')
-rw-r--r--x11-wm/pwm/files/digest-pwm-1.0.200103091
-rw-r--r--x11-wm/pwm/pwm-1.0.20010309.ebuild53
2 files changed, 54 insertions, 0 deletions
diff --git a/x11-wm/pwm/files/digest-pwm-1.0.20010309 b/x11-wm/pwm/files/digest-pwm-1.0.20010309
new file mode 100644
index 000000000000..644345c7f11b
--- /dev/null
+++ b/x11-wm/pwm/files/digest-pwm-1.0.20010309
@@ -0,0 +1 @@
+MD5 2d5e5c33020c97edd85c4e0b47930e00 pwm-20010309.tar.gz 102400
diff --git a/x11-wm/pwm/pwm-1.0.20010309.ebuild b/x11-wm/pwm/pwm-1.0.20010309.ebuild
new file mode 100644
index 000000000000..023db06f6c54
--- /dev/null
+++ b/x11-wm/pwm/pwm-1.0.20010309.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Maintainer: Daniel Robbins <drobbins@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/pwm/pwm-1.0.20010309.ebuild,v 1.1 2001/12/18 00:45:55 drobbins Exp $
+
+NPV=20010309
+S=${WORKDIR}/pwm-${NPV}
+DESCRIPTION="A lightweight window manager"
+SRC_URI="http://www.students.tut.fi/~tuomov/dl/pwm-${NPV}.tar.gz"
+HOMEPAGE="http://www.students.tut.fi/~tuomov/pwm"
+
+DEPEND="virtual/x11"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ cp Makefile Makefile.orig
+ sed -e "s:\$(DOCDIR)/pwm:\$(DOCDIR)/${PF}:g" \
+ -e "s:^MANDIR=.*$::" \
+ -e "s:^DOCDIR=.*$::" \
+ -e "s:^ETCDIR=.*$::" \
+ Makefile.orig >Makefile
+ cp system.mk system.orig
+ sed -e "s:-g -O2:${CFLAGS}:" \
+ -e 's:\$(WARN)::' \
+ system.orig >system.mk
+ cp config.h config.orig
+ sed -e "s:^#define CF_SYS_CONFIG_LOCATION.*$:#define CF_SYS_CONFIG_LOCATION \"/etc/X11/pwm/\":" \
+ config.orig >config.h
+}
+
+src_compile() {
+ emake PREFIX=/usr \
+ MANDIR=/usr/share/man/man1 \
+ DOCDIR=/usr/share/doc \
+ ETCDIR=/etc/X11 \
+ || die
+}
+
+src_install() {
+ make PREFIX=${D}/usr \
+ MANDIR=${D}/usr/share/man/man1 \
+ DOCDIR=${D}/usr/share/doc \
+ ETCDIR=${D}/etc/X11 \
+ install || die
+
+ if [ "`use gnome`" ]
+ then
+ insinto /usr/share/gnome/wm-properties
+ doins support/PWM.desktop
+ fi
+ dodoc ChangeLog README
+}