summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHanno Böck <hanno@gentoo.org>2004-02-03 15:41:57 +0000
committerHanno Böck <hanno@gentoo.org>2004-02-03 15:41:57 +0000
commit5a9945aec296b6c5387c256d51315ad4b91dcd8c (patch)
treeb21d20346097e8fa71716c0fbad8affd55509d60 /x11-wm/icewm
parentMarked stable on hppa. (diff)
downloadgentoo-2-5a9945aec296b6c5387c256d51315ad4b91dcd8c.tar.gz
gentoo-2-5a9945aec296b6c5387c256d51315ad4b91dcd8c.tar.bz2
gentoo-2-5a9945aec296b6c5387c256d51315ad4b91dcd8c.zip
icewm version bump.
Diffstat (limited to 'x11-wm/icewm')
-rw-r--r--x11-wm/icewm/ChangeLog7
-rw-r--r--x11-wm/icewm/files/digest-icewm-1.2.14_pre91
-rw-r--r--x11-wm/icewm/icewm-1.2.14_pre9.ebuild79
3 files changed, 86 insertions, 1 deletions
diff --git a/x11-wm/icewm/ChangeLog b/x11-wm/icewm/ChangeLog
index a29092c5eeca..bb901154d261 100644
--- a/x11-wm/icewm/ChangeLog
+++ b/x11-wm/icewm/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-wm/icewm
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/icewm/ChangeLog,v 1.41 2004/02/02 20:30:13 bcowan Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/icewm/ChangeLog,v 1.42 2004/02/03 15:41:57 hanno Exp $
+
+*icewm-1.2.14_pre9 (03 Feb 2004)
+
+ 03 Feb 2004; Hanno Boeck <hanno@gentoo.org> icewm-1.2.14_pre9.ebuild:
+ Version bump.
02 Feb 2004; Brad Cowan <bcowan@gentoo.org> icewm-1.2.14_pre7.ebuild:
Added support for xinerama flag. Thanks to James Le Cuirot <chewi@ffaura.com>.
diff --git a/x11-wm/icewm/files/digest-icewm-1.2.14_pre9 b/x11-wm/icewm/files/digest-icewm-1.2.14_pre9
new file mode 100644
index 000000000000..cd21daaf8403
--- /dev/null
+++ b/x11-wm/icewm/files/digest-icewm-1.2.14_pre9
@@ -0,0 +1 @@
+MD5 b28db6d83f44d1b440fdae6657970eda icewm-1.2.14pre9.tar.gz 915495
diff --git a/x11-wm/icewm/icewm-1.2.14_pre9.ebuild b/x11-wm/icewm/icewm-1.2.14_pre9.ebuild
new file mode 100644
index 000000000000..833cd9f7baed
--- /dev/null
+++ b/x11-wm/icewm/icewm-1.2.14_pre9.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/icewm/icewm-1.2.14_pre9.ebuild,v 1.1 2004/02/03 15:41:57 hanno Exp $
+
+DESCRIPTION="Ice Window Manager"
+SRC_URI="mirror://sourceforge/${PN}/${P/_}.tar.gz"
+HOMEPAGE="http://www.icewm.org"
+IUSE="esd gnome imlib nls spell truetype xinerama"
+
+DEPEND="virtual/x11
+ esd? ( media-sound/esound )
+ gnome? ( gnome-base/gnome-libs gnome-base/gnome-desktop )
+ imlib? ( >=media-libs/imlib-1.9.10-r1 )
+ nls? ( sys-devel/gettext )
+ truetype? ( >=media-libs/freetype-2.0.9 )"
+
+RDEPEND="${DEPEND}
+ media-fonts/artwiz-fonts"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~ppc ~sparc"
+S=${WORKDIR}/${P/_}
+
+src_compile(){
+ use esd \
+ && myconf="${myconf} --with-esd-config=/usr/bin/esd-config"
+
+ use nls \
+ && myconf="${myconf} --enable-nls --enable-i18n" \
+ || myconf="${myconf} --disable-nls --disable-i18n"
+
+ use imlib \
+ && myconf="${myconf} --with-imlib --without-xpm" \
+ || myconf="${myconf} --without-imlib --with-xpm"
+
+ use spell \
+ && myconf="${myconf} --enable-GtkSpell" \
+ || myconf="${myconf} --disable-GtkSpell"
+
+ use truetype \
+ && myconf="${myconf} --enable-gradients --enable-shape --enable-movesize-fx --enable-shaped-decorations" \
+ || myconf="${myconf} --disable-xfreetype"
+
+ use x86 \
+ && myconf="${myconf} --enable-x86-asm" \
+ || myconf="${myconf} --disable-x86-asm"
+
+ use gnome \
+ && myconf="${myconf} --enable-menus-gnome2 --enable-menus-gnome1" \
+ || myconf="${myconf} --disable-menus-gnome2 --disable-menus-gnome1"
+
+ use xinerama \
+ && myconf="${myconf} --enable-xinerama" \
+ || myconf="${myconf} --disable-xinerama"
+
+ CXXFLAGS="${CXXFLAGS}" econf \
+ --with-libdir=/usr/share/icewm \
+ --with-cfgdir=/etc/icewm \
+ --with-docdir=/usr/share/doc/${PF}/html \
+ ${myconf} || die "configure failed"
+ cd src
+ sed -i "s:/icewm-\$(VERSION)::" Makefile || die "patch failed"
+ cd ${S}
+
+ emake || die "emake failed"
+}
+
+src_install(){
+ make DESTDIR=${D} install || die
+
+ dodoc AUTHORS BUGS CHANGES COPYING FAQ PLATFORMS README* TODO VERSION
+ dohtml -a html,sgml doc/*
+
+ echo "#!/bin/bash" > icewm
+ echo "/usr/bin/icewm-session" >> icewm
+ exeinto /etc/X11/Sessions
+ doexe icewm
+}