summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2012-02-17 01:32:21 +0000
committerJohannes Huber <johu@gentoo.org>2012-02-17 01:32:21 +0000
commitde5dc7ece09ca429ec57d4970fe372f4bf73ed59 (patch)
tree75ebf8e58596ca5348804c8c42f4bea1082d8c14 /x11-themes/oxygen-gtk
parentRemove old. (diff)
downloadgentoo-2-de5dc7ece09ca429ec57d4970fe372f4bf73ed59.tar.gz
gentoo-2-de5dc7ece09ca429ec57d4970fe372f4bf73ed59.tar.bz2
gentoo-2-de5dc7ece09ca429ec57d4970fe372f4bf73ed59.zip
Version bump, for slot 3.
(Portage version: 2.2.0_alpha86/cvs/Linux i686)
Diffstat (limited to 'x11-themes/oxygen-gtk')
-rw-r--r--x11-themes/oxygen-gtk/ChangeLog7
-rw-r--r--x11-themes/oxygen-gtk/oxygen-gtk-1.0.1.ebuild50
2 files changed, 56 insertions, 1 deletions
diff --git a/x11-themes/oxygen-gtk/ChangeLog b/x11-themes/oxygen-gtk/ChangeLog
index f32c7cfb02b3..41164dcc13f2 100644
--- a/x11-themes/oxygen-gtk/ChangeLog
+++ b/x11-themes/oxygen-gtk/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-themes/oxygen-gtk
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-themes/oxygen-gtk/ChangeLog,v 1.26 2012/02/17 00:04:31 johu Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-themes/oxygen-gtk/ChangeLog,v 1.27 2012/02/17 01:32:21 johu Exp $
+
+*oxygen-gtk-1.0.1 (17 Feb 2012)
+
+ 17 Feb 2012; Johannes Huber <johu@gentoo.org> +oxygen-gtk-1.0.1.ebuild:
+ Version bump, for slot 3.
*oxygen-gtk-1.2.1 (17 Feb 2012)
diff --git a/x11-themes/oxygen-gtk/oxygen-gtk-1.0.1.ebuild b/x11-themes/oxygen-gtk/oxygen-gtk-1.0.1.ebuild
new file mode 100644
index 000000000000..fa1083e3fc4e
--- /dev/null
+++ b/x11-themes/oxygen-gtk/oxygen-gtk-1.0.1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-themes/oxygen-gtk/oxygen-gtk-1.0.1.ebuild,v 1.3 2012/02/17 01:32:21 johu Exp $
+
+EAPI=4
+
+MY_PN=${PN}3
+MY_P=${MY_PN}-${PV}
+
+inherit cmake-utils
+
+DESCRIPTION="Official GTK+:2 port of KDE's Oxygen widget style"
+HOMEPAGE="https://projects.kde.org/projects/playground/artwork/oxygen-gtk"
+SRC_URI="mirror://kde/stable/${MY_PN}/${PV}/src/${MY_P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+KEYWORDS="~amd64 ~x86"
+SLOT="3"
+IUSE="debug doc"
+
+RDEPEND="
+ !x11-themes/oxygen-gtk:0
+ dev-libs/dbus-glib
+ dev-libs/glib
+ x11-libs/cairo
+ x11-libs/gtk+:3
+ x11-libs/libX11
+"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ doc? ( app-doc/doxygen )
+"
+
+DOCS=(AUTHORS README)
+
+S="${WORKDIR}/${MY_P}"
+
+src_install() {
+ if use doc; then
+ { cd "${S}" && doxygen Doxyfile; } || die "Generating documentation failed"
+ HTML_DOCS=( "${S}/doc/html/" )
+ fi
+
+ cmake-utils_src_install
+
+ cat <<-EOF > 99oxygen-gtk3
+CONFIG_PROTECT="${EPREFIX}/usr/share/themes/oxygen-gtk/gtk-3.0"
+EOF
+ doenvd 99oxygen-gtk3
+}