summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKrzysztof Pawlik <nelchael@gentoo.org>2006-10-04 19:03:54 +0000
committerKrzysztof Pawlik <nelchael@gentoo.org>2006-10-04 19:03:54 +0000
commitf4317fc578a61c6b73b3d33a4207238c50d61a77 (patch)
tree875ffb0ac3e99f2efda2d6c97c2de7a93492a5ec /x11-terms
parentInitial import, thanks to Alessio Cassibba and guitoo (diff)
downloadgentoo-2-f4317fc578a61c6b73b3d33a4207238c50d61a77.tar.gz
gentoo-2-f4317fc578a61c6b73b3d33a4207238c50d61a77.tar.bz2
gentoo-2-f4317fc578a61c6b73b3d33a4207238c50d61a77.zip
Version bump, see bug #149864.
(Portage version: 2.1.2_pre2-r2)
Diffstat (limited to 'x11-terms')
-rw-r--r--x11-terms/mrxvt/ChangeLog7
-rw-r--r--x11-terms/mrxvt/files/digest-mrxvt-0.5.23
-rw-r--r--x11-terms/mrxvt/mrxvt-0.5.2.ebuild106
3 files changed, 115 insertions, 1 deletions
diff --git a/x11-terms/mrxvt/ChangeLog b/x11-terms/mrxvt/ChangeLog
index e376de413503..b64c3cb20603 100644
--- a/x11-terms/mrxvt/ChangeLog
+++ b/x11-terms/mrxvt/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-terms/mrxvt
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-terms/mrxvt/ChangeLog,v 1.44 2006/07/09 09:31:43 nelchael Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-terms/mrxvt/ChangeLog,v 1.45 2006/10/04 19:03:54 nelchael Exp $
+
+*mrxvt-0.5.2 (04 Oct 2006)
+
+ 04 Oct 2006; Krzysiek Pawlik <nelchael@gentoo.org> +mrxvt-0.5.2.ebuild:
+ Version bump, see bug #149864.
09 Jul 2006; Krzysiek Pawlik <nelchael@gentoo.org>
-files/mrxvt-0.3.13-xdefaults.patch, -files/noflicker-0.4.2.patch,
diff --git a/x11-terms/mrxvt/files/digest-mrxvt-0.5.2 b/x11-terms/mrxvt/files/digest-mrxvt-0.5.2
new file mode 100644
index 000000000000..94336a176216
--- /dev/null
+++ b/x11-terms/mrxvt/files/digest-mrxvt-0.5.2
@@ -0,0 +1,3 @@
+MD5 ed87b7dd9f4fb482de0f14f085085027 mrxvt-0.5.2.tar.gz 559242
+RMD160 85ccf709be85dc91374b1c6c893059155ab5c26f mrxvt-0.5.2.tar.gz 559242
+SHA256 558491d1f112362780abaf7429d14216e658b7768dd30f82f102ce646d3065cf mrxvt-0.5.2.tar.gz 559242
diff --git a/x11-terms/mrxvt/mrxvt-0.5.2.ebuild b/x11-terms/mrxvt/mrxvt-0.5.2.ebuild
new file mode 100644
index 000000000000..f9188f82ccd7
--- /dev/null
+++ b/x11-terms/mrxvt/mrxvt-0.5.2.ebuild
@@ -0,0 +1,106 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-terms/mrxvt/mrxvt-0.5.2.ebuild,v 1.1 2006/10/04 19:03:54 nelchael Exp $
+
+inherit eutils
+
+IUSE="debug png jpeg session truetype menubar"
+
+DESCRIPTION="Multi-tabbed rxvt clone with XFT, transparent background and CJK support"
+HOMEPAGE="http://materm.sourceforge.net/"
+SRC_URI="mirror://sourceforge/materm/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~mips ~ppc ~ppc-macos ~x86"
+
+RDEPEND="png? ( media-libs/libpng )
+ jpeg? ( media-libs/jpeg )
+ truetype? ( virtual/xft
+ media-libs/fontconfig
+ media-libs/freetype )
+ || ( (
+ x11-libs/libX11
+ x11-libs/libXt
+ x11-libs/libXpm
+ x11-libs/libXrender )
+ virtual/x11 )"
+
+DEPEND="${RDEPEND}
+ || ( x11-proto/xproto virtual/x11 )"
+
+src_compile() {
+
+ local myconf
+
+ # if you want to pass any other flags, use EXTRA_ECONF.
+ if use linguas_el ; then
+ myconf="${myconf} --enable-greek"
+ fi
+ if use linguas_ja ; then
+ # --with-encoding=sjis
+ myconf="${myconf} --enable-kanji --with-encoding=eucj"
+ fi
+ if use linguas_ko ; then
+ myconf="${myconf} --enable-kr --with-encoding=kr"
+ fi
+ if use linguas_th ; then
+ myconf="${myconf} --enable-thai"
+ fi
+ if use linguas_zh_CN ; then
+ # --with-encoding=gbk
+ myconf="${myconf} --enable-gb --with-encoding=gb"
+ fi
+ if use linguas_zh_TW ; then
+ myconf="${myconf} --enable-big5 --with-encoding=big5"
+ fi
+
+ # 2006-03-13 gi1242: mrxvt works best with TERM=rxvt AND correctly set
+ # termcap / terminfo entries. If the rxvt termcap / terminfo entries are
+ # messed up then then it's better to set TERM=xterm.
+ #
+ # Provide support for this by setting the or RXVT_TERM environment variables
+ # before emerging, as done in the rxvt ebuild.
+
+ if [[ -n ${RXVT_TERM} ]]; then
+ myconf="${myconf} --with-term=${RXVT_TERM}"
+ fi
+
+ econf \
+ --enable-everything \
+ $(use_enable debug) \
+ $(use_enable png) \
+ $(use_enable jpeg) \
+ $(use_enable session sessionmgr) \
+ $(use_enable truetype xft) \
+ $(use_enable menubar) \
+ ${myconf} || die
+
+ emake || die
+
+}
+
+src_install() {
+
+ make DESTDIR=${D} docdir=/usr/share/doc/${PF} install || die
+ dodoc AUTHORS CREDITS ChangeLog FAQ NEWS README* TODO
+
+}
+
+pkg_postinst() {
+
+ if [[ -z $RXVT_TERM ]]; then
+ einfo
+ einfo "If you experience problems with curses programs, then this is"
+ einfo "most likely because of incorrectly set termcap / terminfo"
+ einfo "entries. If you are unsure how to fix them, then you can try"
+ einfo "setting TERM=xterm."
+ einfo
+ einfo "To emerge mrxvt with TERM=xterm by default, set the RXVT_TERM"
+ einfo "environment variable to 'xterm', or your desired default"
+ einfo "terminal name. Alternately you can put 'Mrxvt.termName: xterm'"
+ einfo "in your ~/.mrxvtrc, or /etc/mrxvt/mrxvtrc."
+ einfo
+ fi
+
+}