summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2010-03-31 06:20:08 +0000
committerJustin Lecher <jlec@gentoo.org>2010-03-31 06:20:08 +0000
commite26e8e7a3985d04b5057d921ca40c831782792a1 (patch)
treec5ebf0e3bb75fe5ed8bc73d74e3c684def7a60f8 /x11-terms
parentVersion bump for dev channel release. Remove old. (diff)
downloadgentoo-2-e26e8e7a3985d04b5057d921ca40c831782792a1.tar.gz
gentoo-2-e26e8e7a3985d04b5057d921ca40c831782792a1.tar.bz2
gentoo-2-e26e8e7a3985d04b5057d921ca40c831782792a1.zip
Import from sunrise, #213243
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'x11-terms')
-rw-r--r--x11-terms/terminator/ChangeLog11
-rw-r--r--x11-terms/terminator/files/0.90-without-icon-cache.patch11
-rw-r--r--x11-terms/terminator/metadata.xml14
-rw-r--r--x11-terms/terminator/terminator-0.90.ebuild29
4 files changed, 65 insertions, 0 deletions
diff --git a/x11-terms/terminator/ChangeLog b/x11-terms/terminator/ChangeLog
new file mode 100644
index 000000000000..e68647441430
--- /dev/null
+++ b/x11-terms/terminator/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for x11-terms/terminator
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-terms/terminator/ChangeLog,v 1.1 2010/03/31 06:20:08 jlec Exp $
+
+*terminator-0.90 (31 Mar 2010)
+
+ 31 Mar 2010; Justin Lecher <jlec@gentoo.org>
+ +files/0.90-without-icon-cache.patch, +terminator-0.90.ebuild,
+ +metadata.xml:
+ Import from sunrise, #213243
+
diff --git a/x11-terms/terminator/files/0.90-without-icon-cache.patch b/x11-terms/terminator/files/0.90-without-icon-cache.patch
new file mode 100644
index 000000000000..c7862def3eaa
--- /dev/null
+++ b/x11-terms/terminator/files/0.90-without-icon-cache.patch
@@ -0,0 +1,11 @@
+--- setup.py.orig 2009-08-12 22:22:53.000000000 -0400
++++ setup.py 2009-08-12 22:22:57.000000000 -0400
+@@ -25,7 +25,7 @@
+
+ def __init__ (self, *args):
+ self.without_gettext = False
+- self.without_icon_cache = False
++ self.without_icon_cache = True
+ Distribution.__init__(self, *args)
+
+
diff --git a/x11-terms/terminator/metadata.xml b/x11-terms/terminator/metadata.xml
new file mode 100644
index 000000000000..180fb04e9c86
--- /dev/null
+++ b/x11-terms/terminator/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<pkgmetadata>
+<herd>gnome</herd>
+<maintainer>
+ <email>jlec@gentoo.org</email>
+</maintainer>
+<longdescription>
+ Much of the behaviour of Terminator is based on GNOME Terminal, and
+ we are adding more features from that as time goes by, but we also
+ want to extend out in different directions with useful features for
+ sysadmins and other users. If you have any suggestions, please file
+ wishlist bugs! (see below for the address)
+</longdescription>
+</pkgmetadata>
diff --git a/x11-terms/terminator/terminator-0.90.ebuild b/x11-terms/terminator/terminator-0.90.ebuild
new file mode 100644
index 000000000000..622dfbbb1bd6
--- /dev/null
+++ b/x11-terms/terminator/terminator-0.90.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-terms/terminator/terminator-0.90.ebuild,v 1.1 2010/03/31 06:20:08 jlec Exp $
+
+EAPI="2"
+
+PYTHON_DEPEND="2"
+PYTHON_MODNAME="terminatorlib"
+
+inherit distutils eutils
+
+DESCRIPTION="Multiple GNOME terminals in one window"
+HOMEPAGE="http://www.tenshu.net/terminator/"
+SRC_URI="http://launchpad.net/${PN}/trunk/${PV}/+download/${PN}_${PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="gnome"
+
+RDEPEND="
+ gnome? ( dev-python/gnome-python )
+ >=x11-libs/vte-0.16[python]"
+DEPEND=""
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PV}-without-icon-cache.patch
+ distutils_src_prepare
+}